Bug 55571 - https authentication through proxy fails
Summary: https authentication through proxy fails
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: http (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-05 20:22 UTC by Darius Ivanauskas
Modified: 2003-03-17 15:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darius Ivanauskas 2003-03-05 20:22:36 UTC
Version:            (using KDE KDE 3.1)
Installed from:    Debian testing/unstable Packages
OS:          Linux

Setup manually a valid proxy in your enviroment for https.
Go to the https site wich requires basic authentication.
enter username and password. Konqueror will fail to conect.
You can now hit 'stop' and 'refresh' - if the authentication information was entered correctly the page will load. The problem is, that the konqueror forgets to send 'CONNECT' request for the proxy on authentication submit. Instead of that it starts to send SSL encrypted data. So the proxy does't know what to to do with such packets.
it was tested with squid, tiny proxy and home-brew proxy :) It seems that 3.0.x series konqueror works well with this. Only 3.1 fails.
Comment 1 Waldo Bastian 2003-03-14 23:25:55 UTC
Can you enable debug area 7113 and log what it says in this situation? 
See  
http://webcvs.kde.org/cgi-bin/cvsweb.cgi/kdebase/kioslave/DEBUG.howto?rev=1.2&content-type=text/x-cvsweb-markup 
for instructions how to do that. 
Comment 2 Waldo Bastian 2003-03-17 15:20:37 UTC
Subject: KDE_3_1_BRANCH: kdelibs/kioslave/http

CVS commit by waba: 

CCMAIL: 55571-done@bugs.kde.org
Fix Bug 55571: https authentication through proxy fails

(This patch basically reverts r1.546 and r1.544)
m_bNeedTunnel was incorrectly used to check whether we were busy connecting 
to a proxy or sending the actual request. Moved some code around so that it 
only gets executed when sending the actual request so that it isn't necassery
any more to abuse m_bNeedTunnel for this.

The resetting of m_bNeedTunnel caused bug 55571, it isn't necassery to reset
it, the resetting was a poor attempt to let m_bNeedTunnel serve as a status
indicator for something it wasn't intended to indicate.


  M +112 -112  http.cc   1.551.2.9