Bug 54668 - New windows are drawn above open menus
Summary: New windows are drawn above open menus
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-15 11:20 UTC by Olaf Jan Schmidt
Modified: 2003-05-12 14:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Jan Schmidt 2003-02-15 11:20:15 UTC
Version:            (using KDE KDE 3.1)
Installed from:    SuSE RPMs
OS:          Linux

When new windows open while menus are open, the windows are drawn above the menu, hiding its content, but the mouse clicks are still interpreted as click into the menu.

This is a big problem as you do not know that the menu is still open in the background, and you do not know which action will be performed if you click into the new window.

The problem is easily reproducable by opening several windows through quickbrowsers or through the knewsticker menu - Konqueror needs some time for accessing the referenced news pages, and if I reopen the knewsticker menu in between, it looks as if the menu is closed once the new Konqueror window appears, but in fact it is still open and all mouse clicks are interpreted as clicks into the (now hidden) menu.

The bug exists at least since KDE 3.0, but I failed to report it before.
Comment 1 Lubos Lunak 2003-03-18 19:36:47 UTC
I can reproduce the problem with SuSE KDE3.1 RPMS too, but I'm unable to reproduce it with 
my development version of KDE, both with HEAD kwin and kwin_iii. My personal guess is that 
this has been fixed in Qt-3.1.2. Please check again after upgrading to this Qt version. 
 
Comment 2 Olaf Jan Schmidt 2003-04-16 20:51:20 UTC
The problem was also present on a self-compiled KDE (3.0 branch). In the meantime I 
upgraded to KDE 3.1.1a and Qt 3.1.2. The problem still exists. 
Comment 3 Lubos Lunak 2003-05-12 14:56:02 UTC
Should not happen anymore in KDE3.1.3.