Bug 54550 - Crashes in Detailed listview.
Summary: Crashes in Detailed listview.
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-12 17:42 UTC by Thomas Fjellstrom
Modified: 2003-11-02 23:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Fjellstrom 2003-02-12 17:42:17 UTC
Version:            (using KDE KDE 3.1)
Installed from:    Compiled From Sources
Compiler:          GCC 3.2.2 
OS:          Linux

When konqueror is still filling in the Detaile listview info, Konqueror will crash if you stop it, ie: by pressing back, up, or refreshing the view repeatedly (pressing F5 fast...)..

heres a trace from a crash caused by pressing F5 fast:

0x40f7aa39 in wait4 () from /lib/libc.so.6
#0  0x40f7aa39 in wait4 () from /lib/libc.so.6
#1  0x40fedbc0 in sys_sigabbrev () from /lib/libc.so.6
#2  0x40db5061 in waitpid () from /lib/libpthread.so.0
#3  0x4059efff in KCrash::defaultCrashHandler(int) ()
   from /home/moose/kde3.1/lib/libkdecore.so.4
#4  0x40f07898 in sigaction () from /lib/libc.so.6
#5  0x405a1949 in operator<<(QDataStream&, KURL const&) ()
   from /home/moose/kde3.1/lib/libkdecore.so.4
#6  0x40134378 in KIO::get(KURL const&, bool, bool) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#7  0x401d692b in KIO::MetaInfoJob::getMetaInfo() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#8  0x401d67d1 in KIO::MetaInfoJob::determineNextFile() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#9  0x401d680f in KIO::MetaInfoJob::slotResult(KIO::Job*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#10 0x401d6247 in KIO::MetaInfoJob::qt_invoke(int, QUObject*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#11 0x408faefe in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#12 0x40142232 in KIO::Job::result(KIO::Job*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#13 0x40130142 in KIO::Job::emitResult() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#14 0x401313e7 in KIO::SimpleJob::slotFinished() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#15 0x40133865 in KIO::TransferJob::slotFinished() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#16 0x4014355c in KIO::TransferJob::qt_invoke(int, QUObject*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#17 0x408faefe in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#18 0x408fadbb in QObject::activate_signal(int) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#19 0x401277dc in KIO::SlaveInterface::finished() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#20 0x401267fb in KIO::SlaveInterface::dispatch(int, QMemArray<char> const&) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#21 0x40125f11 in KIO::SlaveInterface::dispatch() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#22 0x40123f34 in KIO::Slave::gotInput() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#23 0x40125715 in KIO::Slave::qt_invoke(int, QUObject*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#24 0x408faefe in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#25 0x408fafaf in QObject::activate_signal(int, int) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#26 0x40b807c9 in QSocketNotifier::activated(int) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#27 0x40912fe4 in QSocketNotifier::event(QEvent*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#28 0x408a6e62 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#29 0x408a6aa3 in QApplication::notify(QObject*, QEvent*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#30 0x4053ee3c in KApplication::notify(QObject*, QEvent*) ()
   from /home/moose/kde3.1/lib/libkdecore.so.4
#31 0x40885230 in QEventLoop::activateSocketNotifiers() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#32 0x40866aa1 in QEventLoop::processEvents(unsigned) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#33 0x408b8403 in QEventLoop::enterLoop() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#34 0x408b82c0 in QEventLoop::exec() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#35 0x408a705c in QApplication::exec() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#36 0x412082eb in main () from /home/moose/kde3.1/lib/konqueror.so
#37 0x0804c908 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#38 0x0804d447 in handle_launcher_request(int) ()
#39 0x0804d8be in handle_requests(int) ()
#40 0x0804e481 in main ()
#41 0x40ef69f1 in __libc_start_main () from /lib/libc.so.6

And heres one from setting Detailed listmode on my home dir (250 or so files and directories) and pressing F5 to update the list (no extra info originally showed up...)

0x40f7aa39 in wait4 () from /lib/libc.so.6
#0  0x40f7aa39 in wait4 () from /lib/libc.so.6
#1  0x40fedbc0 in sys_sigabbrev () from /lib/libc.so.6
#2  0x40db5061 in waitpid () from /lib/libpthread.so.0
#3  0x4059efff in KCrash::defaultCrashHandler(int) ()
   from /home/moose/kde3.1/lib/libkdecore.so.4
#4  0x40f07898 in sigaction () from /lib/libc.so.6
#5  0x401dd906 in KFileMetaInfo::operator=(KFileMetaInfo const&) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#6  0x401bd4e6 in KFileItem::setMetaInfo(KFileMetaInfo const&) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#7  0x401d6aa9 in KIO::MetaInfoJob::slotMetaInfo(KIO::Job*, QMemArray<char> const&) () from /home/moose/kde3.1/lib/libkio.so.4
#8  0x401d6227 in KIO::MetaInfoJob::qt_invoke(int, QUObject*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#9  0x408faefe in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#10 0x401430e7 in KIO::TransferJob::data(KIO::Job*, QMemArray<char> const&) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#11 0x4013303f in KIO::TransferJob::slotData(QMemArray<char> const&) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#12 0x40143570 in KIO::TransferJob::qt_invoke(int, QUObject*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#13 0x408faefe in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#14 0x40127672 in KIO::SlaveInterface::data(QMemArray<char> const&) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#15 0x401261a7 in KIO::SlaveInterface::dispatch(int, QMemArray<char> const&) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#16 0x40125f11 in KIO::SlaveInterface::dispatch() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#17 0x40123f34 in KIO::Slave::gotInput() ()
   from /home/moose/kde3.1/lib/libkio.so.4
#18 0x40125715 in KIO::Slave::qt_invoke(int, QUObject*) ()
   from /home/moose/kde3.1/lib/libkio.so.4
#19 0x408faefe in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#20 0x408fafaf in QObject::activate_signal(int, int) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#21 0x40b807c9 in QSocketNotifier::activated(int) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#22 0x40912fe4 in QSocketNotifier::event(QEvent*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#23 0x408a6e62 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#24 0x408a6aa3 in QApplication::notify(QObject*, QEvent*) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#25 0x4053ee3c in KApplication::notify(QObject*, QEvent*) ()
   from /home/moose/kde3.1/lib/libkdecore.so.4
#26 0x40885230 in QEventLoop::activateSocketNotifiers() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#27 0x40866aa1 in QEventLoop::processEvents(unsigned) ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#28 0x408b8403 in QEventLoop::enterLoop() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#29 0x408b82c0 in QEventLoop::exec() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#30 0x408a705c in QApplication::exec() ()
   from /home/moose/kde3.1/lib/libqt-mt.so.3
#31 0x412082eb in main () from /home/moose/kde3.1/lib/konqueror.so
#32 0x0804c908 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#33 0x0804d447 in handle_launcher_request(int) ()
#34 0x0804d8be in handle_requests(int) ()
#35 0x0804e481 in main ()
#36 0x40ef69f1 in __libc_start_main () from /lib/libc.so.6
Comment 1 Tommi Tervo 2003-11-02 23:03:52 UTC
Works for me. If you still can get konqueror 3.1.4 crash, please reopen.