Bug 54359 - wrong top_left_corner and bottom_left_corner cursors
Summary: wrong top_left_corner and bottom_left_corner cursors
Status: RESOLVED NOT A BUG
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 53259 56790 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-02-09 18:59 UTC by Uri Shohet
Modified: 2003-06-15 04:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uri Shohet 2003-02-09 18:59:00 UTC
Version:           unknown (using KDE 3.1.9)
Compiler:          gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)
OS:          Linux (i686) release 2.4.18-19.8.0

Hi, 

I use XFree86 4.2.99.3 with Xcursor extension. Until couple of days ago I just used the default redglass cursor icon theme. Now, I installed "Red Dot Cursors" theme pack from http://www.kdelook.org/content/show.php?content=4805, patched qt-copy as described in the README and recompiled. Everything is fine except...
top_left_corner cursor looks exactly like bottom_right_corner (triangle pointing right and down) and bottom_left_corner looks exactly like top_right_corner (triangle pointing right and up). 

This problem is either QT's or kwin's, I don't know, but in metacity (GNOME's window manager) they look correctly.

Regards,

Uri Shohet
Comment 1 Fredrik Höglund 2003-02-09 22:19:05 UTC
The instructions provided with this cursor theme are incorrect. The patch you've 
applied tells Qt that when an application asks for the forward-diagonal arrow 
cursor it should give it the top-left-corner cursor instead, which is why this 
happens. 
 
You don't need to patch Qt or KDE for it to work with Xcursor. The X server has 
a built-in backwards compatibility mechanism that makes it work with existing 
applications without having to modify them. 
 
When an application creates a bitmap cursor, Xcursor computes a hash value 
from the bitmap and looks for that hash value in the cursor theme. 
 
So cursor theme authors only have to create those hash values as symlinks in 
the cursors directory for it to work. 
 
Here's the list of hash values needed for KDE and Qt to work with Xcursor: 
 
Arrow cursors: 
00008160000006810000408080010102 -> v_double_arrow 
028006030e0e7ebffc7f7070c0600140 -> h_double_arrow 
fcf1c3c7cd4491d801f1e1c78f100000 -> fd_double_arrow 
c7088f0f3e6c8088236ef8e1e3e70000 -> bd_double_arrow 
 
Split vertical/horizontal cursors: 
14fef782d02440884392942c11205230 -> sb_h_double_arrow 
2870a09082c103050810ffdffffe0204 -> sb_v_double_arrow 
 
Qt and KDE hand cursors: 
9d800788f1b08800ae810202380a0822 -> hand1 / hand2 
e29285e634086352946a0e7090d73106 -> hand1 / hand2 
 
DnD cursors: 
03b6e0fcb3499374a867c041f52298f0 -> crossed_circle (forbidden) 
4498f0e0c1937ffe01fd06f973665830 -> left_ptr (move cursor) 
6407b0e94181790501fd1e167b474872 -> copy 
640fb0e74195791501fd1ed57b41487f -> link 
 
Working and what's this cursors: 
3ecb610c1bf2410f44200f48c40d3599 -> left_ptr_watch 
d9ce0ab605698f320427677b458ad60b -> question_arrow 
 
Comment 2 hard edged 2003-02-11 11:37:04 UTC
Where are these:  
fd_double_arrow, bd_double_arrow, crossed_circle  
?  
They aren't included with xfree86 4.3 rc 1 (4.2.99.901) linux binary snapshot.  
  
The closest thing available to both fd_double_arrow and bd_double_arrow is 'sizing',  
but that doesn't look right. The only 'icons' (cursors) included that would work are  
in separate files (ll_angle, lr_angle, ul_angle, ur_angle or   
appropriately top_left_corner, top_right_corner, bottom_left_corner, bottom_right_corner).  
  
I don't see anything for crossed_circle, but I suppose 'target' is close enough?  
  
Are those three files just not in the binary snapshot release candidate or are they planned to  
be? If not, either some new icon-cursors need be made or qt/kde changes.  
  
Am I missing something?  
  
Comment 3 mikael goransson 2003-03-13 13:41:50 UTC
hmm, and how do you get these hash values ? 
i'm using whiteglass with kde 3.1 
 
Comment 4 Maksim Orlovich 2003-04-05 03:02:08 UTC
*** Bug 56790 has been marked as a duplicate of this bug. ***
Comment 5 Maksim Orlovich 2003-06-15 04:40:03 UTC
*** Bug 53259 has been marked as a duplicate of this bug. ***