Bug 53178 - Remember the msgs for which we explicitly allow HTML rendering
Summary: Remember the msgs for which we explicitly allow HTML rendering
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.9.3
Platform: unspecified Linux
: NOR wishlist with 66 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 56950 102808 151136 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-01-20 06:49 UTC by Nicolò Wojewoda
Modified: 2015-02-03 12:26 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amit Upadhyay 2003-01-20 06:49:55 UTC
Version:           1.5 (using KDE 3.1.9)
Compiler:          gcc version 3.2 (Mandrake Linux 9.0 3.2-1mdk)
OS:          Linux (i686) release 2.4.19-9mdk

I like KMail's feature of allowing HTML rendering only on demand, and usually prefer text to html, yet once in a while I get HTML mail from trusted sources. I wish KMail would remember which mails I asked it to render as HTML and everytime I come back to that message I dont have to click some warning message.

Sometime, I may realize I want to tern this option off and avoid html rendering, so there may be some action to do it.

Keyword is convenience

Regards,
Amit Upadhyay
Comment 1 Tom Albers 2004-02-20 11:03:01 UTC
I agree with this request (but who am I). I would like to extend this request with the possibility to create a sort of white list of trusted users. Whenever that user sends a message the html-version is directly shown.
Comment 2 Stephan Kulow 2004-05-29 16:34:19 UTC
Replaced n8d10021@rediffmail.com with nico@woje.it due to bounces by reporter
Comment 3 Nicolò Wojewoda 2004-05-29 17:40:59 UTC
>Reporter:	Nicolò Wojewoda

??

I did not report this bug, I just voted it.

Cheers,
the real Nicolò Wojewoda
Comment 4 Stephan Kulow 2004-05-29 23:14:56 UTC
you're the last one to care about it.
Comment 5 Tom Albers 2004-07-31 01:24:58 UTC
Bug 63780 is related
Comment 6 Tom Albers 2004-07-31 01:29:26 UTC
*** Bug 56950 has been marked as a duplicate of this bug. ***
Comment 7 Carsten Burghardt 2005-03-30 11:45:43 UTC
*** Bug 102808 has been marked as a duplicate of this bug. ***
Comment 8 Luigi Toscano 2007-01-29 12:04:05 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Chris Pimlott 2008-04-22 20:02:11 UTC
A particular effect of the current system is that kmail doesn't even show the HTML version by default in individual message window view if you activated HTML in the message preview!
Comment 10 Björn Ruberg 2010-01-11 00:48:20 UTC
*** Bug 151136 has been marked as a duplicate of this bug. ***
Comment 11 Myriam Schweingruber 2012-08-18 08:44:39 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 12 Luigi Toscano 2012-08-19 01:06:15 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.
Comment 13 Bernd Oliver Sünderhauf 2012-11-24 10:22:56 UTC
Per address book contact, this is solved by Bug #63780.
Remembering the decision on a per message basis would be nice, and with Akonadi, it should probably be doable without too much overhead.
Still valid in kmail2, component "general".
Comment 14 Luigi Toscano 2012-11-24 16:42:33 UTC
*** This bug has been confirmed by popular vote. ***
Comment 15 Laurent Montel 2013-03-26 12:35:21 UTC
Fixed in 4.11
Comment 16 Kevin Funk 2015-02-03 11:44:01 UTC
Uhm, are you sure this is fixed? It isn't for me. 

I always have to re-click the "by clicking here" button when opening a HTML-only mail.
Comment 17 Kevin Funk 2015-02-03 11:44:35 UTC
Sorry, forgot to add version info: This is KMail 4.14.2
Comment 18 Laurent Montel 2015-02-03 12:26:44 UTC
Update baloo 4.14.3 (store info was not done correctly).
David had same bug and I fixed baloo for it.
Now if there is still another bug, I can investigate