Bug 50460 - running either sg or newgrp causes segmentation fault in Konsole.
Summary: running either sg or newgrp causes segmentation fault in Konsole.
Status: RESOLVED INTENTIONAL
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 50459 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-11-09 10:55 UTC by Christopher Sawtell
Modified: 2002-11-16 18:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Sawtell 2002-11-09 10:55:11 UTC
Version:           1.1.3 (using KDE KDE 3.0.4)
Installed from:    Gentoo Packages
Compiler:          gcc --version 2.95.3  
OS:          LinuxLinux

running either sg or newgrp causes segmentation fault in Konsole, but works correctly in xterm or virtual terminal ( black screen )
Comment 1 Christopher Sawtell 2002-11-09 10:56:06 UTC
chris@liberty chris $ sg mysql 
Segmentation fault 
chris@liberty chris $ id 
uid=1000(chris) gid=100(users) 
groups=100(users),10(wheel),11(floppy),16(cron),18(audio),19(cdrom),20(dialout),32(gdm),60(mysql) 
chris@liberty chris $ sg wheel 
Segmentation fault 
 
Cut and Paste from Konsole 
Comment 2 Stephan Binner 2002-11-09 10:59:46 UTC
*** Bug 50459 has been marked as a duplicate of this bug. ***
Comment 3 Stephan Binner 2002-11-09 11:00:43 UTC
So Konsole doesn't segfault? And it really works in xterm? Strange. 
Comment 4 Christopher Sawtell 2002-11-09 11:04:15 UTC
Yes, that's correct. Totally baffling. 
Comment 5 Stephan Binner 2002-11-16 18:34:48 UTC
I have honestly no idea what in Konsole can cause this and the segmentation 
fault has to be fixed in sg anyway.