Bug 50405 - dialogs don't show network interface list
Summary: dialogs don't show network interface list
Status: RESOLVED FIXED
Alias: None
Product: kcontrol
Classification: Miscellaneous
Component: kcmlanbrowser (show other bugs)
Version: unspecified
Platform: FreeBSD Ports FreeBSD
: NOR normal (vote)
Target Milestone: ---
Assignee: Alexander Neundorf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-11-08 12:58 UTC by Andriy I Pylypenko
Modified: 2005-01-05 22:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy I Pylypenko 2002-11-08 12:58:14 UTC
Version:            (using KDE KDE 3.0.4)
Installed from:    FreeBSD Ports
Compiler:          gcc version 2.95.4 20020320 [FreeBSD] 
OS:          FreeBSD

Dialogs "Network->LAN Browsing->Guided LISa Setup" and "Information->Network Interfaces" don't show iterface list.

This happens because in order to read interface list one must use ifr_addr.sa_len. KDE sources contains this code enclosed in

#ifdef HAVE_SOCKADDR_SA_LEN
#endif

The problem is that configure script doesn't check this feature.
Comment 1 Andriy I Pylypenko 2002-11-11 08:29:49 UTC
Subject: Re:  dialogs don't show network interface list         

On 9 Nov 2002, Stephan Binner wrote:

> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.

I'm reporting the bug.

It affects not only kcm_lanbrowser but kcm_nics also. The bug is not in
the code of those modules. It is in the configure scripts of the
kdenetwork and kdebase distributions. As I have written in previous
message, these scripts doesn't check feature HAVE_SOCKADDR_SA_LEN.

  Kind regards,
  Andriy I Pylypenko
  PAI1-RIPE

Comment 2 groot 2004-01-17 00:48:01 UTC
Adding this:

+AC_CHECK_MEMBERS(struct sockaddr.sa_len, , ,
+       [#include <sys/types.h>
+       #include <sys/socket.h>
+       ])

to the end of configure.in.in in kdenetwork makes it check for sa_len, at least. It still doesn't find any NICs for me in guided setup,  though.

KInfocenter NIC display works fine.
Comment 3 Lauri Watts 2005-01-05 22:00:07 UTC
*** Bug has been marked as fixed ***.