Bug 488957 - column width in keyboard kcm is too small and resizeable
Summary: column width in keyboard kcm is too small and resizeable
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_keyboard (show other bugs)
Version: 6.1.0
Platform: Arch Linux Linux
: NOR minor
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression, usability
Depends on:
Blocks:
 
Reported: 2024-06-22 07:07 UTC by Wind He
Modified: 2024-07-01 19:20 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.1.2
Sentry Crash Report:


Attachments
kcm_keyboard (76.90 KB, image/png)
2024-06-22 07:07 UTC, Wind He
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wind He 2024-06-22 07:07:56 UTC
Created attachment 170801 [details]
kcm_keyboard

SUMMARY

The problem is simple, using "width: 60" and "resizable: false" is too small
https://invent.kde.org/plasma/plasma-desktop/-/blob/master/kcms/keyboard/ui/Layouts.qml?ref_type=heads#L314

OBSERVED RESULT

Text label is cutting off as my screenshot
Comment 1 Nate Graham 2024-06-28 19:52:29 UTC
Wanna submit a merge request to fix it?

If you don't, this'll be fixed automatically by https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/2342
Comment 2 Wind He 2024-06-29 13:29:14 UTC
This MR will come with 6.2, right?
So my patch will come with 6.1.x? Iā€™m willing to write a quick fix! Will submit soon.
Comment 3 Nate Graham 2024-07-01 19:02:05 UTC
Git commit 8efdd23e13f5dcd228ab1e468f14e1f07e9b8f22 by Nate Graham, on behalf of Wind He.
Committed on 01/07/2024 at 19:02.
Pushed by ngraham into branch 'master'.

kcms/keyboard: fix width and immutability of layout table headers
FIXED-IN: 6.1.2

M  +4    -4    kcms/keyboard/ui/Layouts.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/8efdd23e13f5dcd228ab1e468f14e1f07e9b8f22
Comment 4 Nate Graham 2024-07-01 19:20:22 UTC
Git commit 9f0b2c7d0feb9f38f106d110c2b08d19310ce978 by Nate Graham.
Committed on 01/07/2024 at 19:20.
Pushed by ngraham into branch 'Plasma/6.1'.

kcms/keyboard: fix width and immutability of layout table headers
FIXED-IN: 6.1.2


(cherry picked from commit 8efdd23e13f5dcd228ab1e468f14e1f07e9b8f22)

a5b83156 fix: tableview item width

Co-authored-by: Wind He <g311571057@gmail.com>

M  +4    -4    kcms/keyboard/ui/Layouts.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/9f0b2c7d0feb9f38f106d110c2b08d19310ce978