Bug 488733 - Icons-and-Text Task Manager does not show window titles on a vertical panel
Summary: Icons-and-Text Task Manager does not show window titles on a vertical panel
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 6.1.0
Platform: Neon Linux
: HI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 489081 489200 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-06-19 13:00 UTC by Alexandr Zamaraev (aka Tonal)
Modified: 2024-06-25 20:54 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.1.1
Sentry Crash Report:


Attachments
Taskbar (8.09 KB, image/jpeg)
2024-06-19 13:00 UTC, Alexandr Zamaraev (aka Tonal)
Details
horizontal taskbar (19.06 KB, image/png)
2024-06-20 09:22 UTC, ezh
Details
Vertical Taskbar Few (2) Entries (13.04 KB, image/png)
2024-06-20 17:41 UTC, JD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Zamaraev (aka Tonal) 2024-06-19 13:00:23 UTC
Created attachment 170636 [details]
Taskbar

SUMMARY
Previously, both icons and part of the title were shown on the taskbar, now only icons.
Is it possible to display the title text as before?

OBSERVED RESULT
Icons only on button

EXPECTED RESULT
Icon and text n button 

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0 
Qt Version: 6.7.0

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2024-06-19 19:55:39 UTC
Can reproduce. Looks like a very recent regression. I was touching this code recently to *fix* a bug related to this and it was working fine then. Will investiagte.
Comment 2 Nate Graham 2024-06-19 21:03:12 UTC
Git bisect results:

3ed17946c4b243d96013e9dca595c9b3e8f19783 is the first bad commit
commit 3ed17946c4b243d96013e9dca595c9b3e8f19783 (HEAD)
Author: Marco Martin <notmart@gmail.com>
Date:   Wed May 8 14:21:55 2024 +0000

    applets/taskmanager: Stable icon size
    
    Make sure all the icons will have the same size by looking for the
    smallest one as layouts can have an one-pixel discrepancy between
    items, which might be enough to jump to the next icon size.
    
    On certain panel sizes, icons would get inconsistent sizes for an instant
    
    ![taskbar](/uploads/71327f4e3acb00f6dbd2edbe166f300f/taskbar.webm)

 applets/taskmanager/package/contents/ui/Task.qml     | 4 ++--
 applets/taskmanager/package/contents/ui/TaskList.qml | 9 +++++++++
 2 files changed, 11 insertions(+), 2 deletions(-)
Comment 3 ezh 2024-06-20 09:22:27 UTC
Created attachment 170666 [details]
horizontal taskbar

On a horizontal taskbar icons have a gap right to the text.
Comment 4 JD 2024-06-20 17:41:47 UTC
Created attachment 170694 [details]
Vertical Taskbar Few (2) Entries

This is how it appears in my vertical panel (128px wide).
I used to be able to see a small icon and a decent amount of the window title before 6.1 update.

Two entries seems to be the threshold for the task manager deciding to center icons and not display any text (with my theme).
Comment 5 Ismael Asensio 2024-06-24 11:40:15 UTC
*** Bug 489081 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2024-06-24 18:37:10 UTC
Git commit c0c6d5395584ab984c34d2359d0c7dab8a276abb by Nate Graham, on behalf of Marco Martin.
Committed on 24/06/2024 at 18:37.
Pushed by ngraham into branch 'master'.

applets/taskmanager: Properly size Task icons

Icon max width must be task height, not tasks. This properly lays out
text and icons in all cases again.
FIXED-IN: 6.1.1

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/c0c6d5395584ab984c34d2359d0c7dab8a276abb
Comment 8 Nate Graham 2024-06-24 18:37:29 UTC
Git commit 800b9c47936acc3e29f60754639884a8263be831 by Nate Graham.
Committed on 24/06/2024 at 18:37.
Pushed by ngraham into branch 'Plasma/6.1'.

applets/taskmanager: Properly size Task icons

Icon max width must be task height, not tasks. This properly lays out
text and icons in all cases again.
FIXED-IN: 6.1.1


(cherry picked from commit c0c6d5395584ab984c34d2359d0c7dab8a276abb)

1c92250c Properly size Task Icon

Co-authored-by: Marco Martin <notmart@gmail.com>

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/800b9c47936acc3e29f60754639884a8263be831
Comment 9 cwo 2024-06-25 20:54:16 UTC
*** Bug 489200 has been marked as a duplicate of this bug. ***