Bug 487825 - Dragging applet from panel to desktop is now broken, goes into stuck limbo state
Summary: Dragging applet from panel to desktop is now broken, goes into stuck limbo state
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: git-stable-Plasma/6.1
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 485243 485492 488634 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-05-31 07:41 UTC by David Edmundson
Modified: 2024-06-26 21:24 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Edmundson 2024-05-31 07:41:01 UTC
Steps to reproduce:
 - enter edit mode
 - drag item from applet to desktop
 - no visual indication of the drag occurs
 - dropping removes the applet from the panel, but it is not visibly anywhere
- widget explorer implies the applet is still alive, but that gets cleaned up after a restart
Comment 1 bruno.gonfiotti 2024-05-31 08:02:09 UTC
I can confirm. I also noticed that plasmashell freezes if the panels width/height is too high.
Comment 2 bruno.gonfiotti 2024-05-31 08:03:13 UTC
Ah, I have this bug on plasma 6.0.5.
Comment 3 Niccolò Venerandi 2024-06-03 09:17:40 UTC
See https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1754
Comment 4 Nate Graham 2024-06-19 19:09:04 UTC
*** Bug 488634 has been marked as a duplicate of this bug. ***
Comment 5 cwo 2024-06-20 13:41:47 UTC
*** Bug 485243 has been marked as a duplicate of this bug. ***
Comment 6 Niccolò Venerandi 2024-06-24 09:41:14 UTC
Git commit 3efe3ce8320c0b02fe54af3288fffd30f7ceab50 by Niccolò Venerandi.
Committed on 24/06/2024 at 09:41.
Pushed by niccolove into branch 'master'.

Refactor drag and drop behaviour of applets from panel to other containments

Right now it's impossible to drag and drop applets from the panel to elsewhere, only within the panel. If you try, the applets will be added to the desktop right next to the panel, and you'll have to start dragging them again to move them around or to another panel. This implements a new mode to drag and drop applets from the panel to other containments.

This MR makes it possible to just drag and drop items outside the panel; when you do so, a "real" drag and drop will start that allows you to move that applet on the desktop or to other panels. You can also put the applet back to the origin panel.

Requires https://invent.kde.org/plasma/libplasma/-/merge_requests/1142


Co-authored by Marco Martin

M  +31   -4    containments/desktop/package/contents/ui/main.qml
M  +24   -11   containments/panel/contents/ui/ConfigOverlay.qml
M  +1    -1    containments/panel/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/3efe3ce8320c0b02fe54af3288fffd30f7ceab50
Comment 7 Nate Graham 2024-06-26 21:24:39 UTC
*** Bug 485492 has been marked as a duplicate of this bug. ***