Bug 48771 - kmail crashes at startup
Summary: kmail crashes at startup
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: SVN (3.5 branch)
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-10-06 12:21 UTC by eva
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
backtrace of crash involving the KMessageBox (4.10 KB, text/plain)
2002-10-08 10:13 UTC, Richard Jones
Details
strace log of kmail invocation leading to backtrace (34.65 KB, text/plain)
2002-10-08 10:14 UTC, Richard Jones
Details
backtrace (3.26 KB, text/plain)
2002-10-09 23:13 UTC, eva
Details
strace during crash (2.84 KB, text/plain)
2002-10-09 23:15 UTC, eva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eva 2002-10-06 12:21:36 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc-3.2 suse 8.1
OS:          Linux

todays cvs. BTW, I have 2 imap servers configured. The crash happens after both passwords were entered.

backtrace:
[New Thread 1024 (LWP 21467)]
0x416248c9 in wait4 () from /lib/libc.so.6
#0  0x416248c9 in wait4 () from /lib/libc.so.6
#1  0x4169fc90 in __DTOR_END__ () from /lib/libc.so.6
#2  0x41473a93 in waitpid () from /lib/libpthread.so.0
#3  0x40b6ead7 in KCrash::defaultCrashHandler(int) ()
   from /opt/kde3cvs_1/lib/libkdecore.so.4
#4  0x4147112b in pthread_sighandler () from /lib/libpthread.so.0
#5  <signal handler called>
#6  0x080eef36 in KMFolderTree::addDirectory(KMFolderDir*, KMFolderTreeItem*)
    ()
#7  0x080ee9f4 in KMFolderTree::reload(bool) ()
#8  0x080ed98c in KMFolderTree::KMFolderTree(QWidget*, char const*) ()
#9  0x08093a61 in KMMainWin::createWidgets() ()
#10 0x0809036c in KMMainWin::KMMainWin(QWidget*, char*) ()
#11 0x081d5c1c in KMKernel::openReader() ()
#12 0x081d95d9 in KMKernel::action(bool, bool, QString const&, QString const&, Q
String const&, QString const&, QString const&, KURL const&, KURL::List const&)
    ()
#13 0x081dbf53 in KMailApplication::newInstance() ()
#14 0x40b8e115 in KUniqueApplication::processDelayed() ()
   from /opt/kde3cvs_1/lib/libkdecore.so.4
#15 0x40b8e469 in KUniqueApplication::qt_invoke(int, QUObject*) ()
   from /opt/kde3cvs_1/lib/libkdecore.so.4
#16 0x40ee8642 in QObject::activate_signal(QConnectionList*, QUObject*) (
    this=0x83daf90, clist=0x83d2880, o=0xbfffefd0) at kernel/qobject.cpp:2191
#17 0x411dab50 in QSignal::signal(QVariant const&) (this=0x83daf90,
    t0=@0x83dafb8) at .moc/debug-shared-mt/moc_qsignal.cpp:101
#18 0x40f055a1 in QSignal::activate() (this=0x83daf90)
    at kernel/qsignal.cpp:205
#19 0x40f0c35b in QSingleShotTimer::event(QEvent*) (this=0x83daf68)
    at kernel/qtimer.cpp:277
#20 0x40e82602 in QApplication::internalNotify(QObject*, QEvent*) (
    this=0xbffff5b0, receiver=0x83daf68, e=0xbffff220)
    at kernel/qapplication.cpp:2290
#21 0x40e81c57 in QApplication::notify(QObject*, QEvent*) (this=0xbffff5b0,
    receiver=0x83daf68, e=0xbffff220) at kernel/qapplication.cpp:2054
#22 0x40ae8117 in KApplication::notify(QObject*, QEvent*) ()
   from /opt/kde3cvs_1/lib/libkdecore.so.4
#23 0x40e3593b in QApplication::sendEvent(QObject*, QEvent*) (
    receiver=0x83daf68, event=0xbffff220) at kernel/qapplication.h:475
#24 0x40e5d172 in QEventLoop::activateTimers() (this=0x82b07c0)
    at kernel/qeventloop_unix.cpp:524
#25 0x40e38371 in QEventLoop::processEvents(unsigned) (this=0x82b07c0, flags=4)
    at kernel/qeventloop_x11.cpp:305
#26 0x40e98b2e in QEventLoop::enterLoop() (this=0x82b07c0)
    at kernel/qeventloop.cpp:188
#27 0x40e98a82 in QEventLoop::exec() (this=0x82b07c0)
    at kernel/qeventloop.cpp:138
#28 0x40e82785 in QApplication::exec() (this=0xbffff5b0)
    at kernel/qapplication.cpp:2409
#29 0x081dcb7c in main ()
#30 0x4159f4a2 in __libc_start_main () from /lib/libc.so.6

Greetings,
eva
Comment 1 Stephan Kulow 2002-10-06 12:31:33 UTC
Same crash as in 48695 - reported of that bug said moving 
away kmailrc fixes it. 
Comment 2 Stephan Kulow 2002-10-06 13:54:39 UTC
Subject: Re:  New: kmail crashes at startup

On Sonntag, 6. Oktober 2002 12:21, eva@kde.org wrote:
> ------- You are receiving this mail because: -------
> You are the assignee for the bug, or are watching the assignee.
>
> http://bugs.kde.org/show_bug.cgi?id=48771
>            Summary: kmail crashes at startup
>            Product: kmail
>            Version: unspecified
>           Platform: Compiled Sources
>         OS/Version: Linux
>             Status: NEW
>           Severity: normal
>           Priority: NOR
>          Component: general
>         AssignedTo: kmail@kde.org
>         ReportedBy: eva@kde.org
>
>
> Version:            (using KDE Devel)
> Installed from:    Compiled sources
> Compiler:          gcc-3.2 suse 8.1
> OS:          Linux
>
> todays cvs. BTW, I have 2 imap servers configured. The crash happens after
> both passwords were entered.
>
Hi!

Can you please compile with --enable-debug and perhaps even run it under
valgrind? It's quite hard to make sense of it when you haven't 2 imap servers
to reproduce it.

Greetings, Stephan

Comment 3 Stephan Kulow 2002-10-06 23:01:17 UTC
#48428 shows the same crash and is marked as fixed. Ingo? 
Comment 4 Ingo Klöcker 2002-10-06 23:58:21 UTC
Subject: Re:  kmail crashes at startup

On Sunday 06 October 2002 23:01, Stephan Kulow wrote:
> #48428 shows the same crash and is marked as fixed. Ingo?

The two crashes are showing similar symptoms. But the crash I fixed was 
due to a message box which blocked the correct initialization of KMail. 
The incomplete initialization then caused the crash (because the event 
loop called other code which tried to access uninitialized objects). I 
replaced the message box with a queued message box so that the 
initialization isn't interrupted while the message box is displayed. 
Eva's backtraces doesn't show a sign of a KMessageBox so there has to 
be another bug somewhere.

Comment 5 Richard Jones 2002-10-08 10:12:43 UTC
I've got a similar crash, I believe. When I start up KMail, I get a brief     
flash of a message box titled "Index Out of Date". Before the message box can  
complete rendering, I get the crash. I do have a KMessageBox in my stack  
trace. I'll attach it for your info. I'll attach an strace too, if that'll 
help... 
 
Comment 6 Richard Jones 2002-10-08 10:13:27 UTC
Created attachment 166 [details]
backtrace of crash involving the KMessageBox
Comment 7 Richard Jones 2002-10-08 10:14:48 UTC
Created attachment 167 [details]
strace log of kmail invocation leading to backtrace
Comment 8 Richard Jones 2002-10-08 10:19:12 UTC
I can confirm that moving the kmailrc out of the way and starting kmail up  
fixed the problem. The dialog turns out to be complaining about the index for  
the trash folder being out of date. *shrug*  
  
After shutting kmail down again, I was able to reinstate the original kmailrc 
to restore my settings. 
Comment 9 eva 2002-10-08 10:50:52 UTC
If I cancel the imap login dialogs at startup, I can get kmail running. BTW, I have imap 
folder configured to be used as sent-mail folders, that is probably why kmail wants to 
know the passwords at once. 
 
My reply to Comment #2: I already have everything compiled with --enable-debug 
 
Greetings, 
eva 
Comment 10 Ingo Klöcker 2002-10-09 00:19:03 UTC
Subject: Re:  kmail crashes at startup

On Tuesday 08 October 2002 10:50, eva@kde.org wrote:
>            What    |Removed                     |Added
> ---------------------------------------------------------------------
>------- Version|unspecified                 |3.0

I thought you were using the cvs version?

> My reply to Comment #2: I already have everything compiled with
> --enable-debug

You have to compile with --enable-debug=full in order to get line 
numbers in the debug output. It would be nice if you could do this so 
that we know in which line the crash occurs.

Regards,
Ingo


Comment 11 Ingo Klöcker 2002-10-09 00:19:05 UTC
Subject: Re:  kmail crashes at startup

On Tuesday 08 October 2002 10:12, Richard Jones wrote:
> I've got a similar crash, I believe. When I start up
> KMail, I get a brief flash of a message box titled "Index Out of
> Date". Before the message box can complete rendering, I get the
> crash. I do have a KMessageBox in my stack trace. I'll attach it for
> your info. I'll attach an strace too, if that'll help...

This is a different bug and I have just fixed it.

Regards,
Ingo


Comment 12 eva 2002-10-09 23:13:56 UTC
Created attachment 176 [details]
backtrace
Comment 13 eva 2002-10-09 23:15:05 UTC
Created attachment 177 [details]
strace during crash
Comment 14 Ingo Klöcker 2002-10-10 00:23:34 UTC
Thanks for the backtrace. Please try if the following patch fixes the 
problem. 
 
--- kmfoldertree.cpp~   Fri Sep 13 01:21:26 2002 
+++ kmfoldertree.cpp    Wed Oct  9 23:51:30 2002 
@@ -511,7 +511,7 @@ 
         addDirectory( folder->child(), fti ); 
       // make sure that the folder-settings are correctly read on startup by 
calling listDirectory 
       if (readIsListViewItemOpen(fti) && 
-         folder && fti->folder()->protocol() == "imap") 
+         fti->folder() && fti->folder()->protocol() == "imap") 
         slotFolderExpanded(fti); 
     } 
   } // for-end 
 
Carsten? Do you think this fix is correct? 
 
 
[pid  3963] 23:15:03 stat64("/export/home/eva/.kde3cvs/share/config/", 
 {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0 
[pid  3963] 23:15:03 
 stat64("/export/home/eva/.kde3cvs/share/config/kio_imaprc", 0xbfffd550) 
 = -1 ENOENT (No such file or directory) 
[pid  3963] 23:15:03 stat64("/opt/kde3cvs_1/share/config/kio_imaprc", 
 0xbfffd550) = -1 ENOENT (No such file or directory) 
[pid  3963] 23:15:03 stat64("/opt/kde2/share/config/kio_imaprc", 
 0xbfffd550) = -1 ENOENT (No such file or directory) 
 
Eva? Why is KDE looking in /opt/kde2/... for kio_imaprc? Does 
$KDEDIRS include /opt/kde2? You should probably unset $KDEDIRS. 
 
Regards, 
Ingo 
 
Comment 15 eva 2002-10-16 21:35:47 UTC
Ingo, your patch still works fine.  
eva   
Comment 16 Ingo Klöcker 2002-10-16 22:43:33 UTC
Subject: Re:  kmail crashes at startup

On Wednesday 16 October 2002 21:35, eva@kde.org wrote:
> Ingo, your patch still works fine.

O.k., I committed the patch.

Regards,
Ingo


Comment 17 ralf@skolelinux.de 2005-09-28 19:31:12 UTC
My Kmail keeps crashing:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1110717408 (LWP 6204)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0x40350073 in KMMainWidget::readConfig ()
   from /usr/lib/libkmailprivate.so.0
#4  0x4034f040 in KMMainWidget::KMMainWidget ()
   from /usr/lib/libkmailprivate.so.0
#5  0x4016a44c in KMMainWin::KMMainWin () from /usr/lib/libkmailprivate.so.0
#6  0x402d9675 in KMKernel::openReader () from /usr/lib/libkmailprivate.so.0
#7  0x402deb90 in KMKernel::action () from /usr/lib/libkmailprivate.so.0
#8  0x402d9474 in KMKernel::handleCommandLine ()
   from /usr/lib/libkmailprivate.so.0
#9  0x08049f35 in ?? ()
#10 0xbffff870 in ?? ()
#11 0x00000001 in ?? ()
#12 0xbffff140 in ?? ()
#13 0x081aae70 in ?? ()
#14 0x40fb053c in ?? () from /usr/lib/libqt-mt.so.3
#15 0xbffff140 in ?? ()
#16 0xbffff0d8 in ?? ()
#17 0x40decd3a in QCString::~QCString () from /usr/lib/libqt-mt.so.3
#18 0x407c28a2 in KUniqueApplication::processDelayed ()
   from /usr/lib/libkdecore.so.4
#19 0x407c2d4f in KUniqueApplication::qt_invoke ()
   from /usr/lib/libkdecore.so.4
#20 0x40b4871c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0x40e8762a in QSignal::signal () from /usr/lib/libqt-mt.so.3
#22 0x40b6291d in QSignal::activate () from /usr/lib/libqt-mt.so.3
#23 0x40b6a253 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#24 0x40aebe1f in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#25 0x40aeb41e in QApplication::notify () from /usr/lib/libqt-mt.so.3
#26 0x4071bec3 in KApplication::notify () from /usr/lib/libkdecore.so.4
#27 0x40adb645 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#28 0x40a94cfb in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#29 0x40afe1d8 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#30 0x40afe088 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#31 0x40aec071 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#32 0x0804a0b4 in ?? ()
#33 0xbffff950 in ?? ()
#34 0xbffff860 in ?? ()
#35 0x00000000 in ?? ()
#36 0x00000000 in ?? ()
#37 0x40f8fc40 in vtable for QGArray () from /usr/lib/libqt-mt.so.3
#38 0x0813d7a0 in ?? ()
#39 0x4066f618 in main_arena () from /lib/tls/libc.so.6
#40 0x4066f218 in main_arena () from /lib/tls/libc.so.6
#41 0x40438770 in vtable for KMKernel () from /usr/lib/libkmailprivate.so.0
#42 0x405a10a0 in _int_malloc () from /lib/tls/libc.so.6
#43 0x4054eec0 in __libc_start_main () from /lib/tls/libc.so.6
#44 0x08049e11 in ?? ()