Bug 487398 - Gwenview displays a particular SVG incorrectly
Summary: Gwenview displays a particular SVG incorrectly
Status: RESOLVED DUPLICATE of bug 336436
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 24.02.2
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-05-22 23:51 UTC by JT Hundley
Modified: 2024-05-23 06:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The problematic SVG file. (1.83 KB, image/svg+xml)
2024-05-22 23:51 UTC, JT Hundley
Details
Gimp showing it properly on top, Gwenview showing it incorrectly on bottom. (50.34 KB, image/png)
2024-05-22 23:52 UTC, JT Hundley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JT Hundley 2024-05-22 23:51:24 UTC
Created attachment 169726 [details]
The problematic SVG file.

Gwenview displays a certain SVG incorrectly.


STEPS TO REPRODUCE
1. Open attached SVG in Gwenview.
2. Open attached SVG in GIMP or a web browser.

OBSERVED RESULT
The SVG file does not render properly, the symbols are cut off.

EXPECTED RESULT
I expected the SVG to render the same in all 3 pieces of software.

SOFTWARE/OS VERSIONS
Linux 6.9.1-zen1-1-zen, EndeavorOS
KDE Plasma Version: 6.0.44
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.0

ADDITIONAL INFORMATION
I uploaded this SVG to a website that claims it can check if they're valid or not, and it said this SVG is valid.
Comment 1 JT Hundley 2024-05-22 23:52:59 UTC
Created attachment 169727 [details]
Gimp showing it properly on top, Gwenview showing it incorrectly on bottom.
Comment 2 Antonio Rojas 2024-05-23 06:32:06 UTC

*** This bug has been marked as a duplicate of bug 336436 ***