Bug 486300 - Klipper shows "Clipboard is empty" when no results are found
Summary: Klipper shows "Clipboard is empty" when no results are found
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Clipboard (show other bugs)
Version: 6.0.4
Platform: Other Linux
: NOR minor
Target Milestone: 1.0
Assignee: Thomas Duckworth
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2024-04-29 14:29 UTC by medin
Modified: 2024-05-06 17:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.5


Attachments
Klipper shows "Clipboard is empty" when no results are found. (18.65 KB, image/png)
2024-04-29 14:29 UTC, medin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description medin 2024-04-29 14:29:35 UTC
Created attachment 169000 [details]
Klipper shows "Clipboard is empty" when no results are found.

Instead of showing something like "No results" or "Nothing", Klipper shows "Clipboard is empty" when no results are found.
Comment 1 Thomas Duckworth 2024-05-05 11:29:26 UTC
I've opened a merge request: https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/4289
Comment 2 Nate Graham 2024-05-06 16:42:20 UTC
Git commit e73a835eb6ca9c35bc769b9392c38a4b52e3d487 by Nate Graham, on behalf of Thomas Duckworth.
Committed on 06/05/2024 at 16:42.
Pushed by ngraham into branch 'master'.

applets/clipboard: Show appropriate placeholder message with no search results

The clipboard applet would show "Clipboard is empty" when no matches were found,
instead of a more appropriate message. This fixes it and has the applet show
"No matches found" and the `edit-none` icon when no results are found in the
searchbar, as per the original intended behaviour.
FIXED-IN: 6.0.5

M  +1    -1    applets/clipboard/contents/ui/Menu.qml

https://invent.kde.org/plasma/plasma-workspace/-/commit/e73a835eb6ca9c35bc769b9392c38a4b52e3d487
Comment 3 Nate Graham 2024-05-06 17:02:53 UTC
Git commit abd270de3ce7b6a6be106b27005e7d9d18ab1c7e by Nate Graham, on behalf of Thomas Duckworth.
Committed on 06/05/2024 at 16:42.
Pushed by ngraham into branch 'Plasma/6.0'.

applets/clipboard: Show appropriate placeholder message with no search results

The clipboard applet would show "Clipboard is empty" when no matches were found,
instead of a more appropriate message. This fixes it and has the applet show
"No matches found" and the `edit-none` icon when no results are found in the
searchbar, as per the original intended behaviour.
FIXED-IN: 6.0.5


(cherry picked from commit e73a835eb6ca9c35bc769b9392c38a4b52e3d487)

aed7b739 BUG: 486300
924632d4 Merge branch plasma-workspace:master into fix-klipper-empty-message

M  +1    -1    applets/clipboard/contents/ui/Menu.qml

https://invent.kde.org/plasma/plasma-workspace/-/commit/abd270de3ce7b6a6be106b27005e7d9d18ab1c7e