Bug 485258 - Dolphin crashed after dragging a file to the path breadcrumb
Summary: Dolphin crashed after dragging a file to the path breadcrumb
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Frameworks and Libraries
Component: URL navigator (show other bugs)
Version: 6.1.0
Platform: Arch Linux Linux
: VHI crash
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords: drkonqi
: 471279 485361 485413 485428 485465 485714 485757 485786 485977 486054 486065 486146 486454 486479 486579 486702 486758 486824 486843 486859 486868 486879 486944 486950 487269 487463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-04-09 03:27 UTC by Sophie Cheung
Modified: 2024-05-24 17:28 UTC (History)
34 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2


Attachments
New crash information added by DrKonqi (82.66 KB, text/plain)
2024-04-09 03:27 UTC, Sophie Cheung
Details
Screencast of the reproduction of the bug (3.06 MB, video/webm)
2024-04-09 05:44 UTC, Sophie Cheung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sophie Cheung 2024-04-09 03:27:02 UTC
Application: dolphin (24.02.1)

Qt Version: 6.7.0
Frameworks Version: 6.0.0
Operating System: Linux 6.8.2-arch1-Adashima-T2-1-t2 x86_64
Windowing System: Wayland
Distribution: "Arch Linux"
DrKonqi: 6.0.3 [CoredumpBackend]

-- Information about the crash:
To reproduce the crash, 
1. drag any item to any text section of the path breadcrumb
2. dolphin crashes

The crash occurred even after a fresh restart.
I am not aware of any non-default settings, apart from using a theme.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#5  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::get (this=0x8, this=<optimized out>) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.7.0/src/corelib/tools/qscopedpointer.h:110
[...]
#8  QObject::deleteLater (this=0x0) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.7.0/src/corelib/kernel/qobject.cpp:2456
#9  0x000071d3d3903dfe in KDEPrivate::KUrlNavigatorButton::dragMoveEvent (this=0x6309d8f5d230, event=<optimized out>) at /usr/src/debug/kio/kio-6.0.0/src/filewidgets/kurlnavigatorbutton.cpp:323
#10 0x000071d3d23470d3 in QWidget::event (this=0x6309d8f5d230, event=0x7fffbe8f8ac0) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.7.0/src/widgets/kernel/qwidget.cpp:9237
#11 0x000071d3d22fbfcb in QApplicationPrivate::notify_helper (this=this@entry=0x6309d8c28030, receiver=0x6309d8f5d230, e=e@entry=0x7fffbe8f8ac0) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.7.0/src/widgets/kernel/qapplication.cpp:3287


Reported using DrKonqi
Comment 1 Sophie Cheung 2024-04-09 03:27:05 UTC
Created attachment 168297 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Méven Car 2024-04-09 04:45:55 UTC
I couldn't reproduce the bug though.
Could you provide more precise scenario or a video capture ?

May have be taken of by https://invent.kde.org/frameworks/kio/-/commit/341a75c7e42ea8bcea07d0a0c0044a5a4f342e07
Comment 3 Sophie Cheung 2024-04-09 05:44:30 UTC
Created attachment 168300 [details]
Screencast of the reproduction of the bug

I don't really know how to describe it more precisely so I've attached a screencast to demonstrate the behavior. Will test the patch later.
Comment 4 Méven Car 2024-04-09 06:04:02 UTC
(In reply to Sophie Cheung from comment #3)
> Created attachment 168300 [details]
> Screencast of the reproduction of the bug
> 
> I don't really know how to describe it more precisely so I've attached a
> screencast to demonstrate the behavior. Will test the patch later.

I don't reproduce it.
Do you reproduce it with breeze ?

I think I fixed already anyway.
Comment 5 bugsie 2024-04-12 11:08:45 UTC
*** Bug 485361 has been marked as a duplicate of this bug. ***
Comment 6 bugsie 2024-04-12 11:09:05 UTC
*** Bug 485413 has been marked as a duplicate of this bug. ***
Comment 7 bugsie 2024-04-12 11:09:18 UTC
*** Bug 485428 has been marked as a duplicate of this bug. ***
Comment 8 Patrick Silva 2024-04-13 00:09:31 UTC
*** Bug 485465 has been marked as a duplicate of this bug. ***
Comment 9 bugsie 2024-04-18 13:25:28 UTC
*** Bug 485714 has been marked as a duplicate of this bug. ***
Comment 10 Patrick Silva 2024-04-19 15:04:29 UTC
*** Bug 485757 has been marked as a duplicate of this bug. ***
Comment 11 Patrick Silva 2024-04-23 00:48:31 UTC
*** Bug 485977 has been marked as a duplicate of this bug. ***
Comment 12 Patrick Silva 2024-04-24 13:10:34 UTC
*** Bug 486054 has been marked as a duplicate of this bug. ***
Comment 13 Méven Car 2024-04-30 09:34:25 UTC
*** Bug 486146 has been marked as a duplicate of this bug. ***
Comment 14 Méven Car 2024-04-30 09:40:53 UTC
Only rolling release distro will get confronted with this.
Those distro updated Qt to 6.7 before devs even started using it and Qt 6.7 introduced some very low-level behavior changes causing crashes (deleteLater() now crash when called with a nullptr object, most likely because of https://code.qt.io/cgit/qt/qtbase.git/commit/src/corelib/kernel/qobject.cpp?h=v6.7.0&id=d50746ef3aec72d339f639395a2291009f186680)
Comment 15 Patrick Silva 2024-05-03 14:20:18 UTC
*** Bug 486479 has been marked as a duplicate of this bug. ***
Comment 16 fuhejidianfanguo 2024-05-04 23:54:00 UTC
(In reply to Méven Car from comment #14)
> Only rolling release distro will get confronted with this.
> Those distro updated Qt to 6.7 before devs even started using it and Qt 6.7
> introduced some very low-level behavior changes causing crashes
> (deleteLater() now crash when called with a nullptr object, most likely
> because of
> https://code.qt.io/cgit/qt/qtbase.git/commit/src/corelib/kernel/qobject.
> cpp?h=v6.7.0&id=d50746ef3aec72d339f639395a2291009f186680)

​Yes, before scrolling through the archlinux update I looked at the about to be updated package, which includes qt, after updating qt, Then this bug appeared(Translated)
Comment 17 Dm 2024-05-05 02:26:57 UTC
(In reply to Méven Car from comment #14)
> Only rolling release distro will get confronted with this.
> Those distro updated Qt to 6.7 before devs even started using it and Qt 6.7
> introduced some very low-level behavior changes causing crashes
> (deleteLater() now crash when called with a nullptr object, most likely
> because of
> https://code.qt.io/cgit/qt/qtbase.git/commit/src/corelib/kernel/qobject.
> cpp?h=v6.7.0&id=d50746ef3aec72d339f639395a2291009f186680)

Having same behavior on KDE Neon
I suppose in Neon QT must be used by devs

Operating System: KDE neon 6.0
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.5.0-28-generic (64-bit)
Graphics Platform: Wayland
Processors: 12 × Intel® Core™ i7-8750H CPU @ 2.20GHz
Memory: 15.3 ГиБ of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
Manufacturer: Dell Inc.
Product Name: XPS 15 9570
Comment 18 Méven Car 2024-05-06 13:36:58 UTC
*** Bug 471279 has been marked as a duplicate of this bug. ***
Comment 19 Nicolas Fella 2024-05-07 21:06:19 UTC
*** Bug 485786 has been marked as a duplicate of this bug. ***
Comment 20 Nicolas Fella 2024-05-07 21:06:49 UTC
*** Bug 486579 has been marked as a duplicate of this bug. ***
Comment 21 Nicolas Fella 2024-05-07 21:08:55 UTC
*** Bug 486454 has been marked as a duplicate of this bug. ***
Comment 22 Nicolas Fella 2024-05-07 21:09:10 UTC
*** Bug 486065 has been marked as a duplicate of this bug. ***
Comment 23 Nicolas Fella 2024-05-07 21:28:02 UTC
*** Bug 486702 has been marked as a duplicate of this bug. ***
Comment 24 filip.kendes1 2024-05-08 06:20:31 UTC
*** Bug 486758 has been marked as a duplicate of this bug. ***
Comment 25 filip.kendes1 2024-05-10 06:19:10 UTC
*** Bug 486824 has been marked as a duplicate of this bug. ***
Comment 26 filip.kendes1 2024-05-10 13:07:11 UTC
*** Bug 486843 has been marked as a duplicate of this bug. ***
Comment 27 filip.kendes1 2024-05-11 06:04:39 UTC
*** Bug 486868 has been marked as a duplicate of this bug. ***
Comment 28 filip.kendes1 2024-05-11 06:08:35 UTC
*** Bug 486859 has been marked as a duplicate of this bug. ***
Comment 29 filip.kendes1 2024-05-11 06:12:30 UTC
*** Bug 486879 has been marked as a duplicate of this bug. ***
Comment 30 Antonio Rojas 2024-05-13 07:01:24 UTC
*** Bug 486944 has been marked as a duplicate of this bug. ***
Comment 31 filip.kendes1 2024-05-13 12:53:46 UTC
*** Bug 486950 has been marked as a duplicate of this bug. ***
Comment 32 Dilam 2024-05-16 12:49:54 UTC
This bug is currently marked as "RESOLVED FIXED". I'm in KDE neon and the bug is still present (it often annoys me).

Operating System: KDE neon 6.0
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.5.0-35-generic (64-bit)
Graphics Platform: Wayland

Can someone confirm that it has been fixed and that I just have to wait for the update to come ?
Comment 33 David Tonhofer 2024-05-16 13:56:55 UTC
I'm on Fedora 40 an according to the "About This System" tool, I have:

Operating System: Fedora Linux 40
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.0
Kernel Version: 6.8.9-300.fc40.x86_64 (64-bit)
Graphics Platform: Wayland

This bug is not currently happening so, looks fine.
Comment 34 Dilam 2024-05-16 14:26:57 UTC
(In reply to David Tonhofer from comment #33)
> I'm on Fedora 40 an according to the "About This System" tool, I have:
> 
> Operating System: Fedora Linux 40
> KDE Plasma Version: 6.0.4
> KDE Frameworks Version: 6.2.0
> Qt Version: 6.7.0
> Kernel Version: 6.8.9-300.fc40.x86_64 (64-bit)
> Graphics Platform: Wayland
> 
> This bug is not currently happening so, looks fine.

Ok. I am not on the latest KDE Frameworks version.
I forgot that I had slow down a bit updates in system settings (it's good to be able to not receive updates at each days).
Comment 35 Dilam 2024-05-23 08:35:47 UTC
I can confirm that it is now fixed for me.
Comment 36 filip.kendes1 2024-05-24 17:26:47 UTC
*** Bug 487463 has been marked as a duplicate of this bug. ***
Comment 37 filip.kendes1 2024-05-24 17:28:56 UTC
*** Bug 487269 has been marked as a duplicate of this bug. ***