Bug 483613 - Elisa freezes when clicking 'toggle party mode'
Summary: Elisa freezes when clicking 'toggle party mode'
Status: RESOLVED FIXED
Alias: None
Product: Elisa
Classification: Applications
Component: general (show other bugs)
Version: 24.02.0
Platform: Other Linux
: NOR grave
Target Milestone: ---
Assignee: Matthieu Gallien
URL:
Keywords: qt6
Depends on:
Blocks:
 
Reported: 2024-03-14 22:20 UTC by nathan
Modified: 2024-05-09 17:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 24.05.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nathan 2024-03-14 22:20:13 UTC
SUMMARY
***
STEPS TO REPRODUCE
1. Open Elisa
2. With media playing or paused (an internet radio station in my case) click "toggle party mode"

OBSERVED RESULT
Elisa freezes and becomes unresponsive

SOFTWARE/OS VERSIONS
Operating System: EndeavourOS 
KDE Plasma Version: 6.0.1
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.7.9-arch1-1 (64-bit)
Graphics Platform: Wayland
Comment 1 pL3bq9wlPGp7FvekKWaV 2024-03-21 10:39:41 UTC
(In reply to nathan from comment #0)
> SUMMARY
> ***
> STEPS TO REPRODUCE
> 1. Open Elisa
> 2. With media playing or paused (an internet radio station in my case) click
> "toggle party mode"
> 
> OBSERVED RESULT
> Elisa freezes and becomes unresponsive
> 
> SOFTWARE/OS VERSIONS
> Operating System: EndeavourOS 
> KDE Plasma Version: 6.0.1
> KDE Frameworks Version: 6.0.0
> Qt Version: 6.6.2
> Kernel Version: 6.7.9-arch1-1 (64-bit)
> Graphics Platform: Wayland

Some additional information on how to reproduce this bug consistently:

1). Load a single track into Elisa, or tune into a radio station

2). With the window not in fullscreen, and being small enough in height, click party mode

Elisa consistently becomes unresponsive when following those steps. It seems to be fine when there are 2 or more items in the list.
Comment 2 Nick 2024-03-21 20:38:33 UTC
Hi - I can duplicate his reliably on Neon and Elisa 24.02.1. The .deb shows the problem. The Flatpak works fine.

To duplicate it, load music, and enter party mode (works), exit party mode (works) enter party mode again (freezes). App then goes non-responsive and needs to be force quit.

I'm all partied out. Marking this as confirmed and hope a dev can take a look. Thanks, Nick.
Comment 3 Nate Graham 2024-05-09 17:06:27 UTC
Git commit 19956140b45f683a318954422f0d504bcd72725c by Nate Graham, on behalf of Pedro Nishiyama.
Committed on 09/05/2024 at 17:06.
Pushed by ngraham into branch 'master'.

Fix UI freeze when maximizing the Headerbar

When playing a playlist with few tracks, the UI would freeze when
maximizing the headbar, and the playlist wasn't aligning to the
top properly because `playLoader.implicitHeight` didn't have the
correct height.
FIXED-IN: 24.05.0

M  +73   -24   src/qml/HeaderBar.qml

https://invent.kde.org/multimedia/elisa/-/commit/19956140b45f683a318954422f0d504bcd72725c
Comment 4 Nate Graham 2024-05-09 17:14:37 UTC
Git commit 91558ec4f002b34dd10616e4f9b835026dfe4ddb by Nate Graham, on behalf of Pedro Nishiyama.
Committed on 09/05/2024 at 17:08.
Pushed by ngraham into branch 'release/24.05'.

Fix UI freeze when maximizing the Headerbar

When playing a playlist with few tracks, the UI would freeze when
maximizing the headbar, and the playlist wasn't aligning to the
top properly because `playLoader.implicitHeight` didn't have the
correct height.
FIXED-IN: 24.05.0


(cherry picked from commit 19956140b45f683a318954422f0d504bcd72725c)

d48fff63 HeadBar: Simplify responsive layout when maximized

M  +73   -24   src/qml/HeaderBar.qml

https://invent.kde.org/multimedia/elisa/-/commit/91558ec4f002b34dd10616e4f9b835026dfe4ddb