Bug 483454 - Energy profile slider jumps back to "Save Energy" mode, even though other profile is set
Summary: Energy profile slider jumps back to "Save Energy" mode, even though other pro...
Status: RESOLVED DUPLICATE of bug 475255
Alias: None
Product: plasmashell
Classification: Plasma
Component: Battery Monitor (show other bugs)
Version: 5.27.10
Platform: Ubuntu Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-03-13 15:39 UTC by Daniel Gibson
Modified: 2024-03-13 16:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Gibson 2024-03-13 15:39:39 UTC
SUMMARY

I'm using the current development version of KUbuntu 24.04 with plasma 5.27.10-1ubuntu1 and power-profiles-daemon 0.20-3ubuntu1 on a Framework Laptop 13 with AMD Ryzen 5 7640U.

The energy profile slider always jumps back to the "Save Energy" state, no matter which mode is actually set according to `powerprofilesctl`.
Both setting another profile with the slider and with `powerprofilesctl set balanced` (or "power-saver" or "performance") works, according to `powerprofilesctl list` and `powerprofilesctl get` and `cat /sys/firmware/acpi/platform_profile`.
The slider however always jumps back to the left, and the text above it always resets to "Power Save"

This is very similar to #474016, except that according to powerprofilesctl switching profiles is successful, so it's most probably not a bug in power-profiles-daemon?

STEPS TO REPRODUCE

1. Click battery icon in taskbar
2. move slider to middle or right position

OBSERVED RESULT

The slider moves back to the left, `powerprofilesctl get` shows new state.

EXPECTED RESULT

The slider stays where I moved it, `powerprofilesctl get` shows new state.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 

Operating System: Kubuntu 24.04
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12
Kernel Version: 6.6.0-14-generic (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 7640U w/ Radeon 760M Graphics
Memory: 27.1 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: Framework
Product Name: Laptop 13 (AMD Ryzen 7040Series)
System Version: A5
Comment 1 Nate Graham 2024-03-13 16:07:02 UTC

*** This bug has been marked as a duplicate of bug 475255 ***