Bug 482098 - Overlapping widgets with Activities widget on panel
Summary: Overlapping widgets with Activities widget on panel
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Activity Switcher (show other bugs)
Version: 6.0.0
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 460907 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-02-29 21:37 UTC by Antonio Rojas
Modified: 2024-05-11 15:39 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.5


Attachments
Screenshot (36.13 KB, image/png)
2024-02-29 21:37 UTC, Antonio Rojas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2024-02-29 21:37:44 UTC
Created attachment 166224 [details]
Screenshot

This is with kirigami 6.0.0, which is not available in the selection box

The panel shows some glitches at startup: some icons are drawn on top of others, some at a too small size. Entering edit mode fixes the issues, restarting plasmashell makes them appear again 

Bisected to 6da5023bc90d81a182f71411e18721c5f425a807

Screenshot attached
Comment 1 Nate Graham 2024-03-01 07:07:34 UTC
I think this may be a few separate bugs in individual applets, or else one in the Panel. But I haven't investigated it yet so I'm not sure of that.
Comment 2 Marco Martin 2024-03-05 15:49:32 UTC
(In reply to Antonio Rojas from comment #0)
> Bisected to 6da5023bc90d81a182f71411e18721c5f425a807

I find it very strange the culprit would really be in this comment in kirigami, as all it does is to actually hardcode some spacings to a fixed pixel amount, also kirigami isn't used that much in plasma shell, i suspect is something coming out from the same root cause of 
https://bugs.kde.org/show_bug.cgi?id=477317  (even tough a different effect as is items with wrong layout rather than window with wrong size)
Comment 3 Nate Graham 2024-03-06 17:10:09 UTC
Very very likely, yes.

*** This bug has been marked as a duplicate of bug 477317 ***
Comment 4 Antonio Rojas 2024-03-06 17:28:39 UTC
FWIW, after removing the showActivityManager plasmoid from the panel I can no longer reproduce the issue. So it seems to be an issue with that specific plasmoid after the kirigami size change (and unrelated to the older bug 477317)
Comment 5 Nate Graham 2024-03-06 20:28:40 UTC
Is that a 3rd-party widget?
Comment 6 Antonio Rojas 2024-03-06 20:37:06 UTC
(In reply to Nate Graham from comment #5)
> Is that a 3rd-party widget?

No

https://invent.kde.org/plasma/plasma-desktop/-/tree/master/applets/showActivityManager
Comment 7 Nate Graham 2024-03-08 22:26:26 UTC
Ok, thanks. I haven't been able to make it happen after trying to replicate that setup.
Comment 8 Nate Graham 2024-04-12 14:33:44 UTC
After some investigation in Bug 477317, we found that there were some sizing issues in Qt which have been fixed for Qt 6.7.1, and we also pushed a change to master. Antonio, would you be able to test whether the combination of these changes fixes the issue for you? Thank super be super. Thanks a lot!
Comment 9 Antonio Rojas 2024-04-12 16:38:59 UTC
(In reply to Nate Graham from comment #8)
> After some investigation in Bug 477317, we found that there were some sizing
> issues in Qt which have been fixed for Qt 6.7.1, and we also pushed a change
> to master. Antonio, would you be able to test whether the combination of
> these changes fixes the issue for you? Thank super be super. Thanks a lot!

Sure, can you point me to the Qt fixes I need to test?
Comment 10 Nate Graham 2024-04-12 16:42:08 UTC
From what I can tell, 5539bc8ce3ff1d2e5f6e78be4185e0cac4615218 in QtWayland may be enough, but if that doesn't fix it I'll see if I can track down any more fixed that might also be needed. Thanks a lot for testing!
Comment 11 Antonio Rojas 2024-04-12 18:59:48 UTC
No, these commits don't fix the issue unfortunately.
Comment 12 Nate Graham 2024-04-13 22:07:58 UTC
Ah dang it. Thanks anyway, I appreciate you spending the effort on it.
Comment 13 Edo Friedman 2024-05-05 20:56:35 UTC
I don't know if this is a bad practice or something, but removing the explicit height and width on the icon in the showActivityManager applet seems to fix it for me. I suspect it's due to the icon's dimensions being dependent on its parent's dimensions, which fills the root, whose preferredWidth is dependent on the the icon's width.
Comment 14 Nate Graham 2024-05-06 20:50:51 UTC
Would you be interested in submitting a merge request to fix it? Sounds like the code there is pretty old and in need of some maintenance to fix issues that got worse in Qt6.
Comment 15 Bug Janitor Service 2024-05-08 18:29:13 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/2242
Comment 16 Nate Graham 2024-05-09 19:57:23 UTC
Git commit 449be743eb6eb6decb9927442c11238fb0a05ab2 by Nate Graham, on behalf of Edo Friedman.
Committed on 09/05/2024 at 19:57.
Pushed by ngraham into branch 'master'.

applets/showActivityManager: Fix and improve layout

Fixes an issue where the showActivityManager applet was too small and
caused some applets on the panel to overlap.

Also fixes two other issues found while testing the change:

1. There was an extra small spacing on the right of the applet when not
   displaying the activity name.
2. The activity name could go past the widget when placed on the desktop.

One other pre-existing problem that I couldn't solve is that when you place
a new showActivityManager widget on the desktop, the initial width isn't
big enough to contain the icon and text.
FIXED-IN: 6.0.5

M  +7    -2    applets/showActivityManager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/449be743eb6eb6decb9927442c11238fb0a05ab2
Comment 17 Nate Graham 2024-05-09 20:12:23 UTC
Git commit 0252c5b91ac50fb2516ae88b59fb18ce3b0085d1 by Nate Graham, on behalf of Edo Friedman.
Committed on 09/05/2024 at 20:03.
Pushed by ngraham into branch 'Plasma/6.0'.

applets/showActivityManager: Fix and improve layout

Fixes an issue where the showActivityManager applet was too small and
caused some applets on the panel to overlap.

Also fixes two other issues found while testing the change:

1. There was an extra small spacing on the right of the applet when not
   displaying the activity name.
2. The activity name could go past the widget when placed on the desktop.

One other pre-existing problem that I couldn't solve is that when you place
a new showActivityManager widget on the desktop, the initial width isn't
big enough to contain the icon and text.
FIXED-IN: 6.0.5


(cherry picked from commit 449be743eb6eb6decb9927442c11238fb0a05ab2)

7eb25d01 Improve layout of showActivityManager applet
83473830 Merge branch plasma-desktop:master into master

M  +7    -2    applets/showActivityManager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/0252c5b91ac50fb2516ae88b59fb18ce3b0085d1
Comment 18 Oded Arbel 2024-05-11 13:39:13 UTC
*** Bug 460907 has been marked as a duplicate of this bug. ***