Bug 479818 - Incorrect bold font rendering
Summary: Incorrect bold font rendering
Status: RESOLVED UPSTREAM
Alias: None
Product: konsole
Classification: Applications
Component: font (show other bugs)
Version: master
Platform: openSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords: qt6
Depends on:
Blocks:
 
Reported: 2024-01-14 20:59 UTC by Dominic
Modified: 2024-01-17 06:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Incorrect bold font rendering (4.83 KB, image/png)
2024-01-14 20:59 UTC, Dominic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic 2024-01-14 20:59:57 UTC
Created attachment 164905 [details]
Incorrect bold font rendering

SUMMARY
***
Both Yakuake and Konsole render bold text incorrectly,


STEPS TO REPRODUCE
1. Use FiraCode Nerd Font 10pt as the font
2. In ZSH with fast-syntax-highlighting enabled, type using a bold error color, type in ddd and then dd to see the comparison of incorrect bold rendering

OBSERVED RESULT
Bold seems to be raised compared to standard

EXPECTED RESULT
On the same line

SOFTWARE/OS VERSIONS
Linux/KDE: openSUSE Tumbleweed 20240112
(available in About System)
KDE Plasma Version: 6.0.80
KDE Frameworks Version: Version: 5.249.0
Qt Version: 6.6.1

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2024-01-16 23:14:39 UTC
This is caused by an upstream packaging issue in openSUSE: see https://bugzilla.opensuse.org/show_bug.cgi?id=1199938.

I do see that the above bug report is marked as fixed, so it might have regressed recently. Either way, I'd recommend following up with the openSUSE Folks about it.
Comment 2 Fabian Vogt 2024-01-17 06:43:13 UTC
The bold part of that screenshot looks fine to me, just the @ looks broken.

That was supposedly fixed with https://bugzilla.opensuse.org/show_bug.cgi?id=1217542 though.