Bug 477478 - Preview of running apps on taskbar are "empty"
Summary: Preview of running apps on taskbar are "empty"
Status: RESOLVED DUPLICATE of bug 473703
Alias: None
Product: KPipeWire
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: qt6
: 473483 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-11-24 20:21 UTC by semlraug
Modified: 2024-06-12 14:28 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenprint, left top corner showing empty preview (159.05 KB, image/png)
2023-11-24 20:21 UTC, semlraug
Details
Here's my log. (19.82 KB, text/x-log)
2023-12-16 11:08 UTC, popov895
Details

Note You need to log in before you can comment on or make changes to this bug.
Description semlraug 2023-11-24 20:21:30 UTC
Created attachment 163436 [details]
screenprint, left top corner showing empty preview

SUMMARY
***
Preview of opened app when hovering with mouse above it, are "empty"; see attachment
***


STEPS TO REPRODUCE
1. Open applications
2. Hover with mouse above the application in the taskbar
3. Preview shows up, is empty

OBSERVED RESULT
Empty preview, not showing the "contents"

EXPECTED RESULT
Seeing preview with content

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
Operating System: EndeavourOS 
KDE Plasma Version: 5.27.80
KDE Frameworks Version: 5.245.0
Qt Version: 6.6.0
Kernel Version: 6.6.2-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 3.7 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Manufacturer: Acer
Product Name: Aspire A315-53
System Version: V2.02
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION\
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: Quanta VGA WebCam driver: uvcvideo type: USB
  Display: wayland server: X.org v: 1.21.1.9 with: Xwayland v: 23.2.2
    compositor: kwin_wayland driver: X: loaded: modesetting dri: iris gpu: i915
    resolution: 1920x1080
  API: EGL v: 1.5 drivers: iris,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
    renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  API: ALSA v: k6.6.2-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.85 status: active
Comment 1 Nate Graham 2023-11-26 17:14:35 UTC
Are you seeing this 100% of the time for all apps?
...Or only some of the time for all apps?
...Of all of the time, but only for some apps?
...Or only some of the time for some apps?
Comment 2 semlraug 2023-11-26 19:51:01 UTC
All apps on the taskbar all of the time.

I have now opened: Dolphin, Firefox, Thunderbird, System Settings, VLC and KeepassXC; all previews are empty, except for a title text; VLC shows rewind, play en forward button. But the rest of the preview is empty/black.
Comment 3 Nate Graham 2023-11-29 19:22:26 UTC
Thanks. And does screen recording in Spectacle also fail?
Comment 4 semlraug 2023-11-29 19:35:48 UTC
Spectacle also fails.
Comment 5 Nate Graham 2023-11-30 20:44:43 UTC
Ok, so yeah, it's some kind of issue in KPipeWire not working properly for you at all. Do you in fact have kpipewire and its dependencies installed? Have you manually held back the pipewire package or something?
Comment 6 semlraug 2023-12-01 08:16:15 UTC
According to my system I have 2 kpipewire's installed:

2 extra/kpipewire 5.27.9-1 (85.1 KiB 286.7 KiB) [plasma] (Installed: 5.90.0-1)
    Components relating to pipewire use in Plasma
1 kde-unstable/kpipewire 5.90.0-1 (125.3 KiB 424.9 KiB) [plasma] (Installed)
    Components relating to pipewire use in Plasma
Comment 7 Nate Graham 2023-12-01 17:38:54 UTC
Sounds like there are packaging conflicts. You should only have one version of KPipeWire installed. If you're using the Plasma 6 beta, the correct version is the 5.90 one.
Comment 8 semlraug 2023-12-01 17:56:17 UTC
Thanks, Nate. I'll head over to EndeavourOS to ask others about this conflict and how to resolve it.

If you're certain that this is the rootcause, then we can consider this report as "resolver", I think. Do you agree?
Comment 9 Nate Graham 2023-12-01 18:09:23 UTC
I'm not 100% certain, but I think it's a good bet. We can mark this as RESOLVED DOWNSTREAM for now, and re-open it later if needed.
Comment 10 semlraug 2023-12-01 18:31:00 UTC
According to the experts over at endeavouros I only have 1 version of kpipewire installed.

This command:

yay -Qs kpipewire

shows the locally installed packages, they say.

The output on my system is:

local/kpipewire 5.90.0-1 (plasma)
    Components relating to pipewire use in Plasma

Which means only 5.90 is installed.

As such there is no conflict.

Only trying to help.
Not sure how I can help to provide more info for you guys.
Comment 11 semlraug 2023-12-02 11:32:34 UTC
I started spectacle from cli.
Got this output:

kpipewire_record_logging: VAAPI: Failed to initialize display
kpipewire_record_logging: DRM device not found
kpipewire_record_logging: VAAPI: Failed to initialize display
kpipewire_record_logging: DRM device not found
qt.qml.typeresolution.cycle: Cyclic dependency detected between "qrc:/qt/qml/org/kde/desktop/private/TextFieldContextMenu.qml" and "qrc:/qt/qml/org/kde/desktop/MenuItem.qml"
kpipewire_record_logging: VAAPI: Failed to initialize display
kpipewire_record_logging: DRM device not found
kpipewire_record_logging: VAAPI: Failed to initialize display
kpipewire_record_logging: DRM device not found
[libvpx-vp9 @ 0x7f741446be40] v1.13.1
kpipewire_dmabuf_logging: eglChooseConfig returned this many configs: 1
*** pw_stream_destroy called from wrong context, check thread and locking: Not in loop
*** impl_ext_end_proxy called from wrong context, check thread and locking: Not in loop
'pthread_equal(impl->thread, thread_id)' failed at ../pipewire/spa/plugins/support/loop.c:363 loop_leave()
kf.kio.workers.file: copy() QUrl("file:///tmp/Spectacle.fibEfN/Screencast_20231202_122604.webm") to QUrl("file:///home/willemh/Video's/Schermopnamen/Screencast_20231202_122604.webm") mode= -1
qt.multimedia.ffmpeg.mediadataholder: AVStream duration -9223372036854775808 is invalid. Taking it from the metadata
qt.qml.context: qrc:/qt/qml/org/kde/spectacle/private/Gui/InlineMessage.qml:20:5 Parameter "link" is not declared. Injection of parameters into signal handlers is deprecated. Use JavaScript functions with formal parameters instead.
kf.service.services: KApplicationTrader: mimeType "x-scheme-handler/file" not found
VLC media player 3.0.20 Vetinari (revision 3.0.20-0-g6f0d0ab126b)
[000055969ed89550] main libvlc: Vlc draait met de standaardinterface. Gebruik 'cvlc' om vlc zonder interface te gebruiken.
[00007f30e0005c20] gl gl: Initialized libplacebo v5.264.1 (API v264)
[00007f30e0005c20] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
[00007f30e0005c20] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
Xlib:  extension "DRI2" missing on display ":1".
libva error: vaGetDriverNames() failed with operation failed
[00007f30e0005c20] glconv_vaapi_drm gl error: vaInitialize: operation failed
[00007f30e0005c20] gl gl: Initialized libplacebo v5.264.1 (API v264)
Failed to open VDPAU backend libvdpau_nvidia.so: kan gedeeld objectbestand niet openen: Bestand of map bestaat niet
[00007f30e0005c20] gl gl: Initialized libplacebo v5.264.1 (API v264)
[00007f30f8c13100] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
Comment 12 semlraug 2023-12-02 11:34:01 UTC
BTW: at above last attempt a screen recording *was*  made. But "previews" of running applications still are empty.
Comment 13 popov895 2023-12-11 14:17:40 UTC
Looks like I have a similar issue. Sometimes the previews don't appear at all, but mostly they appear after the taskbar hangs for a second. 

Here's the log:
> kf5idletime_wayland: This plugin does not support polling idle time
> Started Dolphin - File Manager.
> kf.service.services: The desktop entry file "/usr/share/applications/org.freedesktop.Xwayland.desktop" has Type= "Application" but has no Exec field.
> kf.service.services: The desktop entry file "/usr/share/applications/org.freedesktop.Xwayland.desktop" has Type= "Application" but has no Exec field.
> Omitting both --window and --windowclass arguments is not recommended
> kpipewire_logging: PipeWire remote error:  -2 target not found
> kpipewire_logging: PipeWire remote error:  -2 unknown resource 2 op:4
> kpipewire_logging: PipeWire remote error:  -2 unknown resource 2 op:4
> kpipewire_logging: PipeWire remote error:  -2 unknown resource 2 op:4
> kpipewire_logging: PipeWire remote error:  -2 unknown resource 2 op:4
> kpipewire_logging: PipeWire remote error:  -2 unknown resource 2 op:4
> kpipewire_logging: PipeWire remote error:  -2 unknown resource 2 op:7
> QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*

No such issue on X11.
Comment 14 popov895 2023-12-11 14:18:56 UTC
SOFTWARE/OS VERSIONS

Operating System: openSUSE Tumbleweed 20231209
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.112.0
Qt Version: 5.15.11
Kernel Version: 6.6.3-1-default (64-bit)
Graphics Platform: Wayland
Graphics Processor: Mesa Intel® UHD Graphics 620
Comment 15 Arjen Hiemstra 2023-12-14 15:41:47 UTC
*** Bug 473483 has been marked as a duplicate of this bug. ***
Comment 16 David Edmundson 2023-12-14 15:44:40 UTC
Can you run 


`QT_LOGGING_RULES=kpipewire*.debug=true plasmashell --replace` and attach a log of a non-loading preview
Comment 17 semlraug 2023-12-14 19:42:44 UTC
I'm no advanced user or dev. I ran the command and hovered over one of the non loading previews.
This was the output in terminal:

`QT_LOGGING_RULES=kpipewire*.debug=true plasmashell --replace`
```
KPackageStructure of KPluginMetaData(pluginId:"org.kde.kdeconnect", fileName: "/usr/share/plasma/plasmoids/org.kde.kdeconnect/metadata.json") does not match requested format "Plasma/Applet"
kf.plasma.quick: Applet preload policy set to 1
file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/main.qml:196:25: QML FolderViewDropArea (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "minimumWidth"
qt.qml.typeresolution.cycle: Cyclic dependency detected between "qrc:/qt/qml/org/kde/desktop/private/TextFieldContextMenu.qml" and "qrc:/qt/qml/org/kde/desktop/MenuItem.qml"
qt.core.qobject.connect: QObject::connect(QWindow, PlasmaQuick::AppletPopup): invalid nullptr parameter
qt.core.qobject.connect: QObject::connect(QWindow, PlasmaQuick::AppletPopup): invalid nullptr parameter
file:///usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/main.qml:162:21: QML KSortFilterProxyModel: Binding loop detected for property "sourceModel"
file:///usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/main.qml:162:21: QML KSortFilterProxyModel: Binding loop detected for property "sourceModel"
qt.qml.typeresolution.cycle: Cyclic dependency detected between "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml" and "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationHeader.qml"
qt.qml.typeresolution.cycle: Cyclic dependency detected between "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml" and "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/ThumbnailStrip.qml"
qml: SystemTray ItemLoader: Invalid state, cannot determine source!
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:78: TypeError: Property 'i18nCity' of object TimezonesI18n(0x557179b0f740) is not a function
qt.dbus.integration: Could not connect "org.cups.cupsd.Notifier" to PrinterFinishingsChanged(QString, QString, QString, uint, QString, bool) : 
QFont::setPointSizeF: Point size <= 0 (0.000000), must be greater than 0
file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Panel.qml:118:5: QML Connections: Detected function "onActivated" in Connections element. This is probably intended to be a signal handler but no signal of the target matches the name.
qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml:201:9: QML QQuickImage: Error decoding: qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml?timestamp=1702582732637: Niet-ondersteund afbeeldingsformaat
qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml:201:9: QML QQuickImage: Error decoding: qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml?timestamp=1702582732637: Niet-ondersteund afbeeldingsformaat
qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml:201:9: QML QQuickImage: Error decoding: qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml?timestamp=1702582732637: Niet-ondersteund afbeeldingsformaat
kf.windowsystem: static bool KX11Extras::hasWId(WId) may only be used on X11
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 73
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:78: TypeError: Type error
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 73
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> streaming 
```
Comment 18 semlraug 2023-12-14 19:53:16 UTC
Tried again and had two applications that showed empty previews; hovered above the one, then the other and back again, several times:

QT_LOGGING_RULES=kpipewire*.debug=true plasmashell --replace`
KPackageStructure of KPluginMetaData(pluginId:"org.kde.kdeconnect", fileName: "/usr/share/plasma/plasmoids/org.kde.kdeconnect/metadata.json") does not match requested format "Plasma/Applet"
kf.plasma.quick: Applet preload policy set to 1
file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/main.qml:196:25: QML FolderViewDropArea (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "minimumWidth"
qt.qml.typeresolution.cycle: Cyclic dependency detected between "qrc:/qt/qml/org/kde/desktop/private/TextFieldContextMenu.qml" and "qrc:/qt/qml/org/kde/desktop/MenuItem.qml"
qt.core.qobject.connect: QObject::connect(QWindow, PlasmaQuick::AppletPopup): invalid nullptr parameter
qt.core.qobject.connect: QObject::connect(QWindow, PlasmaQuick::AppletPopup): invalid nullptr parameter
file:///usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/main.qml:162:21: QML KSortFilterProxyModel: Binding loop detected for property "sourceModel"
file:///usr/share/plasma/plasmoids/org.kde.plasma.private.systemtray/contents/ui/main.qml:162:21: QML KSortFilterProxyModel: Binding loop detected for property "sourceModel"
qt.qml.typeresolution.cycle: Cyclic dependency detected between "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml" and "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/ThumbnailStrip.qml"
qt.qml.typeresolution.cycle: Cyclic dependency detected between "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/global/Globals.qml" and "file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationHeader.qml"
qml: SystemTray ItemLoader: Invalid state, cannot determine source!
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:78: TypeError: Property 'i18nCity' of object TimezonesI18n(0x5577cf7b1c10) is not a function
qt.dbus.integration: Could not connect "org.cups.cupsd.Notifier" to PrinterFinishingsChanged(QString, QString, QString, uint, QString, bool) : 
QFont::setPointSizeF: Point size <= 0 (0.000000), must be greater than 0
file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Panel.qml:118:5: QML Connections: Detected function "onActivated" in Connections element. This is probably intended to be a signal handler but no signal of the target matches the name.
qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml:201:9: QML QQuickImage: Error decoding: qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml?timestamp=1702583361081: Niet-ondersteund afbeeldingsformaat
qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml:201:9: QML QQuickImage: Error decoding: qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml?timestamp=1702583361081: Niet-ondersteund afbeeldingsformaat
qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml:201:9: QML QQuickImage: Error decoding: qrc:/qt/qml/org/kde/kirigamiaddons/components/Avatar.qml?timestamp=1702583361081: Niet-ondersteund afbeeldingsformaat
kf.windowsystem: static bool KX11Extras::hasWId(WId) may only be used on X11
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 75
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 60
kpipewire_logging: PipeWire remote error:  -2 target not found
kpipewire_logging: PipeWire remote error:  -2 unknown resource 5 op:4
kpipewire_logging: received error message "unknown resource 5 op:4"
kpipewire_logging: PipeWire remote error:  -2 unknown resource 5 op:7
kpipewire_logging: received error message "unknown resource 5 op:7"
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: 0x1: using glBufferSubData(buffer 129, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: PipeWire remote error:  -2 target not found
kpipewire_logging: PipeWire remote error:  -2 unknown resource 6 op:4
kpipewire_logging: PipeWire remote error:  -2 unknown resource 6 op:7
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 76
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: 0x1: using glBufferSubData(buffer 141, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 139, offset 0, size 320) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 137, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 135, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: 0x1: using glBufferSubData(buffer 145, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 152, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 150, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 139, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 141, offset 0, size 80) to update a GL_STATIC_DRAW buffer
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 76
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: PipeWire remote error:  -2 target not found
kpipewire_logging: PipeWire remote error:  -2 unknown resource 6 op:4
kpipewire_logging: PipeWire remote error:  -2 unknown resource 6 op:7
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 59
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: 0x1: using glBufferSubData(buffer 149, offset 0, size 64) to update a GL_STATIC_DRAW buffer
kpipewire_logging: 0x1: using glBufferSubData(buffer 145, offset 0, size 80) to update a GL_STATIC_DRAW buffer
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 59
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 59
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: PipeWire remote error:  -2 target not found
kpipewire_logging: PipeWire remote error:  -2 unknown resource 6 op:4
kpipewire_logging: PipeWire remote error:  -2 unknown resource 6 op:7
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 74
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 74
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kf.windowsystem: static bool KX11Extras::hasWId(WId) may only be used on X11
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 74
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 
kpipewire_logging: state changed streaming -> paused 
kpipewire_logging: state changed paused -> unconnected 
kpipewire_logging: Format  875710290  not supported for modifiers.
kpipewire_logging: state changed unconnected -> connecting 
kpipewire_logging: created successfully 75
kpipewire_logging: state changed connecting -> paused 
kpipewire_logging: state changed paused -> streaming 

I hope this is what you are looking for.
Comment 19 popov895 2023-12-16 11:08:09 UTC
Created attachment 164221 [details]
Here's my log.
Comment 20 Dashon 2024-03-13 11:50:23 UTC
The issue for me is that sometimes they appear and sometimes they do not or take a while to appear.
Comment 21 ian karlsson 2024-05-29 04:59:57 UTC
I have noticed this as well, but only with one application Brave (web browser). To me, it started happening after I locked the desktop and left the computer idle overnight. All other applications had thumbnails rendering OK and restarting Brave would temporarily fix the issue. 

The error I saw in the journalctl output is similar to what has been reported by others:

plasmashell[66949]: kpipewire_logging: PipeWire remote error:  -2 unknown resource 8 op:4

I also noticed bug #477478 which seems to be duplicate.
Comment 22 ian karlsson 2024-05-29 05:03:26 UTC
Correction to the above, bug #473703 is what I was referring to.
Comment 23 Nate Graham 2024-06-12 14:28:39 UTC

*** This bug has been marked as a duplicate of bug 473703 ***