Bug 476022 - Crash while copying to usb drive
Summary: Crash while copying to usb drive
Status: RESOLVED DUPLICATE of bug 448532
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 23.08.2
Platform: Arch Linux Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2023-10-23 21:58 UTC by mattia.mari
Modified: 2023-11-29 08:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mattia.mari 2023-10-23 21:58:06 UTC
Application: dolphin (23.08.2)

Qt Version: 5.15.11
Frameworks Version: 5.111.0
Operating System: Linux 6.5.8-arch1-1 x86_64
Windowing System: Wayland
Distribution: Arch Linux
DrKonqi: 5.27.8 [KCrashBackend]

-- Information about the crash:
Dolphin crashed while copying about 50GB to a usb drive. The window was closed, only the copy progress in the taskbar was visible. It reached about half progress when I left the PC and was already crashed when I got back hours later.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  0x00007f18be6d044d in qobject_cast<QWidget*>(QObject*) (o=0x56002bd38830) at /usr/include/qt/QtWidgets/qwidget.h:755
#7  QtPrivate::QVariantValueHelper<QWidget*>::object(QVariant const&) (v=...) at /usr/include/qt/QtCore/qvariant.h:753
#8  QtPrivate::ObjectInvoker<QtPrivate::QVariantValueHelper<QWidget*>, QVariant const&, QWidget*>::invoke(QVariant const&) (a=...) at /usr/include/qt/QtCore/qvariant.h:107
#9  qvariant_cast<QWidget*>(QVariant const&) (v=...) at /usr/include/qt/QtCore/qvariant.h:879
#10 QVariant::value<QWidget*>() const (this=0x7fffbcb040d0) at /usr/include/qt/QtCore/qvariant.h:367
#11 KJobWidgets::window(KJob*) (job=job@entry=0x56002c0cb5b0) at /usr/src/debug/kjobwidgets5/kjobwidgets-5.111.0/src/kjobwidgets.cpp:22
#12 0x00007f18be7d76c0 in KIO::WidgetsAskUserActionHandler::askUserSkip(KJob*, QFlags<KIO::SkipDialog_Option>, QString const&) (this=this@entry=0x56002c1eda00, job=job@entry=0x56002c0cb5b0, options=..., options@entry=..., errorText=...) at /usr/src/debug/kio5/kio-5.111.0/src/widgets/widgetsaskuseractionhandler.cpp:167
#13 0x00007f18be54b460 in KIO::CopyJobPrivate::slotResultErrorCopyingFiles(KJob*) (this=<optimized out>, job=0x56002c0a49e0) at /usr/src/debug/kio5/kio-5.111.0/src/core/copyjob.cpp:1765
#14 0x00007f18bc8d1097 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7fffbcb043a0, r=<optimized out>, this=0x56002bfa5250, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#15 doActivate<false>(QObject*, int, void**) (sender=0x56002c0a49e0, signal_index=6, argv=0x7fffbcb043a0) at kernel/qobject.cpp:3925
#16 0x00007f18bddbd0fa in KJob::result(KJob*, KJob::QPrivateSignal) (this=this@entry=0x56002c0a49e0, _t1=<optimized out>, _t1@entry=0x56002c0a49e0, _t2=...) at /usr/src/debug/kcoreaddons5/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#17 0x00007f18bddc30cc in KJob::finishJob(bool) (this=0x56002c0a49e0, emitResult=<optimized out>) at /usr/src/debug/kcoreaddons5/kcoreaddons-5.111.0/src/lib/jobs/kjob.cpp:98
#18 0x00007f18bc8d1097 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7fffbcb044d0, r=<optimized out>, this=0x56002b9630d0, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#19 doActivate<false>(QObject*, int, void**) (sender=0x56002bfa50a0, signal_index=6, argv=0x7fffbcb044d0) at kernel/qobject.cpp:3925
#20 0x00007f18bddbd0fa in KJob::result(KJob*, KJob::QPrivateSignal) (this=this@entry=0x56002bfa50a0, _t1=<optimized out>, _t1@entry=0x56002bfa50a0, _t2=...) at /usr/src/debug/kcoreaddons5/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#21 0x00007f18bddc30cc in KJob::finishJob(bool) (this=0x56002bfa50a0, emitResult=<optimized out>) at /usr/src/debug/kcoreaddons5/kcoreaddons-5.111.0/src/lib/jobs/kjob.cpp:98
#22 0x00007f18bc8d1097 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7fffbcb04600, r=<optimized out>, this=0x56002c3ccf40, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#23 doActivate<false>(QObject*, int, void**) (sender=0x56002c45fd90, signal_index=5, argv=0x7fffbcb04600) at kernel/qobject.cpp:3925
#24 0x00007f18be56f5bb in KIO::SlaveInterface::error(int, QString const&) (this=this@entry=0x56002c45fd90, _t1=<optimized out>, _t2=...) at /usr/src/debug/kio5/build/src/core/KF5KIOCore_autogen/include/moc_slaveinterface.cpp:452
#25 0x00007f18be574dc0 in KIO::SlaveInterface::dispatch(int, QByteArray const&) (this=0x56002c45fd90, _cmd=102, rawdata=...) at /usr/src/debug/kio5/kio-5.111.0/src/core/slaveinterface.cpp:181
#26 0x00007f18be56f3da in KIO::SlaveInterface::dispatch() (this=0x56002c45fd90) at /usr/src/debug/kio5/kio-5.111.0/src/core/slaveinterface.cpp:78
#27 0x00007f18be571e32 in KIO::Slave::gotInput() (this=0x56002c45fd90) at /usr/src/debug/kio5/kio-5.111.0/src/core/slave.cpp:354
#28 0x00007f18bc8d1097 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7fffbcb04820, r=<optimized out>, this=0x56002cb33870, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#29 doActivate<false>(QObject*, int, void**) (sender=0x56002c0563a0, signal_index=3, argv=0x7fffbcb04820) at kernel/qobject.cpp:3925
#30 0x00007f18bc8c3bd4 in QObject::event(QEvent*) (this=0x56002c0563a0, e=0x56002c41f350) at kernel/qobject.cpp:1347
#31 0x00007f18bd5788ff in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x56002c0563a0, e=0x56002c41f350) at kernel/qapplication.cpp:3640
#32 0x00007f18bc89c168 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x56002c0563a0, event=0x56002c41f350) at kernel/qcoreapplication.cpp:1064
#33 0x00007f18bc8a10cb in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x56002b77c550) at kernel/qcoreapplication.cpp:1821
#34 0x00007f18bc8e7138 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x56002b7ba5b0) at kernel/qeventdispatcher_glib.cpp:277
#35 0x00007f18ba70df19 in g_main_dispatch (context=0x7f18b0000ec0) at ../glib/glib/gmain.c:3476
#36 0x00007f18ba76c2b7 in g_main_context_dispatch_unlocked (context=0x7f18b0000ec0) at ../glib/glib/gmain.c:4284
#37 g_main_context_iterate_unlocked.isra.0 (context=context@entry=0x7f18b0000ec0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/glib/gmain.c:4349
#38 0x00007f18ba70c112 in g_main_context_iteration (context=0x7f18b0000ec0, may_block=1) at ../glib/glib/gmain.c:4414
#39 0x00007f18bc8eaf7c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x56002b7bf020, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#40 0x00007f18bc89ae74 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fffbcb04ca0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#41 0x00007f18bc89c313 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#42 0x00007f18bcd3bf02 in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1870
#43 0x00007f18bd576cda in QApplication::exec() () at kernel/qapplication.cpp:2832
#44 0x000056002a3e8db8 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/dolphin/dolphin-23.08.2/src/main.cpp:255
[Inferior 1 (process 2943) detached]

The reporter indicates this bug may be a duplicate of or related to bug 474872.

Reported using DrKonqi
Comment 1 Akseli Lahtinen 2023-11-29 08:16:29 UTC

*** This bug has been marked as a duplicate of bug 448532 ***