Bug 474491 - isOnCifsMount does not check for nullptr
Summary: isOnCifsMount does not check for nullptr
Status: RESOLVED DUPLICATE of bug 474451
Alias: None
Product: frameworks-kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.110.0
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-09-13 14:26 UTC by mike
Modified: 2023-09-13 15:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike 2023-09-13 14:26:57 UTC
SUMMARY
***
I get a segfault triggered in kio_file gdb reveals this stacktrace:

#0  KMountPoint::mountType() const (this=0x0) at /usr/src/kio-5.110.0-0ubuntu1~ubuntu23.04~ppa1/src/core/kmountpoint.cpp:411
#1  0x00007fff9c114f24 in isOnCifsMount (filePath=...) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qshareddata.h:161
#2  FileProtocol::copy(QUrl const&, QUrl const&, int, QFlags<KIO::JobFlag>) (this=0x7fff60000fd0, srcUrl=<optimized out>, destUrl=<optimized out>, _mode=-1, _flags=...) at /usr/src/kio-5.110.0-0ubuntu1~ubuntu23.04~ppa1/src/ioslaves/file/file_unix.cpp:743
#3  0x00007ffff36ec946 in KIO::SlaveBase::dispatch(int, QByteArray const&) (this=0x7fff60000fe0, command=<optimized out>, data=...) at /usr/src/kio-5.110.0-0ubuntu1~ubuntu23.04~ppa1/src/core/slavebase.cpp:1364
#4  0x00007ffff36ed516 in KIO::SlaveBase::dispatchLoop() (this=0x7fff60000fe0) at /usr/src/kio-5.110.0-0ubuntu1~ubuntu23.04~ppa1/src/core/slavebase.cpp:342
#5  0x00007ffff3789d32 in KIO::WorkerThread::run() (this=0x555557106e20) at /usr/src/kio-5.110.0-0ubuntu1~ubuntu23.04~ppa1/src/core/workerthread.cpp:62
#6  0x00007ffff60cccc7 in QThreadPrivate::start(void*) (arg=0x555557106e20) at thread/qthread_unix.cpp:331
#7  0x00007ffff588f18a in start_thread (arg=<optimized out>) at ./nptl/pthread_create.c:444
#8  0x00007ffff591dbd0 in clone3 () at ../sysdeps/unix/sysv/linux/x86_64/clone3.S:81

this is triggered by file_unix.cpp in isOnCifsMount.

KMountPoint::List::findByPath obviosly may return a nullptr
***

STEPS TO REPRODUCE
open kdevelop (23.04.3)
open project

OBSERVED RESULT
see immediate crash
the crashing operation is
kf.kio.workers.file: copy() QUrl("file:///<valid path>.kdev4") to QUrl("file:///tmp/kdevelop.IqlheG") mode= -1
EXPECTED RESULT
no crash

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: Ubuntu 23.04 + kubuntu-ppa

KDE Plasma Version: 5.27.8
KDE Frameworks Version:  5.110.0
Qt Version: 5.15.8

ADDITIONAL INFORMATION
Comment 1 Antonio Rojas 2023-09-13 15:50:45 UTC

*** This bug has been marked as a duplicate of bug 474451 ***