Bug 474181 - Plasma panel visually (but not functionally) freezing with Wayland+AMD GPU
Summary: Plasma panel visually (but not functionally) freezing with Wayland+AMD GPU
Status: RESOLVED DUPLICATE of bug 469016
Alias: None
Product: plasmashell
Classification: Plasma
Component: Window List (show other bugs)
Version: 5.27.7
Platform: Neon Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
Depends on:
Reported: 2023-09-05 09:34 UTC by Martin Tlustos
Modified: 2023-09-07 13:17 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Note You need to log in before you can comment on or make changes to this bug.
Description Martin Tlustos 2023-09-05 09:34:58 UTC
When starting kwin wayland, after a while, the window list freezes and doesn't show any changes for my opened programs. Also, when I close al programs and click on the symbol of one program in the window list, all closed programs that are still visible in the frozen window list are opened up again.

NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports

1.  start plasma wayland
2.  open a bunch of programs (in my case kontact, firefox, system monitor and dolphin)
3. do things until the window list freezes (in my case, this happened pretty fast)
4. close all programs
5. click on the symbol of kontact (or any other program on the window list), which is still visible as being open

All programs that still have icons on the window list get reopened

No freeze, no reopening.

Operating System: KDE neon 5.27
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.108.0
Qt Version: 5.15.10
Kernel Version: 6.2.0-32-generic (64-bit)
Graphics Platform: Wayland
Processors: 6 × AMD Ryzen 5 4500U with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: Acer
Product Name: Aspire A515-44G
System Version: V1.12

Additional Info:
It is the symbol only window list, not the standard one.
Comment 1 Martin Tlustos 2023-09-05 09:38:19 UTC
The same thing happens with the standard window list.

Oh, and I have put my panel on the left side of the screen, so not standard at the bottom.
Comment 2 Nate Graham 2023-09-05 19:40:43 UTC
Can you confirm that you are using the widget actually named "Window list"? Or is it named "Task manager" or "Icons-Only Task Manager?"

Does the rest of the panel contents freeze too--such as the Digital Clock or the System Tray?
Comment 3 Martin Tlustos 2023-09-06 08:28:17 UTC
Well, in German it is called "Fensterleiste nur mit Symbolen", but in English it might be called "Icons-only Task Manager"... ;-)

The list somehow half-freezes. Animations and icon changes freeze (like the spinning wheel on kontact right now doesn't go away, and dolphin isnt shown as being opened).
The clock does not show time updates, but I can still click it and it will open the mini calendar.
Opening the system tray works, but without animations.

I tried doing a video with spectacle, but then my system becomes unresponsive, and the cpu usage goes to 100%, so I can't do it unfortunately.
Comment 4 Martin Tlustos 2023-09-06 09:08:32 UTC
Some more weird behavior:
- Programs opened after the freeze do not show up in the list, nor do they show up when doing ALT-TAB, but they show up in system monitor.
Comment 5 Nate Graham 2023-09-06 16:46:21 UTC
Thanks. The symptoms seem to be the same as in Bug 469016, but that one says it's specific to NVIDIA GPUs. Maybe there's a codepath here that affects AMD GPUs.
Comment 6 Alessandro Astone 2023-09-06 16:49:32 UTC
(In reply to Nate Graham from comment #5)
> Thanks. The symptoms seem to be the same as in Bug 469016, but that one says
> it's specific to NVIDIA GPUs. Maybe there's a codepath here that affects AMD
> GPUs.

Well, does this bug also happen only if "Show small window previews when hovering over Tasks" is enabled in the Icons-only Task Manager Settings?

That's the main takeaway from the other bug
Comment 7 Vlad Zahorodnii 2023-09-07 06:53:36 UTC
Did you change anything in "plasma renderer" settings? Please share your kdeglobalsrc
Comment 8 Martin Tlustos 2023-09-07 08:40:01 UTC
which one? I have three kdeglobals: one in ./config/kdedefaults, one in ./config, and one in ./kde/share/config...
The one in ./config has been changed a couple of minutes ago (probably on login), the other two haven't changed since 2022.
Comment 9 Martin Tlustos 2023-09-07 08:50:56 UTC
It seems to be a duplicate of  Bug 469016. I tried the workarounds mentioned, and they work for me as well (moving the panel around).
Comment 10 Martin Tlustos 2023-09-07 08:57:20 UTC
Pretty sure it's aduplicate. I disbaled windows previews and it now seems to work.

*** This bug has been marked as a duplicate of bug 469016 ***