Bug 473491 - kwin crash ?
Summary: kwin crash ?
Status: RESOLVED DUPLICATE of bug 473426
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2023-08-17 21:53 UTC by EBiForE
Modified: 2023-08-17 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description EBiForE 2023-08-17 21:53:38 UTC
Application: systemsettings (5.27.7)

Qt Version: 5.15.10
Frameworks Version: 5.109.0
Operating System: Linux 6.2.0-26-generic x86_64
Windowing System: X11
Distribution: KDE neon Testing Edition
DrKonqi: 5.27.7 [KCrashBackend]

-- Information about the crash:
no window title bar
i can't move windows
i can't use shortcut
i can't use desktop

The crash can be reproduced every time.

-- Backtrace:
Application: Impostazioni di sistema (systemsettings), signal: Aborted

[KCrash Handler]
#4  __pthread_kill_implementation (no_tid=0, signo=6, threadid=140006791710208) at ./nptl/pthread_kill.c:44
#5  __pthread_kill_internal (signo=6, threadid=140006791710208) at ./nptl/pthread_kill.c:78
#6  __GI___pthread_kill (threadid=140006791710208, signo=signo@entry=6) at ./nptl/pthread_kill.c:89
#7  0x00007f55e3442476 in __GI_raise (sig=sig@entry=6) at ../sysdeps/posix/raise.c:26
#8  0x00007f55e34287f3 in __GI_abort () at ./stdlib/abort.c:79
#9  0x00007f55e34896f6 in __libc_message (action=action@entry=do_abort, fmt=fmt@entry=0x7f55e35db943 "*** %s ***: terminated\n") at ../sysdeps/posix/libc_fatal.c:155
#10 0x00007f55e353676a in __GI___fortify_fail (msg=msg@entry=0x7f55e35db92b "stack smashing detected") at ./debug/fortify_fail.c:26
#11 0x00007f55e3536736 in __stack_chk_fail () at ./debug/stack_chk_fail.c:24
#12 0x00007f55e1ba7f3a in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#13 0x00007f55e1ba8d35 in QV4::QObjectWrapper::virtualResolveLookupGetter(QV4::Object const*, QV4::ExecutionEngine*, QV4::Lookup*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#14 0x00007f55e1bc84e5 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#15 0x00007f55e1bccf5f in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f55e1b5ee3e in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#17 0x00007f55e1cebb35 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#18 0x00007f55e1c9c56b in QQmlBoundSignalExpression::evaluate(void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#19 0x00007f55e1c9dca8 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#20 0x00007f55e1cd0795 in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#21 0x00007f55e3ef44ab in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f55e1cd0795 in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#23 0x00007f55e3ef44ab in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f55e1cd0795 in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#25 0x00007f55e3ef44ab in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007f55e226a9a8 in QQuickItemPrivate::removeChild(QQuickItem*) () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#27 0x00007f55e226c26c in QQuickItem::setParentItem(QQuickItem*) () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#28 0x00007f55e2272803 in QQuickItem::qt_metacall(QMetaObject::Call, int, void**) () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#29 0x00007f55e22ecbea in QQuickFlickable::qt_metacall(QMetaObject::Call, int, void**) () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#30 0x00007f55e233af4a in QQuickItemView::qt_metacall(QMetaObject::Call, int, void**) () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#31 0x00007f55e234caaa in QQuickListView::qt_metacall(QMetaObject::Call, int, void**) () from /lib/x86_64-linux-gnu/libQt5Quick.so.5
#32 0x00007f55e1c8b8de in QQmlPropertyPrivate::write(QObject*, QQmlPropertyData const&, QVariant const&, QQmlContextData*, QFlags<QQmlPropertyData::WriteFlag>) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#33 0x00007f55e1bae232 in QV4::QObjectWrapper::setProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData*, QV4::Value const&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#34 0x00007f55e1bae7d2 in QV4::QObjectWrapper::setQmlProperty(QV4::ExecutionEngine*, QQmlContextData*, QObject*, QV4::String*, QV4::QObjectWrapper::RevisionMode, QV4::Value const&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#35 0x00007f55e1bae975 in QV4::QObjectWrapper::virtualPut(QV4::Managed*, QV4::PropertyKey, QV4::Value const&, QV4::Value*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#36 0x00007f55e1b359b7 in QV4::Lookup::setterFallback(QV4::Lookup*, QV4::ExecutionEngine*, QV4::Value&, QV4::Value const&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#37 0x00007f55e1bc8bb2 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#38 0x00007f55e1bccf5f in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#39 0x00007f55e1b5ee3e in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#40 0x00007f55e1cebb35 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#41 0x00007f55e1c9c56b in QQmlBoundSignalExpression::evaluate(void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#42 0x00007f55e1c9dca8 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#43 0x00007f55e1cd0795 in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#44 0x00007f55e3ef44ab in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#45 0x00007f55e1d01d1c in QQmlObjectCreator::finalize(QQmlInstantiationInterrupt&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#46 0x00007f55e1c9013c in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#47 0x00007f55e1c926e9 in QQmlComponentPrivate::completeCreate() () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#48 0x00007f55e1c92883 in QQmlComponent::create(QQmlContext*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#49 0x00007f55e276812f in QQuickWidget::continueExecute() () from /lib/x86_64-linux-gnu/libQt5QuickWidgets.so.5
#50 0x00007f55b3e20dbf in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/systemsettingsview/systemsettings_sidebar_mode.so
#51 0x00007f55b3e225c1 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/systemsettingsview/systemsettings_sidebar_mode.so
#52 0x00005624afe31f9a in ?? ()
#53 0x00005624afe36a03 in ?? ()
#54 0x00007f55e3eea3ce in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#55 0x00007f55e596e47d in KXmlGuiWindow::event(QEvent*) () from /lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#56 0x00007f55e4b6c763 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#57 0x00007f55e3ebce7a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#58 0x00007f55e3ebff77 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#59 0x00007f55e3f16d17 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#60 0x00007f55e27c7d3b in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007f55e281d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#62 0x00007f55e27c53e3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007f55e3f16368 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#64 0x00007f55e3ebb79b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#65 0x00007f55e3ec3d44 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#66 0x00005624afe2c616 in ?? ()
#67 0x00007f55e3429d90 in __libc_start_call_main (main=main@entry=0x5624afe2bac0, argc=argc@entry=2, argv=argv@entry=0x7ffd5d97d1c8) at ../sysdeps/nptl/libc_start_call_main.h:58
#68 0x00007f55e3429e40 in __libc_start_main_impl (main=0x5624afe2bac0, argc=2, argv=0x7ffd5d97d1c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd5d97d1b8) at ../csu/libc-start.c:392
#69 0x00005624afe2cfa5 in ?? ()
[Inferior 1 (process 8255) detached]

Reported using DrKonqi
This report was filed against 'kde' because the product 'systemsettings' could not be located in Bugzilla. Add it to drkonqi's mappings file!
Comment 1 Nicolas Fella 2023-08-17 22:00:25 UTC

*** This bug has been marked as a duplicate of bug 473426 ***