Bug 472758 - Error while installing the latest updates: libphonon4qt5
Summary: Error while installing the latest updates: libphonon4qt5
Status: CONFIRMED
Alias: None
Product: neon
Classification: KDE Neon
Component: Packages Testing Edition (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR major
Target Milestone: ---
Assignee: Neon Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-07-28 19:41 UTC by Valter Mura
Modified: 2023-09-10 18:09 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valter Mura 2023-07-28 19:41:11 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Try to install the latest updates, both Discover and Muon Package manager
2. 
3. 

OBSERVED RESULT
The system returns the following error:
"Error while updating:
/var/cache/apt/archives/qt5-phonon_4%3a4.11.1+p22.04+tunstable+git20230725.0737-0_amd64.deb
trying to overwrite '/usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4.11.1', which is also in package libphonon4qt5-4"

Than the system quits from the update.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
Operating System: KDE neon Testing Edition
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.109.0
Qt Version: 5.15.10
Kernel Version: 5.19.0-46-generic (64-bit)
Graphics Platform: X11
Comment 1 Moltke 2023-07-28 20:28:13 UTC
I've been getting this too for the past 2 days. Running "sudo apt full-upgrade" updates most things, but still get the "libphonon4qt5" error. 

Operating System: KDE neon Testing Edition
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.109.0
Qt Version: 5.15.10
Kernel Version: 5.19.0-50-generic (64-bit)
Graphics Platform: X11
Comment 2 Moltke 2023-07-29 00:02:52 UTC
Now, "sudo apt full-upgrade" won't work either. :(
Comment 3 Jonathan Riddell 2023-07-31 12:51:36 UTC
Git commit a3713e49f20bf05ac3b743697d5b43d9035115c8 by Jonathan Esk-Riddell.
Committed on 31/07/2023 at 14:51.
Pushed by jriddell into branch 'Neon/unstable'.

breaks and conflicts old package names

M  +16   -4    debian/control
M  +1    -1    debian/qt5-phonon.install

https://invent.kde.org/neon/extras/phonon/-/commit/a3713e49f20bf05ac3b743697d5b43d9035115c8
Comment 4 Moltke 2023-07-31 12:59:35 UTC
Someone at reddit posted the solution: 
"sudo dpkg -i --force-overwrite /var/cache/apt/archives/qt5- phonon_4%3a4.11.1+p22.04+tunstable+git20230725.0737-0_amd64.deb" 
after running that, everything works.
Comment 5 Jonathan Riddell 2023-07-31 13:17:58 UTC
New build fixes this by my testing.

Yes you can force-override for overlapping files but it's nicer just not to have overlapping files so thanks for testing and reporting.
Comment 6 Valter Mura 2023-08-21 18:02:35 UTC
The latest update (2023-08-21) returns the following error, while trying to update (through Discover app):

"Cannot remove the system package:
WARNING: You are trying to remove the following essential packages: qt5-phonon (due to plasma-desktop)"

Please fix it, thank you.
Comment 7 EBiForE 2023-08-21 22:26:16 UTC
(In reply to Valter Mura from comment #6)
> The latest update (2023-08-21) returns the following error, while trying to
> update (through Discover app):
> 
> "Cannot remove the system package:
> WARNING: You are trying to remove the following essential packages:
> qt5-phonon (due to plasma-desktop)"
> 
> Please fix it, thank you.

Same here
Comment 8 EBiForE 2023-08-21 22:26:52 UTC
(In reply to EBiForE from comment #7)
> (In reply to Valter Mura from comment #6)
> > The latest update (2023-08-21) returns the following error, while trying to
> > update (through Discover app):
> > 
> > "Cannot remove the system package:
> > WARNING: You are trying to remove the following essential packages:
> > qt5-phonon (due to plasma-desktop)"
> > 
> > Please fix it, thank you.
> 
> Same here

P.S. Also on fresh install
Comment 9 Valter Mura 2023-08-27 20:11:34 UTC
The system now returns this error:

"Unable updating 1 package
Error while installing package: trying to overwrite '/usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4.11.1', which is also in package qt5-phonon 4"

My system:
Operating System: KDE neon Testing Edition
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.110.0
Qt Version: 5.15.10
Kernel Version: 6.2.0-26-generic (64-bit)
Graphics Platform: X11
Graphics Processor: NVE7 (Nvidia)
Comment 10 Valter Mura 2023-09-03 18:13:25 UTC
And the problem is still here on 2023-09-03:

"Aggiornamento di 1 pacchetto non riuscito
Error while installing package: trying to overwrite '/usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4.11.1', which is also in package qt5-phonon 4"

Operating System: KDE neon Testing Edition
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.110.0
Qt Version: 5.15.10
Kernel Version: 6.2.0-26-generic (64-bit)
Graphics Platform: X11
Graphics Processor: NVE7
Comment 11 EBiForE 2023-09-03 23:42:36 UTC
(In reply to Valter Mura from comment #0)
> SUMMARY
> ***
> NOTE: If you are reporting a crash, please try to attach a backtrace with
> debug symbols.
> See
> https://community.kde.org/Guidelines_and_HOWTOs/Debugging/
> How_to_create_useful_crash_reports
> ***
> 
> 
> STEPS TO REPRODUCE
> 1. Try to install the latest updates, both Discover and Muon Package manager
> 2. 
> 3. 
> 
> OBSERVED RESULT
> The system returns the following error:
> "Error while updating:
> /var/cache/apt/archives/qt5-phonon_4%3a4.11.1+p22.04+tunstable+git20230725.
> 0737-0_amd64.deb
> trying to overwrite '/usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4.11.1',
> which is also in package libphonon4qt5-4"
> 
> Than the system quits from the update.
> 
> SOFTWARE/OS VERSIONS
> Linux/KDE Plasma: 
> Operating System: KDE neon Testing Edition
> KDE Plasma Version: 5.27.6
> KDE Frameworks Version: 5.109.0
> Qt Version: 5.15.10
> Kernel Version: 5.19.0-46-generic (64-bit)
> Graphics Platform: X11

Solution:
sudo apt install xfdesktop4
Enter to XFCE DE
sudo apt-get -o Dpkg::Options::="--force-overwrite" install libphonon4qt5-4
From xfce4-terminal
sudo pkcon refresh -p -v && sudo pkcon get-updates -p -v && sudo pkcon update -p -v && poweroff
Comment 12 Valter Mura 2023-09-04 17:54:51 UTC
(In reply to EBiForE from comment #11)
> (In reply to Valter Mura from comment #0)
> > SUMMARY
> > ***
> > NOTE: If you are reporting a crash, please try to attach a backtrace with
> > debug symbols.
> > See
> > https://community.kde.org/Guidelines_and_HOWTOs/Debugging/
> > How_to_create_useful_crash_reports
> > ***
> > 
> > 
> > STEPS TO REPRODUCE
> > 1. Try to install the latest updates, both Discover and Muon Package manager
> > 2. 
> > 3. 
> > 
> > OBSERVED RESULT
> > The system returns the following error:
> > "Error while updating:
> > /var/cache/apt/archives/qt5-phonon_4%3a4.11.1+p22.04+tunstable+git20230725.
> > 0737-0_amd64.deb
> > trying to overwrite '/usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4.11.1',
> > which is also in package libphonon4qt5-4"
> > 
> > Than the system quits from the update.
> > 
> > SOFTWARE/OS VERSIONS
> > Linux/KDE Plasma: 
> > Operating System: KDE neon Testing Edition
> > KDE Plasma Version: 5.27.6
> > KDE Frameworks Version: 5.109.0
> > Qt Version: 5.15.10
> > Kernel Version: 5.19.0-46-generic (64-bit)
> > Graphics Platform: X11
> 
> Solution:
> sudo apt install xfdesktop4
> Enter to XFCE DE
> sudo apt-get -o Dpkg::Options::="--force-overwrite" install libphonon4qt5-4
> From xfce4-terminal
> sudo pkcon refresh -p -v && sudo pkcon get-updates -p -v && sudo pkcon
> update -p -v && poweroff

This is not suitable for me, I don't want to install/use a XFCE desktop but a working KDE one. So, imho this problem should be solved upstream, if possible. Moreover, KDE neon, as per KDE info, is designed for KDE and not for other environments.
Comment 13 EBiForE 2023-09-04 20:53:38 UTC
(In reply to Valter Mura from comment #12)
> (In reply to EBiForE from comment #11)
> > (In reply to Valter Mura from comment #0)
> > > SUMMARY
> > > ***
> > > NOTE: If you are reporting a crash, please try to attach a backtrace with
> > > debug symbols.
> > > See
> > > https://community.kde.org/Guidelines_and_HOWTOs/Debugging/
> > > How_to_create_useful_crash_reports
> > > ***
> > > 
> > > 
> > > STEPS TO REPRODUCE
> > > 1. Try to install the latest updates, both Discover and Muon Package manager
> > > 2. 
> > > 3. 
> > > 
> > > OBSERVED RESULT
> > > The system returns the following error:
> > > "Error while updating:
> > > /var/cache/apt/archives/qt5-phonon_4%3a4.11.1+p22.04+tunstable+git20230725.
> > > 0737-0_amd64.deb
> > > trying to overwrite '/usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4.11.1',
> > > which is also in package libphonon4qt5-4"
> > > 
> > > Than the system quits from the update.
> > > 
> > > SOFTWARE/OS VERSIONS
> > > Linux/KDE Plasma: 
> > > Operating System: KDE neon Testing Edition
> > > KDE Plasma Version: 5.27.6
> > > KDE Frameworks Version: 5.109.0
> > > Qt Version: 5.15.10
> > > Kernel Version: 5.19.0-46-generic (64-bit)
> > > Graphics Platform: X11
> > 
> > Solution:
> > sudo apt install xfdesktop4
> > Enter to XFCE DE
> > sudo apt-get -o Dpkg::Options::="--force-overwrite" install libphonon4qt5-4
> > From xfce4-terminal
> > sudo pkcon refresh -p -v && sudo pkcon get-updates -p -v && sudo pkcon
> > update -p -v && poweroff
> 
> This is not suitable for me, I don't want to install/use a XFCE desktop but
> a working KDE one. So, imho this problem should be solved upstream, if
> possible. Moreover, KDE neon, as per KDE info, is designed for KDE and not
> for other environments.

You can uninstall xfce after update, this is not a solution, this is a workaround by me
Comment 14 Valter Mura 2023-09-10 18:09:47 UTC
Hi,

what can I do to solve this issue???

The error returned is still: "/var/cache/apt/archives/libphonon4qt5-4_4%3a4.11.1+p22.04+vstable+git20230830.0151-0_amd64.deb
trying to overwrite '/usr/lib/x86_64-linux-gnu/libphonon4qt5.so.4.11.1', which is also in package qt5-phonon 4:4.11.1+p22.04+tunstable+git20230804.0221-0"

Can I install safely something or do I have to wait for the intervention of some packager?

I get the error both on Muon and Discover, while pkcon does nothing (stays still)