Bug 471154 - Accessibility KCM asks for save/discard changes even when nothing was changed
Summary: Accessibility KCM asks for save/discard changes even when nothing was changed
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_accessibility (show other bugs)
Version: 5.90.0
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-06-17 13:19 UTC by Patrick Silva
Modified: 2023-12-02 15:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: https://invent.kde.org/plasma/plasma-desktop/-/commit/3d9d4e9016015a07f7652456c0873f9f5582ad01


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2023-06-17 13:19:41 UTC
STEPS TO REPRODUCE
1. open Accessibility KCM
2. close System Settings without changing anything
3. 

OBSERVED RESULT
the save/discard prompt shows up

EXPECTED RESULT
System Settings closes


SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.27.80
KDE Frameworks Version: 5.240.0
Qt Version: 6.5.1
Graphics Platform: Wayland
Comment 1 Nate Graham 2023-06-21 04:54:58 UTC
Cannot reproduce this one.
Comment 2 Justin Zobel 2023-06-21 12:36:30 UTC
I can confirm this one when opening Accessibility from Kickoff. If I open it via kcmshell6 access it works fine.
Comment 3 Bug Janitor Service 2023-09-04 13:07:36 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1692
Comment 4 Nate Graham 2023-09-05 17:57:39 UTC
Fixed by Jürgen Dev with https://invent.kde.org/plasma/plasma-desktop/-/commit/3d9d4e9016015a07f7652456c0873f9f5582ad01 for Plasma 5.27.8 too.
Comment 5 Patrick Silva 2023-11-30 11:23:47 UTC
Can reproduce again.

Operating System: Arch Linux 
KDE Plasma Version: 5.90.0
KDE Frameworks Version: 5.246.0
Qt Version: 6.6.1
Graphics Platform: Wayland
Comment 6 Nate Graham 2023-11-30 20:22:24 UTC
Can't reproduce again.
Comment 7 youkai 2023-12-02 15:35:46 UTC
(In reply to Patrick Silva from comment #5)
> Can reproduce again.
> 
> Operating System: Arch Linux 
> KDE Plasma Version: 5.90.0
> KDE Frameworks Version: 5.246.0
> Qt Version: 6.6.1
> Graphics Platform: Wayland

Really strange. I don't particularly see any relevant changes to the kcm.

Could you look at ~/.config/kaccessrc before (if it exists), and after applying the unprompted changes.
Comment 8 Patrick Silva 2023-12-02 15:43:21 UTC
I clicked on "Default" then on "Apply" buttons. Now the bug is not reproducible anymore.