Bug 470799 - Recent regression: KVM switch setup - toggling back to KDE system causes black wallpaper, floating appmenu, missing Task Manager
Summary: Recent regression: KVM switch setup - toggling back to KDE system causes blac...
Status: RESOLVED DUPLICATE of bug 467074
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.27.5
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-06-08 18:30 UTC by LabHamster
Modified: 2023-06-09 21:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of primary monitor with hovering appmenu, missing Task Manager, black background (69.88 KB, image/png)
2023-06-08 18:30 UTC, LabHamster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LabHamster 2023-06-08 18:30:10 UTC
Created attachment 159543 [details]
Screenshot of primary monitor with hovering appmenu, missing Task Manager, black background

SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***
In a multi-monitor setup with KVM switch, when switching from another system (Windows 11 Enterprise) to a KDE system, desktop wallpaper becomes black on both monitors, appmenu is floating, and Task Manager is missing on both monitors. This seems to be a regression as it worked fine about 1-2 months ago.

If you reboot the KDE system, the issues disappear until the next time you toggle the KVM switch back

STEPS TO REPRODUCE
1. With the KVM switch toggled to the KDE system, toggle to another system
2. Wait 30 seconds
3. Toggle back to the KDE system

OBSERVED RESULT
The appmenu floats when brought up by pressing the Meta/Win key, the Task Manager is missing, and the background is black

EXPECTED RESULT
Background is not black, no floating appmenu, no missing Task Manager

SOFTWARE/OS VERSIONS
Operating System: Fedora Linux Kinoite 38.20230608.0
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Kernel Version: 6.3.5-200.fc38.x86_64 (64-bit)
Graphics Platform: Wayland
Graphics Processor: Mesa Intel® Arc

ADDITIONAL INFORMATION

Primary Monitor:
27", tried in both 1920x1080 and 4K resolutions

Secondary Monitor:
22", 1920x1080

KVM Switch:
Level 1 Techs: 1.4 Display Port KVM Switch - Dual Monitor - Two Computer   (SKU: SQ8628028)
Comment 1 Nate Graham 2023-06-09 20:05:47 UTC
Sounds like exactly the issue seen in Bug 467074. Probably the KVM tells Plasma that its screen has gone into energy saving mode when you switch it to showing the Windows 11 system, triggering the bug describes in Bug 467074.

Screens are hard.

*** This bug has been marked as a duplicate of bug 467074 ***
Comment 2 LabHamster 2023-06-09 21:03:09 UTC
(In reply to Nate Graham from comment #1)
> Sounds like exactly the issue seen in Bug 467074. Probably the KVM tells
> Plasma that its screen has gone into energy saving mode when you switch it
> to showing the Windows 11 system, triggering the bug describes in Bug 467074.
> 
> Screens are hard.
> 
> *** This bug has been marked as a duplicate of bug 467074 ***

Agree that this sounds like a duplicate; thanks for the spot. 

I know some KVM switchs have a built-in DisplayPort repeater so the source doesn't try to do any screen/energy saving stuff which means w/ a repeater toggling displays between systems is very quick because the source system doesn't try to rebuild the screen. This of course comes at a higher price, potentially reduced performance due to less room on the PCB, etc. I know my KVM switch does not have a built-in repeater.

I'll see where I can help with the other ticket. For anyone else who finds this issue, Level1Techs do sell a repeater, but I can't speak to if it fixes this issue: https://store.level1techs.com/products/dp-repeater-hdmi-splitter