Bug 470605 - Firewall KCM broken in Plasma 6 due to use of QQC1 TableView, which doesn't exist anymore
Summary: Firewall KCM broken in Plasma 6 due to use of QQC1 TableView, which doesn't e...
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_firewall (show other bugs)
Version: 5.27.4
Platform: Other Linux
: NOR grave
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: qt6
: 477511 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-06-03 20:15 UTC by Nate Graham
Modified: 2023-11-27 15:58 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2023-06-03 20:15:34 UTC
$ systemsettings kcm_firewall
"file:///home/nate/kde/usr6/share/kpackage/kcms/kcm_firewall/contents/ui/main.qml" 
 "Error loading QML file.\n9: module \"QtQuick.Controls\" version 1.4 is not installed\n"

It needs that import because it uses the QQC1 TableView. We need to port this to the new QQC2 one in Qt 6--or something else.
Comment 1 Justin Zobel 2023-06-05 03:10:33 UTC
Can confirm. Also tracked here https://invent.kde.org/teams/frameworks-devs/kf6-workboard/-/issues/12
Comment 2 Bug Janitor Service 2023-08-29 20:33:34 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-firewall/-/merge_requests/74
Comment 3 Patrick Silva 2023-11-25 19:51:14 UTC
*** Bug 477511 has been marked as a duplicate of this bug. ***
Comment 4 David Redondo 2023-11-27 15:58:26 UTC
Git commit 2b58d3b573f7825d6bb126a2938924aa485ebb78 by David Redondo, on behalf of Guillaume Frognier.
Committed on 27/11/2023 at 16:57.
Pushed by davidre into branch 'master'.

Port form  QQC1 TableView to the new one

This ports the old Quick Controls 1 TableViews to the new ones.
To do so the list models interfacing with QML are converted
to table models. In general the role based QML code has been
converted to work with columns.
Co-authored-by: David Redondo <kde@david-redondo.de>
FIXED-IN:6.0

M  +35   -18   kcm/backends/netstat/conectionsmodel.cpp
M  +6    -6    kcm/backends/netstat/conectionsmodel.h
M  +46   -26   kcm/core/loglistmodel.cpp
M  +15   -16   kcm/core/loglistmodel.h
M  +34   -17   kcm/core/rulelistmodel.cpp
M  +6    -6    kcm/core/rulelistmodel.h
M  +14   -14   kcm/ui/ConnectionsView.qml
M  +15   -15   kcm/ui/LogsView.qml
M  +103  -72   kcm/ui/ViewBase.qml
M  +94   -82   kcm/ui/main.qml

https://invent.kde.org/plasma/plasma-firewall/-/commit/2b58d3b573f7825d6bb126a2938924aa485ebb78