Bug 470001 - KMM crashes on startup on Window
Summary: KMM crashes on startup on Window
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Applications
Component: general (show other bugs)
Version: 5.1.3
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 469836 469955 469956 470638 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-05-19 14:38 UTC by ticengo
Modified: 2023-06-11 23:13 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ticengo 2023-05-19 14:38:10 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. I installed kmymoney-5.1-1772-windows-cl-msvc2019-x86_64
2. when kmm is launched, I can see the tips window then it closed and nothing else append
   Windows task manager wrote "kmm interrupted task"
3.  I tried with this verson too kmymoney-5.1-1771-windows-cl-msvc2019-x86_64: same thing

OBSERVED RESULT
Unable to launch KMM on windows 10 with 64 bits processor.
(previous version kmymoney-5.1-960-windows-msvc2019_64-cl was OK)

EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows:  10 on 64 bits processor
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Jack 2023-05-19 22:17:39 UTC
*** Bug 469956 has been marked as a duplicate of this bug. ***
Comment 2 Jack 2023-05-19 22:27:55 UTC
Altering the title - it's not the Tip of the Day which causes the crash.  The crash still happens even if the Tips are turned off.  It happens after the splash screen is displayed, and before the data file is opened (as it crashes even with -n.)  We now have reports for both Win10 and Win11.

I managed to set up Win10 in a VM, and gdb ends with:

Found an 'html' folder with CSS files: "C:/Program Files/KMyMoney/bin/data/kmymoney//html/"
Could not find QtWebEngineProcess.exe
gdb: unknown target exception 0xc0000409 at 0x7fff3b2f05b8

Thread 1 received signal ?, Unknown signal.
0x00007fff3b2f05b8 in Qt5Core!?qmljsDebugArgumentsString@QCoreApplicationPrivate@@QEAA?AVQString@@XZ () from C:\Program Files\KMyMoney\bin\Qt5Core.dll

I need to figure out why gdb isn't finding the debug symbols, which I thought I unpacked in the appropriate location.  Without them, the backtrace seems pretty useless.
Comment 3 Maurizio Pozzobon 2023-06-02 13:40:56 UTC
I also experience this bug, on Win 10, I'm running kmymoney.5.1.1786
This is the output I get before crash, is there a way that I can help you find the cause?

 WebConnect: Try to connect to WebConnect server
WebConnect: Connect to server failed
WebConnect: Running in server mode
Found html dir(s): ("C:/Program Files/KMyMoney/bin/data/kmymoney//html/")
Found an 'html' folder with CSS files: "C:/Program Files/KMyMoney/bin/data/kmymoney//html/"
System icon theme as reported by QT:  ""
kf.config.core: Use of KConfigWatcher without DBus support. You will not receive updates
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
kf.xmlgui: Shortcut for action  "transaction_select_all" "Select all" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "transaction_assign_number" "Assign next number" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "transaction_new" "New" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "account_reconcile" "Reconcile..." set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "view_hide_reconciled_transactions" "Hide reconciled transactions" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "view_show_transaction_detail" "Show Transaction Detail" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "edit_find_transaction" "Find transaction..." set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "view_show_all_accounts" "Show all accounts" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "view_hide_unused_categories" "Hide unused categories" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "transaction_mark_reconciled" "Reconciled" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "transaction_mark_cleared" "Cleared" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
kf.xmlgui: Shortcut for action  "transaction_mark_toggle" "Toggle" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/budgetview.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/checkprinting.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/csvexporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/csvimporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/forecastview.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/gncimporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/icalendarexporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/kcm_checkprinting.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/kcm_csvimporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/kcm_forecastview.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/kcm_icalendarexporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/kcm_qif.dll" Validity false
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/kcm_reportsview.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/kcm_xmlstorage.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/konlinetasks_sepa.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/ofximporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/onlinejoboutboxview.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/qifexporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/qifimporter.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/reconciliationreport.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/reportsview.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/sqlstorage.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/woob.dll" Validity true
Located plugin "C:/Program Files/KMyMoney/bin/kmymoney/xmlstorage.dll" Validity true
Loading "C:/Program Files/KMyMoney/bin/kmymoney/budgetview.dll"
Plugins: budgetview loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/checkprinting.dll"
Plugins: checkprinting loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/csvexporter.dll"
Plugins: csvexporter loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/csvimporter.dll"
Plugins: csvimporter loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/forecastview.dll"
Plugins: forecastview loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/gncimporter.dll"
Plugins: gncimporter loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/icalendarexporter.dll"
Plugins: icalendarexporter loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/ofximporter.dll"
Plugins: ofximporter loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/onlinejoboutboxview.dll"
Plugins: onlinejoboutboxview loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/qifexporter.dll"
Plugins: qifexporter loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/qifimporter.dll"
Plugins: qifimporter loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/reconciliationreport.dll"
Plugins: reconciliation report loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/reportsview.dll"
Plugins: reportsview loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/sqlstorage.dll"
Plugins: sqlstorage loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/woob.dll"
Python interpreter found: 3.10.8 (tags/v3.10.8:aaaf517, Oct 11 2022, 16:50:30) [MSC v.1933 64 bit (AMD64)]
Python interpreter module search paths: "C:\\Python310\\python310.zip;C:\\Python310\\Lib\\;C:\\Python310\\DLLs\\;C:\\Program Files\\KMyMoney\\bin"
Saved a copy of the embedded :/plugins/woob/kmymoneywoob.py script as "C:/Users/Maurizio/AppData/Local/Temp/kmymoneylzDrDd.py"
Attempt to load the "kmymoneylzDrDd" Python module from "C:/Users/Maurizio/AppData/Local/Temp"
The dependency 'sys' Python module loaded successfully
The 'path' Python variable loaded successfully
"kmymoneylzDrDd" Python module failed to load
Traceback (most recent call last):
  File "C:\Users/Maurizio/AppData/Local/Temp\kmymoneylzDrDd.py", line 13, in <module>
    from woob.core import Woob
ModuleNotFoundError: No module named 'woob'
Plugins: woob loaded
Loading "C:/Program Files/KMyMoney/bin/kmymoney/xmlstorage.dll"
Plugins: xmlstorage loaded
Found html dir(s): ("C:/Program Files/KMyMoney/bin/data/kmymoney//html/")
Found an 'html' folder with CSS files: "C:/Program Files/KMyMoney/bin/data/kmymoney//html/"
Found template dir(s): ("C:/Program Files/KMyMoney/bin/data/kmymoney/templates")
Could not find QtWebEngineProcess.exe
Comment 4 Jack 2023-06-02 16:20:36 UTC
It appears that the problem is within the build process.  That last line implies that some component is missing, which should be included in the install package.  Unfortunately, debugging that process goes rather slowly.  As soon as there is any progress, it will be posted here.
Comment 5 Jack 2023-06-04 18:57:14 UTC
*** Bug 470638 has been marked as a duplicate of this bug. ***
Comment 6 Thomas Baumgart 2023-06-06 12:25:45 UTC
*** Bug 469836 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Baumgart 2023-06-06 12:28:22 UTC
Problem is fixed in build system. Build 1791 does not show the problem anymore.
Comment 8 Robert Blackwell 2023-06-06 12:32:48 UTC
Thomas, thank you for your diligent work in this regard. I confirm build 1791 no longer has the problem.
Comment 9 k6lw 2023-06-07 06:13:40 UTC
Confirmed that this version works on both Windows 10 and 11 Pro. Thanks for the quick fix.
Comment 10 Jack 2023-06-11 23:13:55 UTC
*** Bug 469955 has been marked as a duplicate of this bug. ***