Bug 469821 - No volume OSD when opening a file directly
Summary: No volume OSD when opening a file directly
Status: RESOLVED FIXED
Alias: None
Product: Haruna
Classification: Applications
Component: generic (show other bugs)
Version: 0.11.0
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: george fb
URL:
Keywords:
: 469969 470706 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-05-15 21:09 UTC by Colin J Thomson
Modified: 2023-06-06 17:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin J Thomson 2023-05-15 21:09:00 UTC
SUMMARY
When opening a file (Audio or video) by clicking on it, for example within Dolphin, there is no OSD when adjusting the volume with the mouse wheel or keyboard shortcut in either a Normal or Full screen.

If you open Haruna first and then select a file to play or a URL from the menu the OSD works OK, normal and Full Screen.

***
STEPS TO REPRODUCE
1.  Open a video/Audio from Dolphin, via Mouse click or Keyboard

OBSERVED RESULT
The file plays fine but there is no OSD when changing the volume with mouse or keyboard shortcut.

EXPECTED RESULT
There should be the OSD, especially in Full Screen

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
Operating System: Fedora Linux 38
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
KDE Gear 23.04.1
Qt Version: 5.15.9
Kernel Version: 6.3.2-200.fc38.x86_64 (64-bit)
Graphics Platform: Wayland

ADDITIONAL INFORMATION

Works fine in the previous releases, rolled back to 0.10.3 to test.
Comment 1 george fb 2023-05-15 21:14:00 UTC
Git commit 43b5dc346c045dedf6d95d90b5a9685d06e089ab by George Florea Bănuș.
Committed on 15/05/2023 at 21:13.
Pushed by georgefb into branch 'master'.

MpvVideo: always activate osd

M  +1    -1    src/qml/MpvVideo.qml

https://invent.kde.org/multimedia/haruna/commit/43b5dc346c045dedf6d95d90b5a9685d06e089ab
Comment 2 george fb 2023-05-19 01:05:54 UTC
*** Bug 469969 has been marked as a duplicate of this bug. ***
Comment 3 Colin J Thomson 2023-05-29 14:47:52 UTC
(In reply to george fb from comment #1)
> Git commit 43b5dc346c045dedf6d95d90b5a9685d06e089ab by George Florea Bănuș.
> Committed on 15/05/2023 at 21:13.
> Pushed by georgefb into branch 'master'.
> 
> MpvVideo: always activate osd
> 
> M  +1    -1    src/qml/MpvVideo.qml
> 
> https://invent.kde.org/multimedia/haruna/commit/
> 43b5dc346c045dedf6d95d90b5a9685d06e089ab

Confirmed fixed, thank you.
Comment 4 Alessandro Astone 2023-06-06 17:24:43 UTC
*** Bug 470706 has been marked as a duplicate of this bug. ***
Comment 5 Alessandro Astone 2023-06-06 17:35:06 UTC
Actually now the bug is the opposite, the OSD is only shown if starting Haruna with a video argument.

Probably caused by this early return: https://invent.kde.org/multimedia/haruna/-/commit/43b5dc346c045dedf6d95d90b5a9685d06e089ab#3db4d05674a50f44220d06a3f75b8267daf01b10_59_58
Comment 6 Alessandro Astone 2023-06-06 17:39:56 UTC
(In reply to Alessandro Astone from comment #5)
> Actually now the bug is the opposite, the OSD is only shown if starting
> Haruna with a video argument.
> 
> Probably caused by this early return:
> https://invent.kde.org/multimedia/haruna/-/commit/
> 43b5dc346c045dedf6d95d90b5a9685d06e089ab#3db4d05674a50f44220d06a3f75b8267daf0
> 1b10_59_58

Aaand that's already fixed: https://invent.kde.org/multimedia/haruna/-/commit/a09ee1bf2347b6e1152ef8508d7f952766fbbb9c
Unfortunately not in 0.11.1