Bug 467372 - Today's update fails with unmet dependencies
Summary: Today's update fails with unmet dependencies
Status: RESOLVED FIXED
Alias: None
Product: neon
Classification: KDE Neon
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Neon Bugs
URL:
Keywords:
: 467404 467453 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-03-14 22:43 UTC by Peter
Modified: 2023-03-29 20:33 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment the same as comment (52.45 KB, application/vnd.oasis.opendocument.text)
2023-03-17 06:02 UTC, flamenco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2023-03-14 22:43:24 UTC
SUMMARY

Today's update with Discover fails with unmet dependencies.  

Thanks and regards, as ever.  

STEPS TO REPRODUCE
1.  Run Discover.Update
2. 
3. 

OBSERVED RESULT

Error message as per 'Additional Information', below.  

EXPECTED RESULT

OS updates without a hitch.  

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: KDE Neon 5.27
(available in About System)
KDE Plasma Version:  5.27.2
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8

ADDITIONAL INFORMATION

Give the following error message .... 

<html>Dependency resolution failed:<br/><br/>The following packages have unmet dependencies:
  neon-desktop: Depends: breeze but it is not going to be installed
                Depends: kde-cli-tools but it is not going to be installed
                Depends: khotkeys but it is not going to be installed
                Depends: kinfocenter but it is not going to be installed
                Depends: kio but it is not going to be installed
                Depends: kio-extras but it is not going to be installed
                Depends: kmenuedit but it is not going to be installed
                Depends: kwin-wayland but it is not going to be installed
                Depends: kwin-x11 but it is not going to be installed
                Depends: powerdevil but it is not going to be installed
                Depends: sddm-theme-breeze but it is not going to be installed
                Depends: systemsettings but it is not going to be installed
                Recommends: ark but it is not going to be installed
                Recommends: bluedevil but it is not going to be installed
                Recommends: dolphin but it is not going to be installed
                Recommends: dolphin-plugins but it is not going to be installed
                Recommends: drkonqi-pk-debug-installer but it is not going to be installed
                Recommends: flatpak-kcm but it is not going to be installed
                Recommends: frameworkintegration but it is not going to be installed
                Recommends: gwenview but it is not going to be installed
                Recommends: kde-config-gtk-style but it is not going to be installed
                Recommends: kde-config-plymouth but it is not going to be installed
                Recommends: kde-config-sddm but it is not going to be installed
                Recommends: kde-nomodeset but it is not going to be installed
                Recommends: kde-spectacle but it is not going to be installed
                Recommends: kdegraphics-thumbnailers but it is not going to be installed
                Recommends: kdialog but it is not going to be installed
                Recommends: kio-admin but it is not going to be installed
                Recommends: konsole but it is not going to be installed
                Recommends: kscreen but it is not going to be installed
                Recommends: kwin-addons but it is not going to be installed
                Recommends: kwrite but it is not going to be installed
                Recommends: milou but it is not going to be installed
                Recommends: okular but it is not going to be installed
                Recommends: plasma-browser-integration but it is not going to be installed
                Recommends: plasma-calendar-addons but it is not going to be installed
                Recommends: plasma-dataengines-addons but it is not going to be installed
                Recommends: plasma-discover but it is not going to be installed
                Recommends: plasma-disks but it is not going to be installed
                Recommends: plasma-firewall but it is not going to be installed
                Recommends: plasma-nm but it is not going to be installed
                Recommends: plasma-pa but it is not going to be installed
                Recommends: plasma-runners-addons but it is not going to be installed
                Recommends: plasma-systemmonitor but it is not going to be installed
                Recommends: plasma-thunderbolt but it is not going to be installed
                Recommends: plasma-vault but it is not going to be installed
                Recommends: plasma-wallpapers-addons but it is not going to be installed
                Recommends: plasma-welcome but it is not going to be installed
                Recommends: plasma-widgets-addons but it is not going to be installed
                Recommends: plasma-workspace-wayland but it is not going to be installed
                Recommends: polkit-kde-agent-1 but it is not going to be installed
                Recommends: print-manager but it is not going to be installed
  qml-module-org-kde-newstuff: Depends: qml-module-org-kde-kcm but it is not going to be installed
                               Depends: qml-module-org-kde-kirigami2 (&gt;= 5.49) but it is not going to be installed
                               Depends: libkf5newstuffcore5 but it is not going to be installed
  plasma-desktop: Depends: breeze (&gt;= 4:5.14) but it is not going to be installed
                  Depends: kactivitymanagerd (&gt;= 5.14) but it is not going to be installed
                  Depends: kde-cli-tools (&gt;= 4:5.14) but it is not going to be installed
                  Depends: kio but it is not going to be installed
                  Depends: plasma-framework but it is not going to be installed
                  Depends: plasma-integration (&gt;= 5.14) but it is not going to be installed
                  Depends: plasma-thunderbolt but it is not going to be installed
                  Depends: plasma-workspace (&gt;= 4:5.14) but it is not going to be installed
                  Depends: polkit-kde-agent-1 (&gt;= 4:5.14) but it is not going to be installed
                  Depends: qml-module-org-kde-draganddrop but it is not going to be installed
                  Depends: qml-module-org-kde-kcoreaddons but it is not going to be installed
                  Depends: qml-module-org-kde-kirigami2 (&gt;= 5.54.0~) but it is not going to be installed
                  Depends: qml-module-org-kde-kquickcontrols but it is not going to be installed
                  Depends: qml-module-org-kde-kquickcontrolsaddons but it is not going to be installed
                  Depends: qml-module-org-kde-kwindowsystem but it is not going to be installed
                  Depends: libkf5bookmarks5 but it is not going to be installed
                  Depends: libkf5completion5 but it is not going to be installed
                  Depends: libkf5configgui5 but it is not going to be installed
                  Depends: libkf5configwidgets5 but it is not going to be installed
                  Depends: libkf5iconthemes5 but it is not going to be installed
                  Depends: libkf5kcmutils5 but it is not going to be installed
                  Depends: libkf5kdelibs4support5 but it is not going to be installed
                  Depends: libkf5kiofilewidgets5 but it is not going to be installed
                  Depends: libkf5kiowidgets5 but it is not going to be installed
                  Depends: libkf5newstuffcore5 but it is not going to be installed
                  Depends: libkf5notifyconfig5 but it is not going to be installed
                  Depends: libkf5plasma5 (&gt;= 5.103.0) but it is not going to be installed
                  Depends: libkf5plasmaquick5 (&gt;= 5.103.0) but it is not going to be installed
                  Depends: libkf5quickaddons5 but it is not going to be installed
                  Depends: libkf5runner5 but it is not going to be installed
                  Depends: libkf5sonnetui5 but it is not going to be installed
                  Depends: libkf5xmlgui5 but it is not going to be installed
                  Depends: libnotificationmanager1 but it is not going to be installed
                  Recommends: bluedevil (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kde-config-gtk-style (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kde-config-screenlocker (&gt;= 5.14) but it is not going to be installed
                  Recommends: kde-config-sddm (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kde-style-oxygen-qt5 (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kgamma5 (&gt;= 5.14) but it is not going to be installed
                  Recommends: khelpcenter but it is not going to be installed
                  Recommends: khotkeys (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kinfocenter (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kio-extras but it is not going to be installed
                  Recommends: kmenuedit (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kscreen (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kwin-x11 (&gt;= 4:5.14) but it is not going to be installed or
                              kwin
                  Recommends: plasma-discover (&gt;= 5.14) but it is not going to be installed
                  Recommends: plasma-pa (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: powerdevil (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: systemsettings (&gt;= 4:5.14) but it is not going to be installed
</html>
Comment 1 Carlos De Maine 2023-03-15 22:18:33 UTC
please try on the cli:
sudo apt install libturbojpeg
then
sudo apt install libjpeg8
then 
sudo apt dist-upgrade
ensure to review the installs and removes before pressing (y) - agreeing to the upgrade
Comment 2 Riccardo Robecchi 2023-03-16 09:57:57 UTC
(In reply to Carlos De Maine from comment #1)
> please try on the cli:
> sudo apt install libturbojpeg
> then
> sudo apt install libjpeg8
> then 
> sudo apt dist-upgrade
> ensure to review the installs and removes before pressing (y) - agreeing to
> the upgrade

In my case, it still tries to remove half the system. I find it noteworthy that I had to manually remove libjpeg-turbo8 using dpkg, then install libjpeg8, otherwise it would complain that the two packages conflicted.
Comment 3 lnxusr 2023-03-16 11:18:20 UTC
(In reply to Riccardo Robecchi from comment #2)
> (In reply to Carlos De Maine from comment #1)
> > please try on the cli:
> > sudo apt install libturbojpeg
> > then
> > sudo apt install libjpeg8
> > then 
> > sudo apt dist-upgrade
> > ensure to review the installs and removes before pressing (y) - agreeing to
> > the upgrade
> 
> In my case, it still tries to remove half the system. I find it noteworthy
> that I had to manually remove libjpeg-turbo8 using dpkg, then install
> libjpeg8, otherwise it would complain that the two packages conflicted.

This workaround also didn't work for me, and I had the same problem with ibjpeg-turbo8 .  The workaround found in bug #467379, however, worked like a charm.
Comment 4 Antonio Rojas 2023-03-16 18:40:41 UTC
*** Bug 467404 has been marked as a duplicate of this bug. ***
Comment 5 Antonio Rojas 2023-03-16 18:40:57 UTC
*** Bug 467453 has been marked as a duplicate of this bug. ***
Comment 6 flamenco 2023-03-17 06:02:36 UTC
Created attachment 157351 [details]
attachment the same as comment

<html>Dependency resolution failed:<br/><br/>The following packages have unmet dependencies:
  neon-desktop: Depends: breeze but it is not going to be installed
                Depends: kde-cli-tools but it is not going to be installed
                Depends: khotkeys but it is not going to be installed
                Depends: kinfocenter but it is not going to be installed
                Depends: kio but it is not going to be installed
                Depends: kio-extras but it is not going to be installed
                Depends: kmenuedit but it is not going to be installed
                Depends: kwin-wayland but it is not going to be installed
                Depends: kwin-x11 but it is not going to be installed
                Depends: powerdevil but it is not going to be installed
                Depends: sddm-theme-breeze but it is not going to be installed
                Depends: systemsettings but it is not going to be installed
                Recommends: ark but it is not going to be installed
                Recommends: bluedevil but it is not going to be installed
                Recommends: dolphin but it is not going to be installed
                Recommends: dolphin-plugins but it is not going to be installed
                Recommends: drkonqi-pk-debug-installer but it is not going to be installed
                Recommends: flatpak-kcm but it is not going to be installed
                Recommends: frameworkintegration but it is not going to be installed
                Recommends: fwupd-signed but it is not going to be installed
                Recommends: gwenview but it is not going to be installed
                Recommends: kde-config-gtk-style but it is not going to be installed
                Recommends: kde-config-plymouth but it is not going to be installed
                Recommends: kde-config-sddm but it is not going to be installed
                Recommends: kde-nomodeset but it is not going to be installed
                Recommends: kde-spectacle but it is not going to be installed
                Recommends: kdegraphics-thumbnailers but it is not going to be installed
                Recommends: kdialog but it is not going to be installed
                Recommends: kio-admin but it is not going to be installed
                Recommends: konsole but it is not going to be installed
                Recommends: kscreen but it is not going to be installed
                Recommends: kwin-addons but it is not going to be installed
                Recommends: kwrite but it is not going to be installed
                Recommends: milou but it is not going to be installed
                Recommends: okular but it is not going to be installed
                Recommends: plasma-browser-integration but it is not going to be installed
                Recommends: plasma-calendar-addons but it is not going to be installed
                Recommends: plasma-dataengines-addons but it is not going to be installed
                Recommends: plasma-discover but it is not going to be installed
                Recommends: plasma-disks but it is not going to be installed
                Recommends: plasma-firewall but it is not going to be installed
                Recommends: plasma-nm but it is not going to be installed
                Recommends: plasma-pa but it is not going to be installed
                Recommends: plasma-runners-addons but it is not going to be installed
                Recommends: plasma-systemmonitor but it is not going to be installed
                Recommends: plasma-thunderbolt but it is not going to be installed
                Recommends: plasma-vault but it is not going to be installed
                Recommends: plasma-wallpapers-addons but it is not going to be installed
                Recommends: plasma-welcome but it is not going to be installed
                Recommends: plasma-widgets-addons but it is not going to be installed
                Recommends: plasma-workspace-wayland but it is not going to be installed
                Recommends: polkit-kde-agent-1 but it is not going to be installed
                Recommends: print-manager but it is not going to be installed
  qml-module-org-kde-newstuff: Depends: qml-module-org-kde-kcm but it is not going to be installed
                               Depends: qml-module-org-kde-kirigami2 (&gt;= 5.49) but it is not going to be installed
                               Depends: libkf5newstuffcore5 but it is not going to be installed
  plasma-desktop: Depends: breeze (&gt;= 4:5.14) but it is not going to be installed
                  Depends: kactivitymanagerd (&gt;= 5.14) but it is not going to be installed
                  Depends: kde-cli-tools (&gt;= 4:5.14) but it is not going to be installed
                  Depends: kio but it is not going to be installed
                  Depends: plasma-framework but it is not going to be installed
                  Depends: plasma-integration (&gt;= 5.14) but it is not going to be installed
                  Depends: plasma-thunderbolt but it is not going to be installed
                  Depends: plasma-workspace (&gt;= 4:5.14) but it is not going to be installed
                  Depends: polkit-kde-agent-1 (&gt;= 4:5.14) but it is not going to be installed
                  Depends: qml-module-org-kde-draganddrop but it is not going to be installed
                  Depends: qml-module-org-kde-kcoreaddons but it is not going to be installed
                  Depends: qml-module-org-kde-kirigami2 (&gt;= 5.54.0~) but it is not going to be installed
                  Depends: qml-module-org-kde-kquickcontrols but it is not going to be installed
                  Depends: qml-module-org-kde-kquickcontrolsaddons but it is not going to be installed
                  Depends: qml-module-org-kde-kwindowsystem but it is not going to be installed
                  Depends: libkf5bookmarks5 but it is not going to be installed
                  Depends: libkf5completion5 but it is not going to be installed
                  Depends: libkf5configgui5 but it is not going to be installed
                  Depends: libkf5configwidgets5 but it is not going to be installed
                  Depends: libkf5iconthemes5 but it is not going to be installed
                  Depends: libkf5kcmutils5 but it is not going to be installed
                  Depends: libkf5kdelibs4support5 but it is not going to be installed
                  Depends: libkf5kiofilewidgets5 but it is not going to be installed
                  Depends: libkf5kiowidgets5 but it is not going to be installed
                  Depends: libkf5newstuffcore5 but it is not going to be installed
                  Depends: libkf5notifyconfig5 but it is not going to be installed
                  Depends: libkf5plasma5 (&gt;= 5.103.0) but it is not going to be installed
                  Depends: libkf5plasmaquick5 (&gt;= 5.103.0) but it is not going to be installed
                  Depends: libkf5quickaddons5 but it is not going to be installed
                  Depends: libkf5runner5 but it is not going to be installed
                  Depends: libkf5sonnetui5 but it is not going to be installed
                  Depends: libkf5xmlgui5 but it is not going to be installed
                  Depends: libnotificationmanager1 but it is not going to be installed
                  Recommends: bluedevil (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kde-config-gtk-style (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kde-config-screenlocker (&gt;= 5.14) but it is not going to be installed
                  Recommends: kde-config-sddm (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kde-style-oxygen-qt5 (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kgamma5 (&gt;= 5.14) but it is not going to be installed
                  Recommends: khelpcenter but it is not going to be installed
                  Recommends: khotkeys (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kinfocenter (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kio-extras but it is not going to be installed
                  Recommends: kmenuedit (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kscreen (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: kwin-x11 (&gt;= 4:5.14) but it is not going to be installed or
                              kwin
                  Recommends: plasma-discover (&gt;= 5.14) but it is not going to be installed
                  Recommends: plasma-pa (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: powerdevil (&gt;= 4:5.14) but it is not going to be installed
                  Recommends: systemsettings (&gt;= 4:5.14) but it is not going to be installed
</html>
Comment 7 Jaime Antonio Gonzalez 2023-03-19 03:06:20 UTC
I got a new round of updates on my main computer and now it deleted Lutris, at least it kept my games and preferences, so reinstalling Lutris did the trick. Looks like everything that is related to wine is suffering the side effects of whatever is going on.
Comment 8 Valter Mura 2023-03-19 13:09:52 UTC
I confirm there's a problem. Discover unistalled Gwenview with the latest updates and I cannot reinstall it. If I try, I receive the following error: "Dependency resolution failed"

My system:
Operating System: KDE neon Testing Edition
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.8
Kernel Version: 5.19.0-35-generic (64-bit)
Graphics Platform: X11
Graphics Processor: NVE7
Comment 9 Peter 2023-03-21 21:38:15 UTC
Latest updates seem to have worked OK, so the bug is resolved from my point of view.  

Thanks, as always.
Comment 10 lnxusr 2023-03-29 20:33:43 UTC
It's back as of today's update.  I get the following:

The following packages have unmet dependencies:
  neon-desktop: Depends: kinfocenter but it is not going to be installed
                Depends: kio-extras but it is not going to be installed
                Depends: powerdevil but it is not going to be installed
                Depends: sddm-theme-breeze but it is not going to be installed
                Recommends: dolphin but it is not going to be installed
                Recommends: dolphin-plugins but it is not going to be installed
                Recommends: gwenview but it is not going to be installed
                Recommends: hplip but it is not going to be installed
                Recommends: konsole but it is not going to be installed
                Recommends: okular but it is not going to be installed
                Recommends: phonon4qt5-backend-vlc but it is not going to be installed
                Recommends: plasma-widgets-addons but it is not going to be installed
                Recommends: plasma-workspace-wayland but it is not going to be installed
                Recommends: vlc but it is not going to be installed
  plasma-desktop: Depends: plasma-workspace (>= 4:5.14) but it is not going to be installed
                  Depends: qml-module-org-kde-pipewire but it is not going to be installed
                  Depends: libkf5notifyconfig5 but it is not going to be installed
                  Depends: phonon4qt5 but it is not going to be installed
                  Recommends: khelpcenter but it is not going to be installed
                  Recommends: kinfocenter (>= 4:5.14) but it is not going to be installed
                  Recommends: kio-extras but it is not going to be installed
                  Recommends: powerdevil (>= 4:5.14) but it is not going to be installed