Bug 466679 - Discover can't handle UEFI Secure Boot firmware updates ("THE INPUT IS NOT OF CABINET FORMAT" error)
Summary: Discover can't handle UEFI Secure Boot firmware updates ("THE INPUT IS NOT OF...
Status: RESOLVED DUPLICATE of bug 468379
Alias: None
Product: Discover
Classification: Applications
Component: fwupd Backend (show other bugs)
Version: 5.24.7
Platform: Ubuntu Linux
: NOR major
Target Milestone: ---
Assignee: Plasma Bugs List
Depends on:
Reported: 2023-03-01 20:49 UTC by Dave92f1
Modified: 2023-04-14 01:22 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Dave92f1 2023-03-01 20:49:20 UTC

Discover will report an available UEFI Secure Boot firmware update, but can't install it and doesn't offer any guidance as to how to install manually.

If you try to install with Discover you get "THE INPUT IS NOT OF CABINET FORMAT".

Since Discover is advertised as being the central place to install & update software, it should ideally handle this or at least give guidance as to how to resolve.

I found that the following installs the update - at minimum Discover should tell the user to do this:

        sudo fwupdmgr refresh
        sudo fwupdmgr update

        Then reboot when requested.

Linux/KDE Plasma: Kubuntu 22.04 LTS
Comment 1 Nate Graham 2023-03-02 20:11:37 UTC
So `sudo fwupdmgr update` works? Or does that fail too?
Comment 2 Dave92f1 2023-03-02 20:12:55 UTC
sudo fwupdmgr update worked for me.
Comment 4 Ternomashi 2023-03-18 18:12:39 UTC
On laptop Samsung NP670 there is another error message: "failed to write data to efivarfs: Error writing to file descriptor: Invalid argument". I can also confirm that the problem with "THE INPUT IS NOT OF CABINET FORMAT" can be seen on HP desktop PC UEFI update.
Comment 5 Aleix Pol 2023-04-14 01:22:31 UTC
Pretty sure it's the same issue. Somebody who can reproduce, please try fresh 5.27 branch and report back if the issue is not indeed solved.

*** This bug has been marked as a duplicate of bug 468379 ***