Bug 464876 - Issues adding Environment Variables to flatpak
Summary: Issues adding Environment Variables to flatpak
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_flatpak (show other bugs)
Version: 5.26.90
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 468804 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-01-26 21:32 UTC by Shubham Arora
Modified: 2023-04-22 22:10 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27.5


Attachments
Steps of Reproduction (3.26 MB, video/x-matroska)
2023-01-26 21:32 UTC, Shubham Arora
Details
Steps of Reproduction (3.63 MB, video/x-matroska)
2023-01-26 21:42 UTC, Shubham Arora
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shubham Arora 2023-01-26 21:32:23 UTC
Created attachment 155683 [details]
Steps of Reproduction

SUMMARY/ OBSERVED RESULT
Issue 1: 
1. Add an environment variable. 
2. Try adding a new environment variable. The text within the add new prompt is preserved. 

Issue 2
1. Reopen the flatpak setting after navigating away. 
2. Add another environment variable. The variable is not shown in the UI immediately. 
3. Click apply. 
4. Navigate away and return to the application to see the environment variable successfully added. 

EXPECTED RESULT
Environment variables are immediately Added

SOFTWARE/OS VERSIONS
Operating System: EndeavourOS 
KDE Plasma Version: 5.26.90
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.8
Kernel Version: 6.1.8-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 24 × AMD Ryzen 9 3900X 12-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: AMD Radeon RX 580 Series
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: X570 AORUS ELITE
Comment 1 David Edmundson 2023-01-26 21:36:23 UTC
Is this the right attachment? It appears to show tiling issues
Comment 2 Shubham Arora 2023-01-26 21:42:12 UTC
Created attachment 155684 [details]
Steps of Reproduction

Upload correct video.
Comment 3 ratijas 2023-04-20 13:27:54 UTC
There were multiple bugs you hit at once.

The one that new entries might not show up until you switch apps back and forth is due to a wrong usage of model signals, fixed via https://invent.kde.org/plasma/flatpak-kcm/-/merge_requests/91

The other one that lets users enter the same variable name twice was fixed by introducing validators in the model and (partially) in the UI by disabling "OK" button when input is invalid, via https://invent.kde.org/plasma/flatpak-kcm/-/merge_requests/107

The same MR introduces new logic to clear input before the dialog is shows, so you don't get previous values still there. However, another MR, https://invent.kde.org/plasma/flatpak-kcm/-/merge_requests/109, is going to make those dialogs even better and create them on demand, so no "clear text" hacks would be needed anymore.
Comment 4 ratijas 2023-04-22 22:10:13 UTC
*** Bug 468804 has been marked as a duplicate of this bug. ***