Bug 464248 - crash while copying from 1 external drive to another when paused, disconnected both drives, then reconnected, resume copy task, crashed
Summary: crash while copying from 1 external drive to another when paused, disconnecte...
Status: RESOLVED DUPLICATE of bug 448532
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 22.12.1
Platform: Arch Linux Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2023-01-13 17:52 UTC by jst4ne
Modified: 2023-11-27 10:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jst4ne 2023-01-13 17:52:55 UTC
Application: dolphin (22.12.1)

Qt Version: 5.15.8
Frameworks Version: 5.101.0
Operating System: Linux 6.1.4-arch1-1 x86_64
Windowing System: X11
Distribution: "Arch Linux"
DrKonqi: 5.26.5 [KCrashBackend]

-- Information about the crash:
-have 2 external drives connected
-copy (many files) from 1 external to the other external in 2 seperate copy tasks
-pause 1 task (dont pause the other)
-disconnect both external drives (by accident loss of power, without proper umount, etc...)
-reconnect both external drives (also mount again)
-task 2 (the one not paused) says there was an error, but gives option to retry/skip/cancel... if picked retry, the copying task continues with no problems
-task 1 (the one paused) reports no error with copying at first, but when resumed from pause, it concludes the copy task with a crash (not completing the copying)

expected result:
-task 1 when resumed from pause also restarts the copying where it was last paused, or at least reports similiar error to task 2 (that was not paused) with option to continue the copy task

(I know the situation is very edgy and I'd never even stumble upon it if it wasn't for an accident, but if active copy task can be recovered (was a nice surprise), then the paused should also have same logic)

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  0x00007fb12179e708 in QWidget::graphicsEffect (this=this@entry=0x55d90cbabd10) at kernel/qwidget.cpp:5091
#7  0x00007fb12179f1f6 in QWidgetPrivate::invalidateGraphicsEffectsRecursively (this=<optimized out>) at kernel/qwidget.cpp:1950
#8  0x00007fb12179f28b in QWidgetPrivate::setDirtyOpaqueRegion (this=this@entry=0x55d90caf4080) at kernel/qwidget.cpp:1968
#9  0x00007fb1217a2561 in QWidgetPrivate::updateIsOpaque (this=0x55d90caf4080) at kernel/qwidget.cpp:2154
#10 0x00007fb1217b00ab in QWidget::setParent (this=0x55d90d2559f0, parent=<optimized out>, f=...) at kernel/qwidget.cpp:10533
#11 0x00007fb12179d22a in QWidgetPrivate::init (this=0x55d90caf4080, parentWidget=<optimized out>, f=...) at kernel/qwidget.cpp:1046
#12 0x00007fb1219731f3 in QDialog::QDialog (this=<optimized out>, parent=<optimized out>, f=..., this=<optimized out>, parent=<optimized out>, f=...) at dialogs/qdialog.cpp:400
#13 0x00007fb122a5947e in KIO::SkipDialog::SkipDialog (this=<optimized out>, parent=<optimized out>, options=..., _error_text=..., this=<optimized out>, parent=<optimized out>, options=..., _error_text=...) at /usr/include/qt/QtCore/qflags.h:120
#14 0x00007fb122a59c86 in KIO::WidgetsAskUserActionHandler::askUserSkip (this=0x55d90d265870, job=0x55d90d19a8b0, options=..., errorText=...) at /usr/src/debug/kio/kio-5.101.0/src/widgets/widgetsaskuseractionhandler.cpp:176
#15 0x00007fb1227d5de0 in KIO::CopyJobPrivate::slotResultErrorCopyingFiles (this=<optimized out>, job=0x55d90d1b4d60) at /usr/src/debug/kio/kio-5.101.0/src/core/copyjob.cpp:1766
#16 0x00007fb120abda91 in QtPrivate::QSlotObjectBase::call (a=<optimized out>, r=<optimized out>, this=<optimized out>, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#17 doActivate<false> (sender=0x55d90d1b4d60, signal_index=6, argv=0x7ffc5751db40) at kernel/qobject.cpp:3923
#18 0x00007fb1220525ea in KJob::result (this=this@entry=0x55d90d1b4d60, _t1=<optimized out>, _t1@entry=0x55d90d1b4d60, _t2=...) at /usr/src/debug/kcoreaddons/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#19 0x00007fb12205884c in KJob::finishJob (this=0x55d90d1b4d60, emitResult=<optimized out>) at /usr/src/debug/kcoreaddons/kcoreaddons-5.101.0/src/lib/jobs/kjob.cpp:98
#20 0x00007fb120abda91 in QtPrivate::QSlotObjectBase::call (a=<optimized out>, r=<optimized out>, this=<optimized out>, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#21 doActivate<false> (sender=0x55d90cf88b80, signal_index=6, argv=0x7ffc5751dc70) at kernel/qobject.cpp:3923
#22 0x00007fb1220525ea in KJob::result (this=this@entry=0x55d90cf88b80, _t1=<optimized out>, _t1@entry=0x55d90cf88b80, _t2=...) at /usr/src/debug/kcoreaddons/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#23 0x00007fb12205884c in KJob::finishJob (this=0x55d90cf88b80, emitResult=<optimized out>) at /usr/src/debug/kcoreaddons/kcoreaddons-5.101.0/src/lib/jobs/kjob.cpp:98
#24 0x00007fb120abda91 in QtPrivate::QSlotObjectBase::call (a=<optimized out>, r=<optimized out>, this=<optimized out>, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#25 doActivate<false> (sender=0x55d90d256870, signal_index=5, argv=0x7ffc5751dda0) at kernel/qobject.cpp:3923
#26 0x00007fb1227fa37b in KIO::SlaveInterface::error (this=this@entry=0x55d90d256870, _t1=<optimized out>, _t2=...) at /usr/src/debug/kio/build/src/core/KF5KIOCore_autogen/include/moc_slaveinterface.cpp:452
#27 0x00007fb122802b10 in KIO::SlaveInterface::dispatch (this=0x55d90d256870, _cmd=102, rawdata=...) at /usr/src/debug/kio/kio-5.101.0/src/core/slaveinterface.cpp:181
#28 0x00007fb1227fa19a in KIO::SlaveInterface::dispatch (this=0x55d90d256870) at /usr/src/debug/kio/kio-5.101.0/src/core/slaveinterface.cpp:78
#29 0x00007fb1227fca42 in KIO::Slave::gotInput (this=0x55d90d256870) at /usr/src/debug/kio/kio-5.101.0/src/core/slave.cpp:346
#30 0x00007fb120abda91 in QtPrivate::QSlotObjectBase::call (a=<optimized out>, r=<optimized out>, this=<optimized out>, this=<optimized out>, r=<optimized out>, a=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#31 doActivate<false> (sender=0x55d90d2443b0, signal_index=3, argv=0x7ffc5751dfc0) at kernel/qobject.cpp:3923
#32 0x00007fb120ab0bd0 in QObject::event (this=0x55d90d2443b0, e=0x7fb114015220) at kernel/qobject.cpp:1347
#33 0x00007fb121778b5c in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55d90d2443b0, e=0x7fb114015220) at kernel/qapplication.cpp:3640
#34 0x00007fb120a8cf98 in QCoreApplication::notifyInternal2 (receiver=0x55d90d2443b0, event=0x7fb114015220) at kernel/qcoreapplication.cpp:1064
#35 0x00007fb120a8daa3 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55d90c7746a0) at kernel/qcoreapplication.cpp:1821
#36 0x00007fb120ad3ea8 in postEventSourceDispatch (s=0x55d90c84afb0) at kernel/qeventdispatcher_glib.cpp:277
#37 0x00007fb11ed1687b in g_main_dispatch (context=0x7fb114005010) at ../glib/glib/gmain.c:3454
#38 g_main_context_dispatch (context=0x7fb114005010) at ../glib/glib/gmain.c:4172
#39 0x00007fb11ed6dc89 in g_main_context_iterate.constprop.0 (context=0x7fb114005010, block=1, dispatch=1, self=<optimized out>) at ../glib/glib/gmain.c:4248
#40 0x00007fb11ed15132 in g_main_context_iteration (context=0x7fb114005010, may_block=1) at ../glib/glib/gmain.c:4313
#41 0x00007fb120ad7c8c in QEventDispatcherGlib::processEvents (this=0x55d90c84c710, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#42 0x00007fb120a8574c in QEventLoop::exec (this=0x7ffc5751e440, flags=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#43 0x00007fb120a90269 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#44 0x00007fb120f39fe2 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1870
#45 0x00007fb121776f2a in QApplication::exec () at kernel/qapplication.cpp:2832
#46 0x000055d90b508f53 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/dolphin/dolphin-22.12.1/src/main.cpp:258
[Inferior 1 (process 3203) detached]

Reported using DrKonqi
Comment 1 Akseli Lahtinen 2023-11-27 10:41:40 UTC

*** This bug has been marked as a duplicate of bug 448532 ***