Bug 463078 - Audio in animation timeline doesn't sync with the animation
Summary: Audio in animation timeline doesn't sync with the animation
Status: RESOLVED DUPLICATE of bug 450449
Alias: None
Product: krita
Classification: Applications
Component: Animation (show other bugs)
Version: unspecified
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-12-15 17:52 UTC by noodle lol
Modified: 2022-12-29 22:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noodle lol 2022-12-15 17:52:15 UTC
SUMMARY

STEPS TO REPRODUCE
1. Open the "animation timeline" docker
2. Have an audio imported
3. Make a keyframe to reference the audio discrepancy
4. Select any frames after the 4th one
6. Select play

OBSERVED RESULT
After replaying the audio, when you compare a certain audio part, I noticed that the audio does not match the timeline. It seems that the audio's beginning is cut when played from the 5th frame. Ranging from 1st to 4th frame the audio seems to be perfectly in sync with the timeline.

EXPECTED RESULT
Well, the audio was supposed to match the timeline...

SOFTWARE/OS VERSIONS
Windows: 11

ADDITIONAL INFORMATION
It really ruins the animation experience with krita.
It's basically impossible to use this software's feature properly in my case.
I've also heard this issue has been bothering other users for a long while
Comment 1 Emmet O'Neill 2022-12-29 22:56:40 UTC
Hi there. 

Right now it's a known bug that audio doesn't work very well and has sync issues, among other things.
I can only tell you that a new audio system that fixes most of these issues is being worked on and should land in the first half of 2023.

Thanks for the report and sorry about the bug.
Emmet

*** This bug has been marked as a duplicate of bug 450449 ***