Bug 463061 - qBittorrent System tray icon flashes constantly on KDE Plasma
Summary: qBittorrent System tray icon flashes constantly on KDE Plasma
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: libplasma (show other bugs)
Version: 5.101.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2022-12-15 10:38 UTC by mozo
Modified: 2023-01-18 21:34 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.103


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mozo 2022-12-15 10:38:10 UTC
SUMMARY
Since KDE Frameworks 5.101.0 the qBittorrent system tray icon flashes constantly on KDE Plasma when there's speed change. See the video:
https://youtu.be/y8L_3YNNqoo
I tried different qBittorrent versions and the flashing is always there so apparently it's not a qBittorrent bug.


STEPS TO REPRODUCE
1. Start qBittorrent and minimize it to the system tray. There should be some speed transfer.
2. 
3. 

OBSERVED RESULT
qBittorrent system tray icon flashes.

EXPECTED RESULT
qBittorrent system icon should not flash.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Comment 1 George 2022-12-15 13:01:33 UTC
I can reproduce, and confirm it's quite annoying.

Arch/Manjaro 22.0.0, kernel 6.1
KDE Plasma: 5.26.4
KDE Frameworks: 5.101.0
Qt: 5.15.7
Comment 2 Pesho 2022-12-17 05:37:59 UTC
The issue is reproducible for me. The same behavior can be seen in KTorrent system tray icon.

Operating System: Arch Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Graphics Platform: X11
Comment 3 fifi 2022-12-17 06:38:20 UTC
The issue is reproducible for me. 

Operating System: Arch Linux/EndeavourOS
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Graphics Platform: X11
Comment 4 mozo 2022-12-17 22:24:47 UTC
One more app that is affected - HFS:
https://www.rejetto.com/hfs/

As soon as there's a transfer, the HFS icon also start to flash.
Comment 5 Rawk 2022-12-29 11:24:02 UTC
I'm having this issue with RSIBreak.

Operating System: Arch Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Graphics Platform: X11
Comment 6 mozo 2023-01-04 09:32:52 UTC
Plasma 5.26.5 - the problem is still here.
Comment 7 Nate Graham 2023-01-09 19:37:08 UTC
Icon rendering regression?

OP, are you 100% sure this issue was introduced by Frameworks 5.101, and not any other update that might have happened to get installed around the same time?
Comment 8 mozo 2023-01-09 21:49:06 UTC
It may be coincidence, I'm not sure but it appeared at this time. Just Alt+Tab on a white background and you'll see it. We all have it.
Comment 9 mozo 2023-01-09 21:51:21 UTC
Sorry, I wrote about bug 463061.
So, It may be coincidence, I'm not sure but it appeared at this time. Alt+Tab is for bug 463061.
https://bugs.kde.org/show_bug.cgi?id=463024
Comment 10 Fushan Wen 2023-01-10 01:11:52 UTC
C(In reply to Nate Graham from comment #7)
> Icon rendering regression?
> 
> OP, are you 100% sure this issue was introduced by Frameworks 5.101, and not
> any other update that might have happened to get installed around the same
> time?

Caused by https://invent.kde.org/frameworks/plasma-framework/-/commit/801772616953ab7017722489de0c342ac9c1ed75
Comment 11 mozo 2023-01-10 08:37:18 UTC
Thank you mr. Wen! Do you know when the fix will be applied?
Comment 12 Arjen Hiemstra 2023-01-17 03:35:49 UTC
Git commit a4bd3879780a02ff653f273a4235e247108729ca by Arjen Hiemstra.
Committed on 16/01/2023 at 16:00.
Pushed by ngraham into branch 'master'.

iconitem: Adjust fade animation to not flicker as much

As it turns out, mix(old texture, new texture, animation value) does
actually result in a different visual from simply blending the two
textures on top of each other, because the old texture first gets
blended with the underlying color. This results in some of the
underlying color bleeding through, which can cause flickering if the two
textures are almost the same. To avoid this, change the animation
slightly so that rather than crossfading, we first fade in the new
texture then fade out the old texture. This doesn't cause a whole lot of
visual difference for two completely different textures, but removes the
flickering when they are very similar.
Related: bug 463685

M  +6    -2    src/declarativeimports/core/iconitem.cpp

https://invent.kde.org/frameworks/plasma-framework/commit/a4bd3879780a02ff653f273a4235e247108729ca
Comment 13 Nate Graham 2023-01-17 03:46:52 UTC
Git commit 3fcd43a6ed03d0aff188dfc190cc464c34302a1f by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 17/01/2023 at 03:44.
Pushed by ngraham into branch 'kf5'.

iconitem: Adjust fade animation to not flicker as much

As it turns out, mix(old texture, new texture, animation value) does
actually result in a different visual from simply blending the two
textures on top of each other, because the old texture first gets
blended with the underlying color. This results in some of the
underlying color bleeding through, which can cause flickering if the two
textures are almost the same. To avoid this, change the animation
slightly so that rather than crossfading, we first fade in the new
texture then fade out the old texture. This doesn't cause a whole lot of
visual difference for two completely different textures, but removes the
flickering when they are very similar.
Related: bug 463685

M  +6    -2    src/declarativeimports/core/iconitem.cpp

https://invent.kde.org/frameworks/plasma-framework/commit/3fcd43a6ed03d0aff188dfc190cc464c34302a1f
Comment 14 mozo 2023-01-17 08:30:56 UTC
Thank you!