Bug 463033 - Nvidia stopped working after recent driver update
Summary: Nvidia stopped working after recent driver update
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: 5.26.4
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-12-14 11:06 UTC by Richard Knausenberger
Modified: 2023-01-09 13:06 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Knausenberger 2022-12-14 11:06:08 UTC
SUMMARY
***
Utilization, VRAM, temperature, etc. worked with my Nvidia gpu before, but since a recent driver update (I'm now on 525.60.11, but it broke 2 or 3 updates before) it's no longer working. It still detects my Nvidia gpu (GPU1), but it shows 0% utilization, 0°C temperature, 0 MB VRAM, etc.

The desktop applet ("system monitor") is affected, too (same behavior there).

Nvidia X Server Settings and the nvidia-smi still show the utilization, vram usage, temperature, etc. correctly. Other applications (like Unigine Valley benchmark) still show the correct values.
***


STEPS TO REPRODUCE
1. Update nvidia driver
2. try to show utilization/vram/temperature with Systemmonitor application or desktop applet

OBSERVED RESULT
Shows 0%, 0°C, 0MB, etc.

EXPECTED RESULT
Shows the real values (e.g. 90%, 71°C, 2000MB)

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: openSUSE Tumbleweed
(available in About System)
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.100.0
Qt Version: 5.15.7

ADDITIONAL INFORMATION
Tested with multiple gpus (GTX 1080, RTX 3070)
Comment 1 David Edmundson 2023-01-04 17:54:40 UTC

*** This bug has been marked as a duplicate of bug 461389 ***
Comment 2 David Redondo 2023-01-09 13:06:50 UTC
Git commit 00b1f21b0fe8164c4bcda9109e08bf7a69c0ce24 by David Redondo.
Committed on 09/01/2023 at 12:48.
Pushed by davidre into branch 'master'.

plugins/gpu: Use pci address to identify nvidia gpus

The DRM index does not correspond to the nvidia index. Identify
cards by their pci addresses and derive the index from the position
in the query.
Related: bug 461361
FIXED-IN:5.27

M  +1    -1    plugins/gpu/LinuxBackend.cpp
M  +19   -13   plugins/gpu/LinuxNvidiaGpu.cpp
M  +5    -2    plugins/gpu/LinuxNvidiaGpu.h
M  +2    -0    plugins/gpu/NvidiaSmiProcess.cpp
M  +1    -0    plugins/gpu/NvidiaSmiProcess.h
M  +1    -1    plugins/network/NetworkManagerBackend.cpp

https://invent.kde.org/plasma/ksystemstats/commit/00b1f21b0fe8164c4bcda9109e08bf7a69c0ce24