Bug 462972 - Window resize of Spotify (Snap) lets system freeze completely
Summary: Window resize of Spotify (Snap) lets system freeze completely
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.26.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 463001 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-12-12 21:02 UTC by viduq
Modified: 2023-01-06 14:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description viduq 2022-12-12 21:02:40 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. In a wayland session (with backports installed) open the snap Spotify application.
2. Grab the window on the right edge (not the corner) to resize it and make it as small as possible (move mouse to the left).

OBSERVED RESULT
System freezes completely. Only reset helps. 

EXPECTED RESULT
Nothing should happen.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.100.0
Qt Version: 5.15.6

ADDITIONAL INFORMATION
Happens in Wayland session in Spotify (Snap) application.
Comment 1 Vlad Zahorodnii 2022-12-13 10:08:16 UTC
Please post the output of

  qdbus org.kde.KWin /KWin supportInformation
Comment 2 viduq 2022-12-16 09:09:04 UTC
Please found the output here:
https://invent.kde.org/-/snippets/2451
Comment 3 Vlad Zahorodnii 2023-01-06 09:12:07 UTC
Can't reproduce. I think it's been fixed by https://invent.kde.org/plasma/kwin/-/commit/b095f51035b04c3ac15b6686bc61a0f85b35d4ea. Reopen if it's reproducible in 5.27
Comment 4 Vlad Zahorodnii 2023-01-06 09:27:29 UTC
*** Bug 463001 has been marked as a duplicate of this bug. ***