Bug 462840 - Feature Request: Suggest to install distro-specific packages for missing VPN plugins
Summary: Feature Request: Suggest to install distro-specific packages for missing VPN ...
Status: RESOLVED FIXED
Alias: None
Product: plasma-nm
Classification: Plasma
Component: general (show other bugs)
Version: master
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-12-10 08:02 UTC by ratijas
Modified: 2022-12-23 02:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments
NetworkManager is missing support for 'openvpn' VPN connections (68.49 KB, image/png)
2022-12-10 08:02 UTC, ratijas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ratijas 2022-12-10 08:02:22 UTC
Created attachment 154470 [details]
NetworkManager is missing support for 'openvpn' VPN connections

SUMMARY

Network Manager could be a bit more helpful when required VPN support packages are missing.

STEPS TO REPRODUCE
1. Freshly installed minimal system, like Arch with base KDE/Plasma desktop package (from the new archinstall script)
2. Import OpenVPN certificate.
3. Try to connect to this OpenVPN connection.

OBSERVED RESULT

Notification says:

> NetworkManager is missing support for 'openvpn' VPN connections. Please use the package manager to install it. 

EXPECTED RESULT

When I was connecting an Android phone for the first time, applet suggested me installing Camera app to make "import photos" action available. I'd expect something similar for OpenVPN and other VPN backends too.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: git-master
Qt Version: 5.15.7
Kernel Version: 6.0.11-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-8565U CPU @ 1.80GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Manufacturer: LENOVO
Product Name: 20QD003CRT
System Version: ThinkPad X1 Carbon 7th
Comment 1 Nicolas Fella 2022-12-19 14:26:51 UTC
Git commit 5ce6ea4ab65407ec668c277fb27372738ee56e24 by Nicolas Fella.
Committed on 19/12/2022 at 14:22.
Pushed by nicolasfella into branch 'master'.

Offer installing missing VPN plugins

Currently when a network manager plugin is missing we inform the user that they need to install a plugin, but don't guide them through it

Since the NetworkManager plugins have appstream ids we can use appstream URLs to open Discover to let the user install the needed things

M  +1    -0    libs/CMakeLists.txt
M  +10   -2    libs/handler.cpp

https://invent.kde.org/plasma/plasma-nm/commit/5ce6ea4ab65407ec668c277fb27372738ee56e24