Bug 462203 - Meta key does not always open Plasma’s "main menu"
Summary: Meta key does not always open Plasma’s "main menu"
Status: REPORTED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.26.3
Platform: Debian testing Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-11-24 15:24 UTC by yvan
Modified: 2022-12-21 10:28 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yvan 2022-11-24 15:24:23 UTC
Hi,

SUMMARY

Sometimes, pressing "Meta" keyboard key (the MS Windows logo) does not start the "main menu" (bottom left button of the screen, which I believe is called "Kicker").

Note that I am running Plasma 5.26.0 on Debian testing, and I faced this bug repetitively since I switched to Plasma this summer, so approximately since 5.25.3. I have not tried 5.26.3 yet, but I have read changelogs and I could not find this issue mentioned. I also could not find something similar in already reported issues, but maybe I missed something.

As I use keyboard a lot this is quite annoying, but there is also the Krunner with Alt+F2 as an alternative so this is not a big issue.

STEPS TO REPRODUCE

This bug seems to happens and to stop randomly: sometimes it appears when resuming from sleep, sometimes it is fixed when resuming from sleep. I can not tell if just unlocking screen can trigger / repair the issue. I am almost sure I already tried to reboot and that it did not fix the issue, it just works "when it wants" :-)

I tried to go to the system settings to check configured shortcuts, but:
- I am not sure to find the proper shortcut. I believe it is Activer le composant graphique Lanceur d’application" which should be something like "Activate graphic component Application launcher" in English.
- There is no keyboard shurctut associated with this action, at least when I face this issue.
- I do not find a way to define a "Meta" only shortcut, system insists in wanting a second key press (but this is another issue).
- If I define another keyboard shortcut for this action, this new shortcut never triggers the "main menu".

OBSERVED RESULT

Pressing "Meta" keyboard key sometimes does not open the "main menu".

EXPECTED RESULT

Pressing "Meta" keyboard key should always open the "main menu".

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Debian testing
(available in About System)
KDE Plasma Version: 5.26.0
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6

ADDITIONAL INFORMATION

Please do not hesitate if you want me to do some tests or if you need other information.

Regards,
Yvan
Comment 1 Nate Graham 2022-11-30 04:20:07 UTC
Did you ever use Latte Dock? What output does the following command produce?

`grep -r -A 5 ModifierOnlyShortcuts ~/.config/kwinrc`
Comment 2 yvan 2022-11-30 08:31:07 UTC
Thanks for your answer.

(In reply to Nate Graham from comment #1)
> Did you ever use Latte Dock? What output does the following command produce?
>
> `grep -r -A 5 ModifierOnlyShortcuts ~/.config/kwinrc`

No, I have never used Latte Dock. The above command returns nothing.
Comment 3 Nate Graham 2022-11-30 17:37:01 UTC
That's odd. Since you're using Plasma 5.26, I would expect this to always be working.

Does Kickoff have the Alt+F1 keyboard shortcut set on it? You can see in its configuration window.
Comment 4 yvan 2022-11-30 19:18:43 UTC
(In reply to Nate Graham from comment #3)
> That's odd. Since you're using Plasma 5.26, I would expect this to always be
> working.
> 
> Does Kickoff have the Alt+F1 keyboard shortcut set on it? You can see in its
> configuration window.

Just checked, there is no keyboard shortcut associated with Kickoff. I will add Alt+F1.
Comment 5 Nate Graham 2022-11-30 19:19:32 UTC
Thanks. If you do, does that make the Meta key start working to open it?
Comment 6 yvan 2022-11-30 20:18:46 UTC
(In reply to Nate Graham from comment #5)
> Thanks. If you do, does that make the Meta key start working to open it?

Meta key was working before I added the keyboard shortcut, and it is still working now. I will let you know if the issue comes back or not.
Comment 7 yvan 2022-12-03 11:03:31 UTC
(In reply to yvan from comment #6)
> (In reply to Nate Graham from comment #5)
> > Thanks. If you do, does that make the Meta key start working to open it?
> 
> Meta key was working before I added the keyboard shortcut, and it is still
> working now. I will let you know if the issue comes back or not.

I confirm that the problem still occurs randomly even when a keyboard shortcut (Alt+F1) is associated with Kickoff.
Comment 8 Bug Janitor Service 2022-12-18 05:15:15 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 9 yvan 2022-12-18 16:14:47 UTC
This bug did not occurre for a week, while it was much more frequent before. My system received updates:
- Plasma 5.26.3
- KDE Framework 5.100.0
- Qt 5.15.6

If will let the bug status as "needsinfo", except if the bug reappears.
Comment 10 yvan 2022-12-21 10:28:51 UTC
I encountered the issue again today, so I set the bug status as "REPORTED".