Bug 46215 - double click in title bar icon passed to underlying windows
Summary: double click in title bar icon passed to underlying windows
Status: CLOSED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: FreeBSD Ports FreeBSD
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-08-07 14:33 UTC by T Stadelmann1
Modified: 2002-09-16 14:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description T Stadelmann1 2002-08-07 14:28:45 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kwin
Version:           KDE 3.0.0 
Severity:          normal
Installed from:    FreeBSD Ports
Compiler:          Not Specified
OS:                FreeBSD
OS/Compiler notes: Same problem observed under Linux.

If a double click is performed on the system icon in a KWin title bar to quickly close
the window the second click is passed to the
underlying window including the desktop.

This is counter-intuitive and makes the MWM
window style practically unusable as this
design does not incorporate a separate
close button.

The problem is observed both on Linux and FreeBSD and in KDE version 2.2 as well as 3.0.


(Submitted via bugs.kde.org)
Comment 1 Cristian Tibirna 2002-08-07 16:56:08 UTC
On Wednesday 07 August 2002 10:28 t.stadelmann1@physics.ox.ac.uk wrote:
> Package: kwin
> Version: KDE 3.0.0
> Severity: normal
> Installed from:    FreeBSD Ports
> Compiler:          Not Specified
> OS:                FreeBSD
> OS/Compiler notes: Same problem observed under Linux.
>
> If a double click is performed on the system icon in a KWin title bar to
> quickly close the window the second click is passed to the
> underlying window including the desktop.

The double click-to-close on the icon button was found counter-intuitive and 
broken from a GUI design and HCI standpoint by one of the kwin contributors 
and by the kwin development team. Thus it was disabled and taken out in the 
latest version of KWin from all window styles.

> This is counter-intuitive and makes the MWM
> window style practically unusable as this
> design does not incorporate a separate
> close button.

I'm not aware of an MWM window style in the KDE CVS. If it is a style you get 
from outside the KDE sources please report the unusability issue directly to 
its author as it is less probable that the said author would read the kwin 
bug reports or the kwin mailing list.

On another hand most (if not all!) kwin styles support configurability of 
titlebar buttons thus you can add a close button yourself.

On yet another hand the icon button exposes the operations menu upon click 
thus letting you choose the "Close" command from this menu.

On yet other hand you can always use the "Alt-F4" to close a window.

Thus it is barely possible that a window style become unusable because of 
lack of double-click behavior.

As of the precise bug you report (second click passing through) I saw a few 
reports in the bug report system but I was never able to reproduce it 
myself thus it is difficult for me to investigate the problem.

Thanks


-- 
Cristian Tibirna .. tibirna@sympatico.ca
PhD student .. ctibirna@giref.ulaval.ca .. www.giref.ulaval.ca/~ctibirna
KDE developer .. tibirna@kde.org .. www.kde.org