Bug 46210 - i18n, BiDi: Support for RLM/LRM in HTML pages.
Summary: i18n, BiDi: Support for RLM/LRM in HTML pages.
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml renderer (show other bugs)
Version: 4.0
Platform: unspecified Linux
: NOR normal with 179 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 65604 88164 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-08-07 10:48 UTC by mooffie
Modified: 2007-12-13 22:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test case for LRM being rendered as a space in KHTML 4 (224 bytes, text/html)
2003-09-17 23:08 UTC, Oded Arbel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mooffie 2002-08-07 10:40:05 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           
Version:           4.0 (using KDE 3.0.0 )
Severity:          normal
Installed from:    
Compiler:          gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-110)
OS:                Linux (i686) release 2.4.18-3
OS/Compiler notes: 

Documents written in bidirectional scripts such as Hebrew and Arabic sometimes use two special formatting characters: LRM (left-to-right mark) and RLM (righ-to-left mark). These are invisible characters that only affect the flow of the text. 

However when I view texts with such characters I see empty boxes instead.

Example:

<div dir="rtl">
HEBREW-SCRIPT one. &rlm; two HEBREW-SCRIPT
</div>

Konqueror shows a box in stead of the "&rlm;".

I tried to use both entity references ("&rlm;" and "&lrm;") and numeric references ("&#8207;" and "&#8206;").

(I haven't yet checked other BiDi formatting characters.)

More information can be found in the HTML 4 spec:

http://www.w3.org/TR/html4/struct/dirlang.html#h-8.2.5


(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Oded Arbel 2003-09-17 23:07:24 UTC
I also tried the other BiDi formatting entities and they don't cause a box to 
be shown.  
At least the LRM and RLM marks are doing their job correctly - but they are 
rendered as a space, which is dead wrong - these should be zero width 
characters. 
 
see attached test case. both lines should be identical as the LRM mark should 
have no effect at all. 
 
KDE 3.1.3, Linux, Mandrake RPMs 
Comment 2 Oded Arbel 2003-09-17 23:08:02 UTC
Created attachment 2493 [details]
Test case for LRM being rendered as a space in KHTML 4
Comment 3 Stephan Kulow 2003-11-02 11:29:42 UTC
*** Bug 65604 has been marked as a duplicate of this bug. ***
Comment 4 Sashmit Bhaduri 2004-03-16 07:20:12 UTC
bug still exists in kde 3.2.1
Comment 5 Diego Iastrubni 2004-10-27 20:51:59 UTC
Stephan,

Is this is the same bug as 65604? IMHO no, this is a differnt issue.

This one says the &RLM; is dislplayed as "space" and 65604 says it's rendered onscreen. These are different bugs. (BTW, 88164 is a duplicate of 65604).

still valid in kde3.3.1 BTW.
Comment 6 Stephan Kulow 2004-10-27 21:09:43 UTC
Am Mittwoch 27 Oktober 2004 20:52 schrieb cuco:
> This one says the &RLM; is dislplayed as "space" and 65604 says it's
> rendered onscreen.
It's rendered as box on screen.

Greetings, Stephan

Comment 7 mooffie 2004-10-27 22:15:00 UTC
On Wed, 27 Oct 2004, Stephan Kulow wrote:
> It's rendered as box on screen.

On my system, sometimes it's rendered as a box, sometimes as a little
arrow. It depends on what glyphs the font has there. I don't remember,
though, that it was ever rendered as a space, but since these two
characters should be zero-width charcaters, as long as they are
displayed somehow it's probably a single bug.

Comment 8 Maksim Orlovich 2005-06-16 20:59:30 UTC
*** Bug 88164 has been marked as a duplicate of this bug. ***
Comment 9 Charles Samuels 2006-03-04 20:43:23 UTC
I see this as a space. My font is FreeSans.
Comment 10 Charles Samuels 2006-03-21 10:17:11 UTC
This really should be fixed in Qt.

It's a unicode value so Qt's text rendering should handle it.
Comment 11 Munzir Taha 2006-03-21 12:01:05 UTC
This bug has already been fixed some time ago.
I am now using konqueor 3.5.1 on dapper drake and just tested it and it works properly.
Comment 12 Munzir Taha 2006-03-21 12:24:19 UTC
Sorry, I just read the original bug that says it's displayed as a box but now after reading the other comments that says it displays as a space and considered this the same bug, I want to confirm it's still there :(

In other words, Konqueror still displays an additioal space not displays &rlm; as a space. Which measn &rlm does its job of properly but it should be zero-width which is not the case now
Comment 13 Charles Samuels 2006-04-01 20:35:41 UTC
Using 3.5 branch, I cannot reproduce this anymore. Can anyone confirm?
Comment 14 Munzir Taha 2006-04-04 00:54:37 UTC
Yes, I confirm. 3.5.2 solved the problem of the space BUT now another problem shows. With something like
foo&rlm;bar
one can't select the word bar easily by dragging the mouse pointer over it. So, still the "Support for RLM/LRM in HTML pages" is a bit broken.
Comment 15 Diego Iastrubni 2006-04-06 20:09:24 UTC
This is always the case when mixing LTR/RTL words in a
sentence. It seems those entities are encoded as "ltr" chars.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
Comment 16 Diego Iastrubni 2007-12-13 22:31:11 UTC
I cannot reproduce this any more in KDE4, bye bye.