Bug 461027 - Knewstuff molecules downloading as hotstuff-access.xml
Summary: Knewstuff molecules downloading as hotstuff-access.xml
Status: RESOLVED DUPLICATE of bug 457443
Alias: None
Product: kalzium
Classification: Applications
Component: general (show other bugs)
Version: 22.08.2
Platform: Snap Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kalzium Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-10-26 17:31 UTC by Scarlett Moore
Modified: 2022-10-27 21:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scarlett Moore 2022-10-26 17:31:24 UTC
SUMMARY
***
In the molecule editor.
Downloading new molecules from the get hot new stuff downloads as hotstuff-access.xml in Home/Documents and also 
'/home/scarlett/snap/kalzium/75/.local/share/kalzium/molecules/hotstuff-access and fails to load. Renaming the file to mymolecule.cml allows it to load.
***


STEPS TO REPRODUCE
1. Open molecule editor and Download new molecule, Dialog box shows molecule saved to Home/Documents
2. Dialog box with Could not load molecule
3. Go to Home/Documents and there is a file hotstuff-access.xml - rename to somemolecule.cml
and select Load Molecule select somemolecule.cml and it loads just fine.

OBSERVED RESULT
saving file as wrong name / format

EXPECTED RESULT
Download and install without intervention.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma:  KDE Neon snap application
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
This very well could be a snap problem, but I am unsure where I need to fix the issue. Also possibly a duplicate of https://bugs.kde.org/show_bug.cgi?id=457443
Comment 1 Tuomas Nurmi 2022-10-27 21:14:50 UTC
I can reproduce this from a normal build and install of current git head. After some inspecting, I don't think snap plays a role in this, so I'll mark this duplicate of 457443.  I added some details of my testing & inspection on that report.

*** This bug has been marked as a duplicate of bug 457443 ***