Bug 460139 - On Wayland, Spectacle cannot take screenshots of drawings made with the "Mouse Mark" desktop effect
Summary: On Wayland, Spectacle cannot take screenshots of drawings made with the "Mous...
Status: RESOLVED DUPLICATE of bug 457639
Alias: None
Product: Spectacle
Classification: Applications
Component: General (show other bugs)
Version: 22.08.1
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-10-09 00:15 UTC by bachirgiga@gmail.com
Modified: 2022-10-10 18:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bachirgiga@gmail.com 2022-10-09 00:15:53 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Make sure you are on Wayland
2. Draw anything with the "Mouse Mark" desktop effect
3. Take a screenshot with Spectacle with the drawings in the Area

OBSERVED RESULT
The mouse marks should appear on the screenshot

EXPECTED RESULT
The mouse marks do not appear on the screenshot

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux (kernel 5.19.13-arch1-1)
(available in About System)
KDE Plasma Version: 5.25.90
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2022-10-10 18:54:03 UTC
Fixed in 5.26 already!

*** This bug has been marked as a duplicate of bug 457639 ***