Bug 459938 - xdg-desktop-portal-kde error message appears from Journalctl log every reboot or re-login
Summary: xdg-desktop-portal-kde error message appears from Journalctl log every reboot...
Status: RESOLVED DUPLICATE of bug 458865
Alias: None
Product: xdg-desktop-portal-kde
Classification: Plasma
Component: general (show other bugs)
Version: 5.25.5
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-10-03 13:06 UTC by Zesko
Modified: 2022-11-30 15:11 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zesko 2022-10-03 13:06:27 UTC
SUMMARY

I noticed that the same error message of  xdg-desktop-portal-kde appears in the journalctl log every reboot or re-login.

The error message:
-----------------
xdg-desktop-portal-kde: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
                                                    
                                                    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
systemd-coredump: [🡕] Process 1344 (xdg-desktop-por) of user 963 dumped core.
-----------------

I guess that the issue was caused by update some QT package that would break xdg-desktop-portal-kde.

See the error message in the log:
https://github.com/flatpak/xdg-desktop-portal/issues/896#issuecomment-1265385153

See the same issue:
https://bbs.archlinux.org/viewtopic.php?id=279527

STEPS TO REPRODUCE
1.  Just install any Arch based distro or Manjaro Testing branch in VM 
2.  Update system
3.  Install xdg-desktop-portal-kde
4. Reboot and see the error log in "journalctl -b 0 -p err"


SOFTWARE/OS VERSIONS
- Manjaro Testing branch:
- KDE Plasma Version: 5.25.5
- KDE Frameworks Version: 5.98.0
- Qt Version: 5.15.6
- Graphics Platform: Wayland
- xdg-desktop-portal 1.15.0-1
- xdg-desktop-portal-kde 5.25.5-1
Comment 1 Antonio Rojas 2022-10-03 13:10:04 UTC

*** This bug has been marked as a duplicate of bug 458865 ***