Bug 459848 - System settings crashing when tryign to connect display over usb-c
Summary: System settings crashing when tryign to connect display over usb-c
Status: RESOLVED DUPLICATE of bug 447199
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-09-30 09:26 UTC by Valerio Formato
Modified: 2022-09-30 11:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valerio Formato 2022-09-30 09:26:34 UTC
Application: systemsettings (5.25.5)

Qt Version: 5.15.6
Frameworks Version: 5.98.0
Operating System: Linux 5.19.12-arch1-1 x86_64
Windowing System: X11
Distribution: Arch Linux
DrKonqi: 5.25.5 [KCrashBackend]

-- Information about the crash:
I am trying to connect an external display via Displayport over USB-C and the display keeps disconnecting every two seconds. While trying to setup the system settings app also crashed

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault

[KCrash Handler]
#4  0x00007fa0340290e1 in KScreen::Config::clone() const () from /usr/lib/libKF5Screen.so.7
#5  0x00007fa037f52d39 in ?? () from /usr/lib/qt/plugins/kcms/kcm_kscreen.so
#6  0x00007fa037f539e3 in ?? () from /usr/lib/qt/plugins/kcms/kcm_kscreen.so
#7  0x00007fa042e76784 in ?? () from /usr/lib/libQt5Qml.so.5
#8  0x00007fa042d7a1b7 in ?? () from /usr/lib/libQt5Qml.so.5
#9  0x00007fa042d7c1b2 in QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const () from /usr/lib/libQt5Qml.so.5
#10 0x00007fa042d8f103 in ?? () from /usr/lib/libQt5Qml.so.5
#11 0x00007fa042d955e4 in ?? () from /usr/lib/libQt5Qml.so.5
#12 0x00007fa042d3bd26 in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /usr/lib/libQt5Qml.so.5
#13 0x00007fa042e973fd in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /usr/lib/libQt5Qml.so.5
#14 0x00007fa042e53a31 in QQmlBoundSignalExpression::evaluate(void**) () from /usr/lib/libQt5Qml.so.5
#15 0x00007fa042e549ac in ?? () from /usr/lib/libQt5Qml.so.5
#16 0x00007fa042e766bf in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /usr/lib/libQt5Qml.so.5
#17 0x00007fa0450bd050 in ?? () from /usr/lib/libQt5Core.so.5
#18 0x00007fa03e25edf7 in QQuickAction::triggered(QObject*) () from /usr/lib/libQt5QuickTemplates2.so.5
#19 0x00007fa03e261730 in ?? () from /usr/lib/libQt5QuickTemplates2.so.5
#20 0x00007fa03e261a60 in QQuickAbstractButtonPrivate::trigger() () from /usr/lib/libQt5QuickTemplates2.so.5
#21 0x00007fa03e264a1a in QQuickAbstractButtonPrivate::handleRelease(QPointF const&) () from /usr/lib/libQt5QuickTemplates2.so.5
#22 0x00007fa03e27fc29 in QQuickControl::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5QuickTemplates2.so.5
#23 0x00007fa04343f979 in QQuickItem::event(QEvent*) () from /usr/lib/libQt5Quick.so.5
#24 0x00007fa045d78b1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#25 0x00007fa04508cb88 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#26 0x00007fa04344da85 in QQuickWindowPrivate::deliverMouseEvent(QQuickPointerMouseEvent*) () from /usr/lib/libQt5Quick.so.5
#27 0x00007fa04344e4d2 in QQuickWindowPrivate::deliverPointerEvent(QQuickPointerEvent*) () from /usr/lib/libQt5Quick.so.5
#28 0x00007fa045555c45 in QWindow::event(QEvent*) () from /usr/lib/libQt5Gui.so.5
#29 0x00007fa045d78b1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#30 0x00007fa04508cb88 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#31 0x00007fa043f8bcbe in QQuickWidget::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5QuickWidgets.so.5
#32 0x00007fa045daf6e7 in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#33 0x00007fa045d78b1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#34 0x00007fa045d7e339 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#35 0x00007fa04508cb88 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#36 0x00007fa045d7c337 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /usr/lib/libQt5Widgets.so.5
#37 0x00007fa045dcd3b5 in ?? () from /usr/lib/libQt5Widgets.so.5
#38 0x00007fa045dcf15e in ?? () from /usr/lib/libQt5Widgets.so.5
#39 0x00007fa045d78b1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#40 0x00007fa04508cb88 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#41 0x00007fa04553f13c in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/libQt5Gui.so.5
#42 0x00007fa045528985 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Gui.so.5
#43 0x00007fa03f72f6c0 in ?? () from /usr/lib/libQt5XcbQpa.so.5
#44 0x00007fa04391981b in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0x00007fa04396fec9 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0x00007fa0439180d2 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0x00007fa0450d750c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#48 0x00007fa04508532c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#49 0x00007fa04508fe59 in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#50 0x00005583b6fb7b7a in ?? ()
#51 0x00007fa04483c290 in ?? () from /usr/lib/libc.so.6
#52 0x00007fa04483c34a in __libc_start_main () from /usr/lib/libc.so.6
#53 0x00005583b6fb84d5 in ?? ()
[Inferior 1 (process 1255) detached]

Reported using DrKonqi
This report was filed against 'kde' because the product 'systemsettings' could not be located in Bugzilla. Add it to drkonqi's mappings file!
Comment 1 Nicolas Fella 2022-09-30 11:36:58 UTC

*** This bug has been marked as a duplicate of bug 447199 ***