Bug 45962 - Cervisia ignores compression setting on checkout.
Summary: Cervisia ignores compression setting on checkout.
Status: RESOLVED FIXED
Alias: None
Product: cervisia
Classification: Applications
Component: general (show other bugs)
Version: 1.5rich1
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Loose
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-30 19:48 UTC by ronny
Modified: 2003-06-11 21:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ronny 2002-07-30 19:40:04 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           cervisia
Version:           1.5rich1 (using KDE 3.0.2 )
Severity:          normal
Installed from:    Gentoo
Compiler:          gcc version 3.1
OS:                Linux (i686) release 2.4.18-xfs
OS/Compiler notes: 

When Cervisia is used to checkout a new module (via trick (open different sanbox then checkout) due to other bug that seems to be closed by now) it ignores the compression options made in Settings->Repository->Settings...

When the modules is later updated the settings are respected.



(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Christian Loose 2002-11-26 20:50:23 UTC
The problem is that cervisia doesn't immediately save the changed configuration. 
So the new compression setting isn't in ~/.kde/share/config/cervisiapartrc when 
the checkout action is called (s. cvsClient() in misc.cpp). 
 
I will look into it for KDE 3.1.1. 
Comment 2 Christian Loose 2003-06-11 21:44:16 UTC
Subject: KDE_3_1_BRANCH: kdesdk/cervisia

CVS commit by cloose: 

Backport fix from HEAD for BR #45962: 

Save changed settings in SettingDialog
so that the following checkout can use them.

CCMAIL: 45962-done@bugs.kde.org


  M +5 -0      ChangeLog   1.22.2.10
  M +2 -0      settingsdlg.cpp   1.15.2.1


--- kdesdk/cervisia/ChangeLog  #1.22.2.9:1.22.2.10
@@ -1,2 +1,7 @@
+2003-06-11  Christian Loose <christian.loose@hamburg.de>
+
+        * Fix BR #45962: Save changed settings in SettingDialog
+          so that the following checkout can use them.
+
 2003-06-07  Andr