Bug 459318 - non-default keyboard shortcut should be detected as changed setting
Summary: non-default keyboard shortcut should be detected as changed setting
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_kwintabbox (show other bugs)
Version: master
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 448894 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-09-18 11:05 UTC by Patrick Silva
Modified: 2023-01-12 21:43 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2022-09-18 11:05:28 UTC
SUMMARY
Cannot reproduce with Screen Locking KCM

STEPS TO REPRODUCE
1. open Task Switcher KCM with its default settings
2. set a non-default keyboard shortcut
3. click on 'Highlight changed settings' button

OBSERVED RESULT
the KCM is not highlighted with an orange dot

EXPECTED RESULT
the KCM is highlighted with an orange dot


SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.26.80
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Graphics Platform: Wayland
Comment 1 Nate Graham 2023-01-09 20:29:39 UTC
*** Bug 448894 has been marked as a duplicate of this bug. ***
Comment 2 Bug Janitor Service 2023-01-11 00:18:59 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/3417
Comment 3 Bug Janitor Service 2023-01-11 20:31:49 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/3426
Comment 4 Ismael Asensio 2023-01-12 20:20:51 UTC
Git commit b11416c3968d0a31926afb2a192e1d7e2cbdb004 by Ismael Asensio.
Committed on 12/01/2023 at 18:58.
Pushed by iasensio into branch 'master'.

kcms/tabbox: Highlight non-default shortcuts

This sets the property on the shortcut widgets when they
should get highlighted: the option is selected in System
Settings and the shortcut is not the default.

It requires a change in `KXMLGui/KKeyShortcutWidget` to
actually paint the highlihgt ring.
(commit 47572c26, KF103)

M  +11   -0    src/kcms/tabbox/kwintabboxconfigform.cpp
M  +1    -0    src/kcms/tabbox/kwintabboxconfigform.h
M  +1    -0    src/kcms/tabbox/main.cpp

https://invent.kde.org/plasma/kwin/commit/b11416c3968d0a31926afb2a192e1d7e2cbdb004