Bug 458991 - Do not split url on :
Summary: Do not split url on :
Status: RESOLVED DUPLICATE of bug 452978
Alias: None
Product: konsole
Classification: Applications
Component: kpart (show other bugs)
Version: 22.04.1
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-11 10:28 UTC by Salvo "LtWorf" Tomaselli
Modified: 2022-09-11 12:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the issue (38.78 KB, image/png)
2022-09-11 10:28 UTC, Salvo "LtWorf" Tomaselli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Salvo "LtWorf" Tomaselli 2022-09-11 10:28:01 UTC
Created attachment 151982 [details]
Screenshot of the issue

SUMMARY

STEPS TO REPRODUCE
1. echo http://localhost:8080/index.html
2. Try to trigger the copy-url context menu

OBSERVED RESULT

It will copy http://localhost but not the rest, which is incorrect.


EXPECTED RESULT

It should copy the entire url, not just some part.

SOFTWARE/OS VERSIONS

KDE Frameworks 
Versione 5.97.0

Qt 
Versione 5.15.4 (compilato con 5.15.4)

Il sistema di gestione delle finestre xcb


ADDITIONAL INFORMATION

This used to work fine, this bug was introduced at some point in the past year.
Comment 1 Paul Worrall 2022-09-11 12:19:57 UTC

*** This bug has been marked as a duplicate of bug 452978 ***