This applet has three actions available: Change user, Lock session and Leave. Leave action has the power symbol and in fact, it performs a shutdown request, not a session log out.
So, this is at least, confusing.
On the other hand, I find a Leave=="log out" more appropriate for this applet. I am a developer from LliureX distribution and all users I have talked with agree on this. However, there is room for both "power off" and "leave" actions.
So we used to have this concept of a "default leave action" but we've been steadily moving away from it for the reasons you indicate: it's weird and confusing. We should probably do the same here too.
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kdeplasma-addons/-/merge_requests/230
Git commit 4c8b47ddd0c7d208068954c2b8991cb32e0d7567 by Aleix Pol.
Committed on 09/09/2022 at 16:09.
Pushed by apol into branch 'master'.
userswitcher: log out on the "Leave" option, now called "Log Out"
Instead of shutting down, which doesn't make much sense in the context.
M +7 -3 applets/userswitcher/package/contents/ui/main.qml