Bug 458570 - Crash when exiting dolphin.
Summary: Crash when exiting dolphin.
Status: RESOLVED DUPLICATE of bug 458709
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 21.12.2
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-08-31 20:19 UTC by `{third: "Beedell", first: "Roke"}`{.JSON5}
Modified: 2022-09-12 18:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description `{third: "Beedell", first: "Roke"}`{.JSON5} 2022-08-31 20:19:19 UTC
Application: dolphin (21.12.2)

Qt Version: 5.15.3
Frameworks Version: 5.91.0
Operating System: Linux 5.17.5-300.fc36.x86_64 x86_64
Windowing System: X11
Distribution: Fedora Linux 36 (KDE Plasma)
DrKonqi: 5.24.3 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
I was duplicating files from a modification-protected internal NTFS partition to another internal NTFS partition of the same drive that pbviously was possible to modify.

- Unusual behavior I noticed:
During the previous operation of the host OS, when I allowed the machine to sleep, the screen did not appear subsequently. Consequently, I forcefully reinitialized the machine successfully. However, when the initialization of dolphin that eventually unexpectedly ceased to operate / crashed was initialized, enablement of the menubar caused it to disappear, whereas disablement caused it to appear. This demonstrated corruption of the configuration within memory, so I reinitalized dolphin, and drkonqi appeared immediately.

- Custom settings of the application:
What was described within the previous section.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f989171120a in KJobWidgets::window(KJob*) () from /lib64/libKF5JobWidgets.so.5
#5  0x00007f9891825cf1 in KIO::WidgetsAskUserActionHandler::askUserRename(KJob*, QString const&, QUrl const&, QUrl const&, QFlags<KIO::RenameDialog_Option>, unsigned long long, unsigned long long, QDateTime const&, QDateTime const&, QDateTime const&, QDateTime const&) () from /lib64/libKF5KIOWidgets.so.5
#6  0x00007f98915a1830 in KIO::CopyJob::slotResult(KJob*) () from /lib64/libKF5KIOCore.so.5
#7  0x00007f988fc77726 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#8  0x00007f9890dffb69 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#9  0x00007f9890e03fab in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#10 0x00007f988fc77726 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#11 0x00007f98915c10e0 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib64/libKF5KIOCore.so.5
#12 0x00007f98915ba5aa in KIO::SlaveInterface::dispatch() () from /lib64/libKF5KIOCore.so.5
#13 0x00007f98915bde31 in KIO::Slave::gotInput() () from /lib64/libKF5KIOCore.so.5
#14 0x00007f988fc77726 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#15 0x00007f988fc6e182 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007f98907d9c22 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#17 0x00007f988fc44118 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#18 0x00007f988fc47474 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#19 0x00007f988fc95197 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#20 0x00007f988d8acf4f in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#21 0x00007f988d902168 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#22 0x00007f988d8aa8e0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#23 0x00007f988fc94c8a in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007f988fc42b7a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#25 0x00007f988fc4ac22 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#26 0x000056367585c71d in main ()
[Inferior 1 (process 2298) detached]

The reporter indicates this bug may be a duplicate of or related to bug 440385, bug 408350.

Possible duplicates by query: bug 458111, bug 456223, bug 455657, bug 454133, bug 440385.

Reported using DrKonqi
Comment 1 Nate Graham 2022-09-12 18:17:37 UTC

*** This bug has been marked as a duplicate of bug 364039 ***
Comment 2 Ahmad Samir 2022-09-12 18:45:22 UTC

*** This bug has been marked as a duplicate of bug 458709 ***